aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmax
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/openmax
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/openmax')
-rw-r--r--recipes/openmax/gst-openmax/check.diff11
-rw-r--r--recipes/openmax/gst-openmax_0.10.0.4.bb18
-rw-r--r--recipes/openmax/libomxil-bellagio_0.9.0.bb22
3 files changed, 51 insertions, 0 deletions
diff --git a/recipes/openmax/gst-openmax/check.diff b/recipes/openmax/gst-openmax/check.diff
new file mode 100644
index 0000000000..9e74abf537
--- /dev/null
+++ b/recipes/openmax/gst-openmax/check.diff
@@ -0,0 +1,11 @@
+--- /tmp/gst-check.m4 2008-08-05 17:46:09.000000000 +0200
++++ gst-openmax-0.10.0.4/common/m4/gst-check.m4 2008-08-05 17:46:29.000000000 +0200
+@@ -114,7 +114,7 @@
+
+ AC_DEFUN([AG_GST_CHECK_GST_CHECK],
+ [
+- AG_GST_CHECK_MODULES(GST_CHECK, gstreamer-check-[$1], [$2],
++ AG_GST_CHECK_MODULES(GST_CHECK, gstreamer-check, [$2],
+ [GStreamer Check unittest Library], [$3])
+ ])
+
diff --git a/recipes/openmax/gst-openmax_0.10.0.4.bb b/recipes/openmax/gst-openmax_0.10.0.4.bb
new file mode 100644
index 0000000000..39f35380bc
--- /dev/null
+++ b/recipes/openmax/gst-openmax_0.10.0.4.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "GstOpenMAX is a GStreamer plug-in that allows communication with OpenMAX IL components"
+LICENSE = "LGPLv2"
+DEPENDS = "gstreamer libomxil-bellagio"
+
+SRC_URI = "http://gstreamer.freedesktop.org/src/gst-openmax/pre/gst-openmax-${PV}.tar.bz2 \
+ file://check.diff;patch=1 \
+ "
+
+inherit autotools
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
+FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
+FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.*a"
+
diff --git a/recipes/openmax/libomxil-bellagio_0.9.0.bb b/recipes/openmax/libomxil-bellagio_0.9.0.bb
new file mode 100644
index 0000000000..c7cecc0570
--- /dev/null
+++ b/recipes/openmax/libomxil-bellagio_0.9.0.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "OpenMAX Integration Layer (IL) is a standard API to access Multimedia Components on mobile platforms. It has been defined by the Khronos group."
+LICENSE = "LGPLv2"
+DEPENDS = "alsa-lib ffmpeg \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad', d)}"
+
+PR = "r6"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/omxil/${PN}-${PV}.tar.gz"
+
+inherit autotools
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+
+
+FILES_${PN} += "${libdir}/bellagio/*.so ${libdir}/bellagio/*.la"
+FILES_${PN}-dev += "${libdir}/bellagio/*.a"
+FILES_${PN}-dbg += "${libdir}/bellagio/.debug"
+