aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmoko-3rdparty
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-11-25 11:40:01 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-11-25 13:27:55 +0100
commit2bffdb50983b98f68bb6c01ed3cdcb920ba66843 (patch)
treee161b164026a5cb68d973d73363d6e78585f81b6 /recipes/openmoko-3rdparty
parent425ade7f37ee2fad43b192d7120c105da9986ac3 (diff)
downloadopenembedded-2bffdb50983b98f68bb6c01ed3cdcb920ba66843.tar.gz
minneo: bump SRCREV, add edje-native depends
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/openmoko-3rdparty')
-rw-r--r--recipes/openmoko-3rdparty/minneo/setup.py.patch20
-rw-r--r--recipes/openmoko-3rdparty/minneo_svn.bb13
2 files changed, 30 insertions, 3 deletions
diff --git a/recipes/openmoko-3rdparty/minneo/setup.py.patch b/recipes/openmoko-3rdparty/minneo/setup.py.patch
new file mode 100644
index 0000000000..a7b603322f
--- /dev/null
+++ b/recipes/openmoko-3rdparty/minneo/setup.py.patch
@@ -0,0 +1,20 @@
+--- trunk.orig/setup.py 2010-11-25 13:10:09.000000000 +0100
++++ trunk/setup.py 2010-11-25 13:11:15.000000000 +0100
+@@ -50,13 +50,12 @@
+ for root, dirs, files in os.walk('data/themes/'):
+ if root == 'data/themes/' or root.find('images') >= 0 or root.find('.svn') >= 0:
+ continue
+- for i, file_name in enumerate(files):
++ theme_files = []
++ for file_name in files:
+ if file_name == 'minneo.edj':
+- files[i] = os.path.join(root, file_name)
+- else:
+- del files[i]
++ theme_files.append(os.path.join(root, file_name))
+ theme_name = os.path.basename(root)
+- l.append((os.path.join('share/minneo/themes', theme_name), files))
++ l.append((os.path.join('share/minneo/themes', theme_name), theme_files))
+ return l
+
+ def main():
diff --git a/recipes/openmoko-3rdparty/minneo_svn.bb b/recipes/openmoko-3rdparty/minneo_svn.bb
index 89aac566e6..be90fafd12 100644
--- a/recipes/openmoko-3rdparty/minneo_svn.bb
+++ b/recipes/openmoko-3rdparty/minneo_svn.bb
@@ -5,12 +5,13 @@ AUTHOR = "Valéry Febvre <vfebvre@easter-eggs.com>"
SECTION = "x11/applications"
PRIORITY = "optional"
-SRCREV = "4"
-PV = "1.0.1+svnr${SRCPV}"
+SRCREV = "6"
+PV = "1.0.2+svnr${SRCPV}"
PACKAGE_ARCH = "all"
-SRC_URI = "svn://minneo.googlecode.com/svn;module=trunk;proto=http"
+SRC_URI = "svn://minneo.googlecode.com/svn;module=trunk;proto=http \
+ file://setup.py.patch"
S = "${WORKDIR}/trunk"
inherit distutils
@@ -18,3 +19,9 @@ inherit distutils
FILES_${PN} += "${datadir}/minneo ${datadir}/applications/minneo.desktop ${datadir}/pixmaps/minneo.png"
RDEPENDS_${PN} += "python-audio python-pyalsaaudio python-elementary"
+DEPENDS = "edje-native"
+
+do_compile_append() {
+ cd ${S}/data/themes
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/data/themes/default ${S}/data/themes/default/minneo.edc
+}