aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmoko-3rdparty
diff options
context:
space:
mode:
authorValery Febvre <vfebvre@easter-eggs.com>2010-03-17 15:47:51 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-03-18 14:49:26 +0100
commit091ae3e58b2c658d7d820126fa3ac70923395dc7 (patch)
tree537f30b09b7163dc55f2cd0edb6c0fc3067f1d6d /recipes/openmoko-3rdparty
parent9355f83bdabdfa59df848638d909fbaffda6c23a (diff)
downloadopenembedded-091ae3e58b2c658d7d820126fa3ac70923395dc7.tar.gz
NeoLight: new recipe (version 1.4.0 from svn)
NeoLight turns your mobile device into a flashlight. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/openmoko-3rdparty')
-rw-r--r--recipes/openmoko-3rdparty/neolight_svn.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/openmoko-3rdparty/neolight_svn.bb b/recipes/openmoko-3rdparty/neolight_svn.bb
new file mode 100644
index 0000000000..8568072d85
--- /dev/null
+++ b/recipes/openmoko-3rdparty/neolight_svn.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "An application to turn your mobile device into a flashlight"
+HOMEPAGE = "http://code.google.com/p/neolight/"
+LICENSE = "GPLv3"
+AUTHOR = "Valéry Febvre <vfebvre@easter-eggs.com>"
+SECTION = "x11/applications"
+PRIORITY = "optional"
+
+SRCREV = "16"
+PV = "1.4.0+svnr${SRCPV}"
+
+PACKAGE_ARCH = "all"
+
+SRC_URI = "svn://neolight.googlecode.com/svn;module=trunk;proto=http"
+S = "${WORKDIR}/trunk"
+
+inherit distutils
+
+FILES_${PN} += "${datadir}/neolight ${datadir}/applications/neolight.desktop ${datadir}/pixmaps/neolight.png"
+
+RDEPENDS += "python-edbus python-elementary"
+
+do_compile_prepend() {
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/data ${S}/data/neolight.edc
+}