aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmoko-3rdparty
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-10-07 09:32:59 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-10-07 12:16:20 +0200
commit0b4933c5b122f5c71e2fb18f143f1ffd7981cac9 (patch)
tree723c6c7041c06baf789345614e911ce40e7547e7 /recipes/openmoko-3rdparty
parent2a7b6e70e9373616c4d12abf51cd8d0389e1147e (diff)
downloadopenembedded-0b4933c5b122f5c71e2fb18f143f1ffd7981cac9.tar.gz
mokojeweled: add recipe for new game
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/openmoko-3rdparty')
-rw-r--r--recipes/openmoko-3rdparty/mokojeweled_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/openmoko-3rdparty/mokojeweled_git.bb b/recipes/openmoko-3rdparty/mokojeweled_git.bb
new file mode 100644
index 0000000000..8313f6565b
--- /dev/null
+++ b/recipes/openmoko-3rdparty/mokojeweled_git.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "A bejeweled clone in Elementary"
+HOMEPAGE = "http://gitorious.org/mokosuite2/mokojeweled"
+AUTHOR = "Daniele Ricci"
+LICENSE = "GPLv3"
+DEPENDS = "elementary edje-native"
+SECTION = "x11/games"
+
+PV = "0.1+gitr${SRCPV}"
+SRCREV = "caf3072c6c10114cb54fb5b35dfa89db3fd0ac75"
+
+SRC_URI = "git://gitorious.org/mokosuite2/mokojeweled.git;protocol=git"
+S = "${WORKDIR}/git"
+
+CFLAGS += "-DOPENMOKO"
+EXTRA_OECONF = " --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+
+do_configure_prepend() {
+ autopoint --force
+}
+
+inherit gettext autotools