aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmoko-3rdparty
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-01-28 09:40:45 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-01-28 09:55:08 +0100
commitecf22021df6ecceb5a993a84a7800d6b16e60c62 (patch)
tree4b270b67bea1b03772a6c4fa11113be2cba0dc52 /recipes/openmoko-3rdparty
parent35211e52f175bb31cf3315689c5da7185362672e (diff)
downloadopenembedded-ecf22021df6ecceb5a993a84a7800d6b16e60c62.tar.gz
ventura: new elementary/webkit based browser
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/openmoko-3rdparty')
-rw-r--r--recipes/openmoko-3rdparty/ventura_svn.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/openmoko-3rdparty/ventura_svn.bb b/recipes/openmoko-3rdparty/ventura_svn.bb
new file mode 100644
index 0000000000..b64a9ebaa5
--- /dev/null
+++ b/recipes/openmoko-3rdparty/ventura_svn.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "elementary based web browser for openmoko phones named ventura"
+HOMEPAGE = "http://code.google.com/p/elm-browser"
+AUTHOR = "cchandel"
+LICENSE = "GPLv2"
+SECTION = "e/apps"
+DEPENDS = "elementary webkit-efl libglade sqlite3"
+SRCREV = "7"
+PV = "0.01+svnr${SRCPV}"
+
+SRC_URI = "svn://elm-browser.googlecode.com/svn;module=trunk;proto=http"
+S = "${WORKDIR}/trunk"
+
+inherit autotools
+
+do_install_append() {
+ install -d "${D}/${datadir}/pixmaps"
+ install -m 0644 "${S}/resources/ventura.png" "${D}/${datadir}/pixmaps"
+ install -d "${D}/${datadir}/applications"
+ install -m 0644 "${S}/resources/ventura.desktop" "${D}/${datadir}/applications"
+ install -d "${D}/${datadir}/ventura"
+ for ico in "${S}/resources/"*.png; do
+ if [ "$(basename $ico)" != "ventura.png" ]; then
+ install -m 0644 $ico "${D}/${datadir}/ventura"
+ fi
+ done
+}
+
+FILES_${PN} += "/usr/share/ventura/* /usr/share/applications/* /usr/share/pixmaps/*"