summaryrefslogtreecommitdiffstats
path: root/recipes/openmoko-3rdparty
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:05:04 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:57:14 +0100
commitd7f99e8b69296d3385017297619f06de4334cfdb (patch)
tree50c1d9911b73aafd13d5d9601e9c8af2d0e20bf9 /recipes/openmoko-3rdparty
parent6310a961f23b5e19adef74748104f4b1a9e57ca8 (diff)
downloadopenembedded-d7f99e8b69296d3385017297619f06de4334cfdb.tar.gz
om-neon: new recipe from SHR
Diffstat (limited to 'recipes/openmoko-3rdparty')
-rw-r--r--recipes/openmoko-3rdparty/om-neon_svn.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/openmoko-3rdparty/om-neon_svn.bb b/recipes/openmoko-3rdparty/om-neon_svn.bb
new file mode 100644
index 0000000000..5ecaf14123
--- /dev/null
+++ b/recipes/openmoko-3rdparty/om-neon_svn.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Simple image viewer"
+HOMEPAGE = "http://neon.projects.openmoko.org/"
+LICENSE = "GPLv3"
+AUTHOR = "Valéry Febvre <vfebvre@easter-eggs.com>"
+SECTION = "x11/applications"
+PRIORITY = "optional"
+DEPENDS = "edje-native python-native"
+
+SRCREV = ${AUTOREV}
+PV = "1.0.0+svnr${SRCPV}"
+PR = "r2"
+
+S = "${WORKDIR}/trunk"
+
+# Pure Python plus Edje interface
+PACKAGE_ARCH = "all"
+
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/neon;module=trunk"
+
+inherit distutils
+
+FILES_${PN} += "${datadir}/neon ${datadir}/applications/neon.desktop ${datadir}/pixmaps"
+
+RDEPENDS += "python-textutils python-evas python-ecore python-edje"
+
+do_compile_prepend() {
+ sed -i "s/\/opt\/bin\/edje_cc -v/${@"${STAGING_BINDIR_NATIVE}".replace('/', '\/')}\/edje_cc/g" ${S}/build_edje.py
+ sed -i "s/#THEMES_DIR = '\/usr\/share\/neon\/themes'/THEMES_DIR = '\/usr\/share\/neon\/themes'/g" ${S}/neon/neon.py
+ sed -i "s/THEMES_DIR = '..\/data\/themes'/#THEMES_DIR = '..\/data\/themes'/g" ${S}/neon/neon.py
+}