aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmoko-base
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/openmoko-base
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/openmoko-base')
-rw-r--r--recipes/openmoko-base/openmoko-common_svn.bb21
-rw-r--r--recipes/openmoko-base/openmoko-icon-theme-standard_svn.bb19
-rw-r--r--recipes/openmoko-base/openmoko-libs_svn.bb36
-rw-r--r--recipes/openmoko-base/openmoko-session/session24
-rw-r--r--recipes/openmoko-base/openmoko-session_svn.bb32
-rwxr-xr-xrecipes/openmoko-base/openmoko-sound-system/pulseaudio46
-rw-r--r--recipes/openmoko-base/openmoko-sound-system/session28
-rw-r--r--recipes/openmoko-base/openmoko-sound-system_0.1.0.bb31
-rw-r--r--recipes/openmoko-base/openmoko-sound-theme-standard_svn.bb23
-rw-r--r--recipes/openmoko-base/openmoko-theme-standard-qvga_svn.bb25
-rw-r--r--recipes/openmoko-base/openmoko-theme-standard_svn.bb27
11 files changed, 312 insertions, 0 deletions
diff --git a/recipes/openmoko-base/openmoko-common_svn.bb b/recipes/openmoko-base/openmoko-common_svn.bb
new file mode 100644
index 0000000000..dc5d24abe1
--- /dev/null
+++ b/recipes/openmoko-base/openmoko-common_svn.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Common files for the Openmoko distribution"
+SECTION = "openmoko/base"
+PV = "0.0+svnr${SRCREV}"
+PR = "r1"
+
+inherit openmoko-base
+
+SRC_URI = "${OPENMOKO_MIRROR}/src/target/${OPENMOKO_RELEASE}/artwork;module=images;proto=http"
+S = "${WORKDIR}"
+
+dirs = "images/pixmaps"
+
+do_install() {
+ find ${WORKDIR} -name ".svn" | xargs rm -rf
+ install -d ${D}${datadir}/openmoko/
+ for i in ${dirs}; do
+ cp -fpPR ${S}/$i ${D}${datadir}/openmoko/
+ done
+}
+
+FILES_${PN} = "${datadir}"
diff --git a/recipes/openmoko-base/openmoko-icon-theme-standard_svn.bb b/recipes/openmoko-base/openmoko-icon-theme-standard_svn.bb
new file mode 100644
index 0000000000..0961d74162
--- /dev/null
+++ b/recipes/openmoko-base/openmoko-icon-theme-standard_svn.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Standard Gtk+ icon theme for the Openmoko distribution"
+SECTION = "openmoko/base"
+PV = "0.1+svnr${SRCREV}"
+PR = "r1"
+
+inherit openmoko-base autotools
+
+SRC_URI = "${OPENMOKO_MIRROR}/src/target/${OPENMOKO_RELEASE}/artwork;module=icons;proto=http"
+S = "${WORKDIR}/icons"
+
+pkg_postinst_openmoko-icon-theme-standard () {
+#!/bin/sh -e
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+gtk-update-icon-cache ${datadir}/icons/openmoko-standard/
+}
+
+PACKAGE_ARCH = "all"
diff --git a/recipes/openmoko-base/openmoko-libs_svn.bb b/recipes/openmoko-base/openmoko-libs_svn.bb
new file mode 100644
index 0000000000..20b05efb0b
--- /dev/null
+++ b/recipes/openmoko-base/openmoko-libs_svn.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "openmoko-libs is a set of libraries implementing a Gtk+ based application framework for mobile communication applications"
+SECTION = "openmoko/libs"
+LICENSE = "LGPL"
+DEPENDS += "gtk+ eds-dbus libgsmd libxosd"
+PV = "0.4+svnr${SRCREV}"
+PR = "r0"
+
+inherit openmoko
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES =+ "\
+ libmokojournal libmokojournal-dev libmokojournal-dbg \
+ libmokogsmd libmokogsmd-dev libmokogsmd-dbg \
+ libmokocore libmokocore-dev libmokocore-dbg \
+ libmokoui libmokoui-dev libmokoui-dbg \
+"
+
+FILES_libmokojournal = "${libdir}/libmokojournal.so.*"
+FILES_libmokojournal-dev = "${libdir}/libmokojournal.so ${libdir}/libmokojournal.*a ${includedir}/${PN}/libmokojournal"
+FILES_libmokojournal-dbg += "${libdir}/.debug/libmokojournal.so.*"
+
+FILES_libmokogsmd = "${libdir}/libmokogsmd.so.*"
+FILES_libmokogsmd-dev = "${libdir}/libmokogsmd.so ${libdir}/libmokogsmd.*a ${includedir}/${PN}/libmokogsmd"
+FILES_libmokogsmd-dbg += "${libdir}/.debug/libmokogsmd.so.*"
+
+FILES_libmokocore = "${libdir}/libmokocore.so.*"
+FILES_libmokocore-dev = "${libdir}/libmokocore.so ${libdir}/libmokocore.*a ${includedir}/${PN}/libmokocore"
+FILES_libmokocore-dbg += "${libdir}/.debug/libmokocore.so.*"
+
+FILES_libmokoui = "${libdir}/libmokoui.so.*"
+FILES_libmokoui-dev = "${libdir}/libmokoui.so ${libdir}/libmokoui.*a ${includedir}/${PN}/libmokoui"
+FILES_libmokoui-dbg += "${libdir}/.debug/libmokoui.so.*"
+
diff --git a/recipes/openmoko-base/openmoko-session/session b/recipes/openmoko-base/openmoko-session/session
new file mode 100644
index 0000000000..c7a773efcb
--- /dev/null
+++ b/recipes/openmoko-base/openmoko-session/session
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+export GTK_MODULES="libgtkstylus.so libgtkinput.so"
+SHOWCURSOR="no"
+
+matchbox-panel-2 \
+ --start-applets=openmoko-panel-mainmenu,systray,startup \
+ --end-applets=openmoko-panel-battery,openmoko-panel-gsm,openmoko-panel-gps,openmoko-panel-usb,openmoko-panel-bt,openmoko-panel-clock &
+
+# start old-style panel plugin to get a keyboard
+mbinputmgr &
+
+# set default alsa configuration
+alsactl restore 0 -f /etc/alsa/stereoout.state
+
+# start UI and dialer
+openmoko-footer &
+openmoko-today --desktop &
+openmoko-dialer &
+
+sleep 1
+
+exec matchbox-window-manager -use_titlebar no -use_cursor $SHOWCURSOR $@
+
diff --git a/recipes/openmoko-base/openmoko-session_svn.bb b/recipes/openmoko-base/openmoko-session_svn.bb
new file mode 100644
index 0000000000..1baa1d68b0
--- /dev/null
+++ b/recipes/openmoko-base/openmoko-session_svn.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Matchbox session files for Openmoko"
+SECTION = "openmoko/base"
+RDEPENDS = "matchbox-panel-2 matchbox-wm openmoko-today gconf"
+PV = "0.1+svnr${SRCREV}"
+PR = "r0"
+
+inherit openmoko-base
+
+SRC_URI = "${OPENMOKO_MIRROR}/src/target/${OPENMOKO_RELEASE};module=etc;proto=http \
+ file://session"
+S = "${WORKDIR}"
+
+do_install() {
+ cp -R ${S}/etc ${D}/${sysconfdir}
+ rm -fR ${D}/${sysconfdir}/.svn
+ rm -fR ${D}/${sysconfdir}/matchbox/.svn
+ chmod -R 755 ${D}/${sysconfdir}
+ # DEMO only. Need to handle this differently in actual production images
+ install -m 0755 ${WORKDIR}/session ${D}/${sysconfdir}/matchbox/session
+}
+
+pkg_postinst_openmoko-session () {
+#!/bin/sh -e
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/openmoko/interface/theme openmoko-standard
+}
+
+PACKAGE_ARCH = "all"
+
diff --git a/recipes/openmoko-base/openmoko-sound-system/pulseaudio b/recipes/openmoko-base/openmoko-sound-system/pulseaudio
new file mode 100755
index 0000000000..76daacd3ae
--- /dev/null
+++ b/recipes/openmoko-base/openmoko-sound-system/pulseaudio
@@ -0,0 +1,46 @@
+#!/bin/sh
+#
+# pulseaudio This shell script starts and stops pulseaudio.
+#
+# chkconfig: 345 90 40
+# description: Pulseaudio manages the sound input/output
+# processname: pulseaudio
+
+# Source function library.
+#. /etc/rc.d/init.d/functions
+
+RETVAL=0
+prog="pulseaudio"
+
+start() {
+ echo -n "Starting the audio server..."
+ # FIXME once alsa/shm permissions have been fixed, supply --system
+ pulseaudio --resample-method=trivial -D -nF /etc/pulse/session
+ echo $prog
+}
+
+stop() {
+ # Stop daemons.
+ echo -n "Shutting down $prog: "
+ killall pulseaudio
+ echo "done"
+}
+
+# See how we were called.
+case "$1" in
+ start)
+ start
+ ;;
+ stop)
+ stop
+ ;;
+ restart|reload)
+ stop
+ start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart}"
+ exit 1
+esac
+
+exit $RETVAL
diff --git a/recipes/openmoko-base/openmoko-sound-system/session b/recipes/openmoko-base/openmoko-sound-system/session
new file mode 100644
index 0000000000..ed2346d55f
--- /dev/null
+++ b/recipes/openmoko-base/openmoko-sound-system/session
@@ -0,0 +1,28 @@
+#!/usr/bin/pulseaudio -nF
+
+# Create autoload entries for the device drivers
+add-autoload-sink output module-alsa-sink fragment_size=2048 sink_name=output
+add-autoload-source input module-alsa-source source_name=input
+
+# Load several protocols
+load-module module-esound-protocol-unix
+load-module module-simple-protocol-tcp
+load-module module-native-protocol-unix
+load-module module-cli-protocol-unix
+
+# Make some devices default
+set-default-sink output
+set-default-source input
+
+# Don't fail if the audio files referred to below don't exist
+.nofail
+
+# Load an audio to the sample cache for usage with module-x11-bell
+load-sample-lazy x11-bell /usr/share/openmoko/sounds/notify_doorbell.wav
+load-module module-x11-bell sample=x11-bell
+
+# Load samples
+load-sample startup /usr/share/openmoko/sounds/startup_unintrusive.wav
+load-sample touchscreen /usr/share/openmoko/sounds/touchscreen_click.wav
+load-sample ringtone /usr/share/openmoko/sounds/ringtone_classy.wav
+
diff --git a/recipes/openmoko-base/openmoko-sound-system_0.1.0.bb b/recipes/openmoko-base/openmoko-sound-system_0.1.0.bb
new file mode 100644
index 0000000000..67fe16c858
--- /dev/null
+++ b/recipes/openmoko-base/openmoko-sound-system_0.1.0.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Openmoko Sound System"
+SECTION = "openmoko/base"
+RDEPENDS = "\
+ pulseaudio-server \
+ pulseaudio-module-alsa-sink \
+ pulseaudio-module-alsa-source \
+ pulseaudio-module-cli \
+ pulseaudio-module-esound-protocol-unix \
+ pulseaudio-module-simple-protocol-tcp \
+ pulseaudio-module-native-protocol-unix \
+ pulseaudio-module-cli-protocol-unix \
+"
+PR = "r6"
+
+inherit openmoko-base update-rc.d
+
+INITSCRIPT_NAME = "pulseaudio"
+INITSCRIPT_PARAMS = "defaults 35"
+
+SRC_URI = "file://pulseaudio \
+ file://session"
+S = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}/${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/pulseaudio ${D}/${sysconfdir}/init.d/
+ install -d ${D}/${sysconfdir}/pulse
+ install -m 0755 ${WORKDIR}/session ${D}/${sysconfdir}/pulse/session
+}
+
+PACKAGE_ARCH = "all"
diff --git a/recipes/openmoko-base/openmoko-sound-theme-standard_svn.bb b/recipes/openmoko-base/openmoko-sound-theme-standard_svn.bb
new file mode 100644
index 0000000000..bb500dbeb5
--- /dev/null
+++ b/recipes/openmoko-base/openmoko-sound-theme-standard_svn.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Standard sound theme for the Openmoko distribution"
+SECTION = "openmoko/base"
+PV = "0.1+svnr${SRCREV}"
+PR = "r2"
+
+inherit openmoko-base autotools
+
+SRC_URI = "${OPENMOKO_MIRROR}/src/target/${OPENMOKO_RELEASE}/artwork;module=sounds;proto=http"
+S = "${WORKDIR}/sounds"
+
+do_install() {
+ find ${WORKDIR} -name ".svn" | xargs rm -rf
+ install -d ${D}${datadir}/openmoko/sounds
+ for i in *.mp3; do
+ cp -fpPR ${S}/$i ${D}${datadir}/openmoko/sounds/
+ done
+ for i in touchscreen_click.wav ringtone_classy.wav notify_doorbell.wav startup_unintrusive.wav; do
+ cp -f ${S}/$i ${D}${datadir}/openmoko/sounds/
+ done
+}
+
+FILES_${PN} = "${datadir}"
+
diff --git a/recipes/openmoko-base/openmoko-theme-standard-qvga_svn.bb b/recipes/openmoko-base/openmoko-theme-standard-qvga_svn.bb
new file mode 100644
index 0000000000..5cb7042c92
--- /dev/null
+++ b/recipes/openmoko-base/openmoko-theme-standard-qvga_svn.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Standard Gtk+ theme for the Openmoko distribution, qvga version"
+SECTION = "openmoko/base"
+PV = "0.0+svnr${SRCREV}"
+PR = "r0"
+
+inherit openmoko-base
+
+SRC_URI = "${OPENMOKO_MIRROR}/src/target/${OPENMOKO_RELEASE}/artwork;module=themes;proto=http"
+S = "${WORKDIR}"
+
+dirs = "themes/openmoko-standard-qvga"
+
+do_install() {
+ find ${WORKDIR} -name ".svn" | xargs rm -rf
+ install -d ${D}${datadir}/themes/
+ for i in ${dirs}; do
+ cp -fpPR ${WORKDIR}/$i ${D}${datadir}/themes/
+ done
+
+ install -d ${D}${sysconfdir}/gtk-2.0
+ echo 'include "${datadir}/themes/openmoko-standard-qvga/gtk-2.0/gtkrc"' >> ${D}${sysconfdir}/gtk-2.0/gtkrc
+}
+
+PACKAGE_ARCH = "all"
+FILES_${PN} = "${datadir} ${sysconfdir}"
diff --git a/recipes/openmoko-base/openmoko-theme-standard_svn.bb b/recipes/openmoko-base/openmoko-theme-standard_svn.bb
new file mode 100644
index 0000000000..e5e54934dc
--- /dev/null
+++ b/recipes/openmoko-base/openmoko-theme-standard_svn.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Standard Gtk+ theme for the Openmoko distribution"
+SECTION = "openmoko/base"
+PV = "0.0+svnr${SRCREV}"
+PR = "r5"
+
+inherit openmoko-base
+
+SRC_URI = "${OPENMOKO_MIRROR}/src/target/${OPENMOKO_RELEASE}/artwork;module=themes;proto=http"
+S = "${WORKDIR}"
+
+dirs = "themes/openmoko-standard"
+
+do_install() {
+ find ${WORKDIR} -name ".svn" | xargs rm -rf
+ install -d ${D}${datadir}/themes/
+ for i in ${dirs}; do
+ cp -fpPR ${WORKDIR}/$i ${D}${datadir}/themes/
+ done
+
+ install -d ${D}${sysconfdir}/gtk-2.0
+ echo 'include "${datadir}/themes/openmoko-standard/gtk-2.0/gtkrc"' >> ${D}${sysconfdir}/gtk-2.0/gtkrc
+}
+
+CONFFILES_${PN} = "${sysconfdir}/gtk-2.0/gtkrc"
+
+PACKAGE_ARCH = "all"
+FILES_${PN} = "${datadir} ${sysconfdir}"