summaryrefslogtreecommitdiffstats
path: root/recipes/openmoko-projects
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/openmoko-projects
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/openmoko-projects')
-rw-r--r--recipes/openmoko-projects/assassin-thumbnail.bb18
-rw-r--r--recipes/openmoko-projects/assassin_svn.bb17
-rw-r--r--recipes/openmoko-projects/diversity-daemon/no-xmmp.patch24
-rw-r--r--recipes/openmoko-projects/diversity-daemon_svn.bb19
-rw-r--r--recipes/openmoko-projects/diversity-radar_svn.bb16
-rw-r--r--recipes/openmoko-projects/enlazar_svn.bb16
-rw-r--r--recipes/openmoko-projects/etk-theme-ninja_svn.bb27
-rw-r--r--recipes/openmoko-projects/exposure/setup-r62.diff12
-rw-r--r--recipes/openmoko-projects/illume-theme-asu_svn.bb41
-rw-r--r--recipes/openmoko-projects/om-locations_git.bb20
-rw-r--r--recipes/openmoko-projects/om-maps-berlin_20080430.bb7
-rw-r--r--recipes/openmoko-projects/om-maps-buenos-aires_20080430.bb7
-rw-r--r--recipes/openmoko-projects/om-maps-hong-kong_20080919.bb7
-rw-r--r--recipes/openmoko-projects/om-maps-london_20080430.bb7
-rw-r--r--recipes/openmoko-projects/om-maps-low-levels_20080430.bb8
-rw-r--r--recipes/openmoko-projects/om-maps-new-york_20080430.bb7
-rw-r--r--recipes/openmoko-projects/om-maps-paris_20080430.bb7
-rw-r--r--recipes/openmoko-projects/om-maps-providence_20080430.bb7
-rw-r--r--recipes/openmoko-projects/om-maps-san-francisco_20080430.bb7
-rw-r--r--recipes/openmoko-projects/om-maps-sydney_20080430.bb7
-rw-r--r--recipes/openmoko-projects/om-maps-taipei_20080430.bb7
-rw-r--r--recipes/openmoko-projects/om-maps.inc18
-rw-r--r--recipes/openmoko-projects/om-settings_svn.bb25
-rw-r--r--recipes/openmoko-projects/openmoko-agpsui_svn.bb13
-rw-r--r--recipes/openmoko-projects/openmoko-community-repository.bb19
-rw-r--r--recipes/openmoko-projects/paroli_git.bb20
-rw-r--r--recipes/openmoko-projects/pyefl-sudoku_svn.bb18
-rw-r--r--recipes/openmoko-projects/tichy_git.bb16
28 files changed, 417 insertions, 0 deletions
diff --git a/recipes/openmoko-projects/assassin-thumbnail.bb b/recipes/openmoko-projects/assassin-thumbnail.bb
new file mode 100644
index 0000000000..b05c65dc1d
--- /dev/null
+++ b/recipes/openmoko-projects/assassin-thumbnail.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Assassin Packages Thumbnails"
+HOMEPAGE = "http://assassin.projects.openmoko.org/"
+LICENSE = "GPL"
+RDEPENDS = "assassin"
+PV = "0.1+svnr${SRCREV}"
+PR = "r1"
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/target/thumbnails/;module=result;proto=https"
+
+do_install() {
+ install -d ${D}${THUMBNAIL_DIR}
+ cp -f ${WORKDIR}/result/${THUMBNAIL_FN} ${D}${THUMBNAIL_DIR}
+}
+
+FILES_${PN} = "${THUMBNAIL_DIR}/${THUMBNAIL_FN}"
+
+THUMBNAIL_DIR = "${datadir}/assassin/"
+THUMBNAIL_FN = "thumbnail.eet"
diff --git a/recipes/openmoko-projects/assassin_svn.bb b/recipes/openmoko-projects/assassin_svn.bb
new file mode 100644
index 0000000000..c2ab9579a3
--- /dev/null
+++ b/recipes/openmoko-projects/assassin_svn.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Action GUI for Installer"
+HOMEPAGE = "http://assassin.projects.openmoko.org/"
+LICENSE = "GPL"
+DEPENDS = "dbus (>= 1.1.1) glib-2.0 e-wm packagekit etk edbus eet"
+RDEPENDS = "etk-theme-ninja"
+PV = "0.2+svnr${SRCREV}"
+PR = "r6.04"
+
+SRC_URI = "svn://om-assassin.googlecode.com/svn/;module=trunk;proto=http"
+
+S = "${WORKDIR}/trunk"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = ""
+
+FILES_${PN} += "${prefix}/share/*"
diff --git a/recipes/openmoko-projects/diversity-daemon/no-xmmp.patch b/recipes/openmoko-projects/diversity-daemon/no-xmmp.patch
new file mode 100644
index 0000000000..2065e97dce
--- /dev/null
+++ b/recipes/openmoko-projects/diversity-daemon/no-xmmp.patch
@@ -0,0 +1,24 @@
+Index: diversity-xmpp-backend/Makefile.am
+===================================================================
+--- a/diversity-xmpp-backend/Makefile.am (revision 276)
++++ a/diversity-xmpp-backend/Makefile.am (working copy)
+@@ -1,3 +1,4 @@
++if HAVE_XMPP
+ INCLUDES = -I${top_srcdir}/include
+
+ AM_CPPFLAGS = \
+@@ -4,9 +5,7 @@
+ $(GLIB_CFLAGS) \
+ $(LM_CFLAGS)
+
+-if HAVE_XMPP
+ noinst_LTLIBRARIES = libdiversity-xmpp-backend.la
+-endif
+
+ noinst_HEADERS = diversity-xmpp-backend.h
+
+@@ -48,3 +47,4 @@
+
+ xmpp-marshal.h: xmpp-marshal.list
+ $(GLIB_GENMARSHAL) --prefix xmpp_marshal --header $< > $@
++endif
diff --git a/recipes/openmoko-projects/diversity-daemon_svn.bb b/recipes/openmoko-projects/diversity-daemon_svn.bb
new file mode 100644
index 0000000000..43c1d0a1b9
--- /dev/null
+++ b/recipes/openmoko-projects/diversity-daemon_svn.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Diversity Daemon"
+HOMEPAGE = "http://diversity.projects.openmoko.org/"
+SECTION = "network/misc"
+LICENSE = "GPL"
+DEPENDS = "glib-2.0 dbus dbus-glib eds-dbus libjana curl"
+RDEPENDS_${PN} = "eds-dbus"
+PV = "0.0+svnr${SRCREV}"
+PR = "r3"
+
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/diversity/trunk;module=diversity-daemon;proto=https \
+ file://no-xmmp.patch;patch=1;minrev=276"
+S = "${WORKDIR}/diversity-daemon"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-nm --disable-xmpp --enable-session-bus"
+
+FILES_${PN} += "${datadir}/dbus-1/"
+FILES_${PN} += "${sysconfdir}/dbus-1/"
diff --git a/recipes/openmoko-projects/diversity-radar_svn.bb b/recipes/openmoko-projects/diversity-radar_svn.bb
new file mode 100644
index 0000000000..1d754d23ca
--- /dev/null
+++ b/recipes/openmoko-projects/diversity-radar_svn.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Diversity Radar is a GPS location based communicative application"
+HOMEPAGE = "http://diversity.projects.openmoko.org/"
+SECTION = "openmoko/applications"
+LICENSE = "GPL"
+DEPENDS = "python-evas python-edje python-ecore python-edbus python-dbus python-etk"
+RDEPENDS_${PN} = "diversity-daemon"
+PV = "0.0.4+svnr${SRCREV}"
+PR = "r0.01"
+
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/diversity/toys;module=diversity-radar;proto=http"
+
+S = "${WORKDIR}/${PN}"
+
+inherit setuptools
+
+FILES_${PN} += "${prefix}/share/*"
diff --git a/recipes/openmoko-projects/enlazar_svn.bb b/recipes/openmoko-projects/enlazar_svn.bb
new file mode 100644
index 0000000000..4d86dc6a06
--- /dev/null
+++ b/recipes/openmoko-projects/enlazar_svn.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Enlazar - Network part for Assasin"
+HOMEPAGE = "http://enlazar.projects.openmoko.org/"
+LICENSE = "GPL"
+DEPENDS = "evas edje ecore edbus"
+RDEPENDS = "networkmanager"
+PV = "0.1+svnr${SRCREV}"
+PR = "r3"
+PE = "2"
+
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/enlazar;module=trunk;proto=http"
+
+S = "${WORKDIR}/trunk"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = ""
diff --git a/recipes/openmoko-projects/etk-theme-ninja_svn.bb b/recipes/openmoko-projects/etk-theme-ninja_svn.bb
new file mode 100644
index 0000000000..a4fb2f3054
--- /dev/null
+++ b/recipes/openmoko-projects/etk-theme-ninja_svn.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Ninja - Etk theme"
+HOMEPAGE = "http://ninja.projects.openmoko.org/"
+SECTION = "openmoko/misc"
+LICENSE = "GPL"
+DEPENDS = "edje"
+PV = "0.0.1+svnr${SRCREV}"
+PR = "r1"
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/ninja;module=trunk;proto=http"
+
+S = "${WORKDIR}/trunk"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+
+PACKAGE_ARCH = "all"
+# All of this package is just data, doesn't need dev,dbg package
+PACKAGES = "${PN}"
+
+FILES_${PN} += "${datadir}/ninja/default.edj"
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${datadir}/etk/themes/default.edj etk-default.edj ${datadir}/ninja/default.edj 50
+}
+pkg_postrm_${PN} () {
+ update-alternatives --remove etk-default.edj ${datadir}/ninja/default.edj
+}
diff --git a/recipes/openmoko-projects/exposure/setup-r62.diff b/recipes/openmoko-projects/exposure/setup-r62.diff
new file mode 100644
index 0000000000..694787bdec
--- /dev/null
+++ b/recipes/openmoko-projects/exposure/setup-r62.diff
@@ -0,0 +1,12 @@
+Index: setup.py
+===================================================================
+--- setup.py (Revision 62)
++++ setup.py (Arbeitskopie)
+@@ -27,7 +27,6 @@
+ setup_requires=['python-evas>=0.2.1'],
+ data_files=[('applications', 'src/exposure.desktop']),
+ ('exposure', ['data/themes/exposure.edj']),
+- ('images', ['data/image/exposure.jpg']),
+ ('/etc/X11/Xsession.d/', ['src/80app-launcher-bootup']),
+ ]
+ )
diff --git a/recipes/openmoko-projects/illume-theme-asu_svn.bb b/recipes/openmoko-projects/illume-theme-asu_svn.bb
new file mode 100644
index 0000000000..e232dbb554
--- /dev/null
+++ b/recipes/openmoko-projects/illume-theme-asu_svn.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "Illume - Mobile UI module for Enlightenment"
+HOMEPAGE = "http://illume.projects.openmoko.org/"
+LICENSE = "MIT/BSD"
+DEPENDS = "edje-native eet-native"
+RPROVIDES_${PN} = "illume-theme"
+RCONFLICTS = "illume-config"
+PV = "0.0+svnr${SRCREV}"
+PR = "r9"
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/target/themes/;module=illume-theme-asu;proto=http"
+
+S = "${WORKDIR}/illume-theme-asu"
+
+do_compile() {
+ cd misc-data/asu && ./build.sh && cd ../..
+ cd misc-data/asu_init && ./build.sh && cd ../..
+ cd config
+ eet -e e.cfg config e.src 1
+ eet -e module.battery.cfg config module.battery.src 1
+ eet -e module.illume.cfg config module.illume.src 1
+}
+
+do_install() {
+ install -d ${D}${sysconfdir}/enlightenment
+ install -d ${D}${datadir}/enlightenment/data/themes
+ install -d ${D}${datadir}/enlightenment/data/init
+ install -d ${D}${datadir}/enlightenment/data/config/asu
+ # Make asu the default profile
+ echo 'E_PROFILE="-profile asu"' > ${D}${sysconfdir}/enlightenment/default_profile
+ install -m 0644 ${S}/misc-data/asu/asu.edj ${D}${datadir}/enlightenment/data/themes/asu.edj
+ install -m 0644 ${S}/misc-data/asu_init/asu_init.edj ${D}${datadir}/enlightenment/data/init/asu_init.edj
+ install -m 0644 ${S}/config/*.cfg ${D}${datadir}/enlightenment/data/config/asu
+}
+
+PACKAGE_ARCH_${PN} = "all"
+PACKAGES = "\
+ ${PN} \
+"
+FILES_${PN} = "${sysconfdir}/enlightenment ${datadir}/enlightenment"
+
+CONFFILES_${PN} = "${sysconfdir}/enlightenment/default_profile"
diff --git a/recipes/openmoko-projects/om-locations_git.bb b/recipes/openmoko-projects/om-locations_git.bb
new file mode 100644
index 0000000000..b50de38e9e
--- /dev/null
+++ b/recipes/openmoko-projects/om-locations_git.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Locations is a GPS location based application that lets you save and send your favorite locations to friends."
+HOMEPAGE = "http://wiki.openmoko.org/wiki/Om2008.8_Locations"
+SECTION = "openmoko/applications"
+LICENSE = "GPL"
+DEPENDS = "eet evas edje ecore edbus etk"
+RDEPENDS_${PN} = "diversity-daemon"
+PV = "0.2+gitr${SRCREV}"
+PR = "r1.03"
+
+SRC_URI = "git://git.openmoko.org/git/om-locations.git;protocol=git"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+
+do_configure_prepend() {
+ autopoint --force
+}
diff --git a/recipes/openmoko-projects/om-maps-berlin_20080430.bb b/recipes/openmoko-projects/om-maps-berlin_20080430.bb
new file mode 100644
index 0000000000..17bfe725fc
--- /dev/null
+++ b/recipes/openmoko-projects/om-maps-berlin_20080430.bb
@@ -0,0 +1,7 @@
+PR = "r2"
+
+MAP_NAME = "Berlin"
+require om-maps.inc
+
+MAP_FN = "om-maps-berlin-${PV}.eet"
+MAP_VER = "${PV}"
diff --git a/recipes/openmoko-projects/om-maps-buenos-aires_20080430.bb b/recipes/openmoko-projects/om-maps-buenos-aires_20080430.bb
new file mode 100644
index 0000000000..8f2f2a205d
--- /dev/null
+++ b/recipes/openmoko-projects/om-maps-buenos-aires_20080430.bb
@@ -0,0 +1,7 @@
+PR = "r2"
+
+MAP_NAME = "Buenos Aires"
+require om-maps.inc
+
+MAP_FN = "om-maps-buenos-aires-${PV}.eet"
+MAP_VER = "${PV}"
diff --git a/recipes/openmoko-projects/om-maps-hong-kong_20080919.bb b/recipes/openmoko-projects/om-maps-hong-kong_20080919.bb
new file mode 100644
index 0000000000..9b641778ec
--- /dev/null
+++ b/recipes/openmoko-projects/om-maps-hong-kong_20080919.bb
@@ -0,0 +1,7 @@
+PR = "r1"
+
+MAP_NAME = "Hong Kong"
+require om-maps.inc
+
+MAP_FN = "om-maps-hong-kong-${PV}.eet"
+MAP_VER = "${PV}"
diff --git a/recipes/openmoko-projects/om-maps-london_20080430.bb b/recipes/openmoko-projects/om-maps-london_20080430.bb
new file mode 100644
index 0000000000..f19b956f00
--- /dev/null
+++ b/recipes/openmoko-projects/om-maps-london_20080430.bb
@@ -0,0 +1,7 @@
+PR = "r2"
+
+MAP_NAME = "London"
+require om-maps.inc
+
+MAP_FN = "om-maps-london-${PV}.eet"
+MAP_VER = "${PV}"
diff --git a/recipes/openmoko-projects/om-maps-low-levels_20080430.bb b/recipes/openmoko-projects/om-maps-low-levels_20080430.bb
new file mode 100644
index 0000000000..29cfab068c
--- /dev/null
+++ b/recipes/openmoko-projects/om-maps-low-levels_20080430.bb
@@ -0,0 +1,8 @@
+PR = "r1"
+
+MAP_NAME = "low levels"
+require om-maps.inc
+
+
+MAP_FN = "om-maps-low-levels-${PV}.eet"
+MAP_VER = "${PV}"
diff --git a/recipes/openmoko-projects/om-maps-new-york_20080430.bb b/recipes/openmoko-projects/om-maps-new-york_20080430.bb
new file mode 100644
index 0000000000..52a40cccc6
--- /dev/null
+++ b/recipes/openmoko-projects/om-maps-new-york_20080430.bb
@@ -0,0 +1,7 @@
+PR = "r2"
+
+MAP_NAME = "New York"
+require om-maps.inc
+
+MAP_FN = "om-maps-new-york-${PV}.eet"
+MAP_VER = "${PV}"
diff --git a/recipes/openmoko-projects/om-maps-paris_20080430.bb b/recipes/openmoko-projects/om-maps-paris_20080430.bb
new file mode 100644
index 0000000000..3c66830cdb
--- /dev/null
+++ b/recipes/openmoko-projects/om-maps-paris_20080430.bb
@@ -0,0 +1,7 @@
+PR = "r2"
+
+MAP_NAME = "Paris"
+require om-maps.inc
+
+MAP_FN = "om-maps-paris-${PV}.eet"
+MAP_VER = "${PV}"
diff --git a/recipes/openmoko-projects/om-maps-providence_20080430.bb b/recipes/openmoko-projects/om-maps-providence_20080430.bb
new file mode 100644
index 0000000000..5fd447b663
--- /dev/null
+++ b/recipes/openmoko-projects/om-maps-providence_20080430.bb
@@ -0,0 +1,7 @@
+PR = "r2"
+
+MAP_NAME = "Providence"
+require om-maps.inc
+
+MAP_FN = "om-maps-providence-${PV}.eet"
+MAP_VER = "${PV}"
diff --git a/recipes/openmoko-projects/om-maps-san-francisco_20080430.bb b/recipes/openmoko-projects/om-maps-san-francisco_20080430.bb
new file mode 100644
index 0000000000..b4fb9d00e6
--- /dev/null
+++ b/recipes/openmoko-projects/om-maps-san-francisco_20080430.bb
@@ -0,0 +1,7 @@
+PR = "r2"
+
+MAP_NAME = "San Francisco"
+require om-maps.inc
+
+MAP_FN = "om-maps-san-francisco-${PV}.eet"
+MAP_VER = "${PV}"
diff --git a/recipes/openmoko-projects/om-maps-sydney_20080430.bb b/recipes/openmoko-projects/om-maps-sydney_20080430.bb
new file mode 100644
index 0000000000..81e379c373
--- /dev/null
+++ b/recipes/openmoko-projects/om-maps-sydney_20080430.bb
@@ -0,0 +1,7 @@
+PR = "r2"
+
+MAP_NAME = "Sydney"
+require om-maps.inc
+
+MAP_FN = "om-maps-sydney-${PV}.eet"
+MAP_VER = "${PV}"
diff --git a/recipes/openmoko-projects/om-maps-taipei_20080430.bb b/recipes/openmoko-projects/om-maps-taipei_20080430.bb
new file mode 100644
index 0000000000..fdd5c36f02
--- /dev/null
+++ b/recipes/openmoko-projects/om-maps-taipei_20080430.bb
@@ -0,0 +1,7 @@
+PR = "r2"
+
+MAP_NAME = "Taipei"
+require om-maps.inc
+
+MAP_FN = "om-maps-taipei-${PV}.eet"
+MAP_VER = "${PV}"
diff --git a/recipes/openmoko-projects/om-maps.inc b/recipes/openmoko-projects/om-maps.inc
new file mode 100644
index 0000000000..1caba01faf
--- /dev/null
+++ b/recipes/openmoko-projects/om-maps.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "Map of ${MAP_NAME}, for use with Locations application. \
+ Data from OpenStreetMap.org, licenced CC-by-SA."
+HOMEPAGE = "http://wiki.openmoko.org/wiki/Om_2008.8_Locations"
+SECTION = "network/misc"
+LICENSE = "Creative Commons Attribution-ShareAlike 2.0"
+
+SRC_URI = "http://people.openmoko.org/olv/om-maps/${MAP_VER}/${MAP_FN}"
+
+MAP_DIR = "${datadir}/om-maps"
+FILES_${PN} = "${MAP_DIR}/${MAP_FN}"
+
+PACKAGES = "${PN}"
+PACKAGE_ARCH = "all"
+
+do_install() {
+ install -d ${D}${MAP_DIR}
+ cp -f ${WORKDIR}/${MAP_FN} ${D}${MAP_DIR}
+}
diff --git a/recipes/openmoko-projects/om-settings_svn.bb b/recipes/openmoko-projects/om-settings_svn.bb
new file mode 100644
index 0000000000..579dd3d1be
--- /dev/null
+++ b/recipes/openmoko-projects/om-settings_svn.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Exposure all devices on neo1973"
+DEPENDS = "python-etk python-edbus"
+RDEPENDS = "python-etk python-re python-codecs python-edbus python-pyxdg"
+PV = "0.0.1+svnr${SRCREV}"
+PR = "r3"
+PE = "1"
+
+S = "${WORKDIR}/trunk"
+
+inherit setuptools
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/exposure;module=trunk;proto=http \
+ "
+
+
+PACKAGES = "${PN}"
+FILES_${PN} += "${prefix}/share/* ${sysconfdir}/X11/Xsession.d/*"
+
+pkg_postinst_${PN} () {
+#!/bin/sh
+if test "x$D" = "x"; then
+ killall exposure.py
+ sleep 1
+ exposure.py
+fi
+}
diff --git a/recipes/openmoko-projects/openmoko-agpsui_svn.bb b/recipes/openmoko-projects/openmoko-agpsui_svn.bb
new file mode 100644
index 0000000000..b9b2de2de7
--- /dev/null
+++ b/recipes/openmoko-projects/openmoko-agpsui_svn.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "GPS diagnostic tool"
+HOMEPAGE = "http://openmoko-agpsui.projects.openmoko.org/"
+SECTION = "openmoko/apps"
+LICENSE = "GPL"
+DEPENDS = "gtk+"
+PV = "0.1+svnr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/openmoko-agpsui;module=trunk;proto=https"
+
+S = "${WORKDIR}/trunk"
+
+inherit autotools pkgconfig
diff --git a/recipes/openmoko-projects/openmoko-community-repository.bb b/recipes/openmoko-projects/openmoko-community-repository.bb
new file mode 100644
index 0000000000..8486309a34
--- /dev/null
+++ b/recipes/openmoko-projects/openmoko-community-repository.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Configuration files for online package repositories of the Openmoko community repository feeds."
+PR = "r0.03"
+
+do_compile() {
+ mkdir -p ${S}/${sysconfdir}/opkg
+ for feed in Multiverse; do
+ echo "src/gz daily-${feed} ${OPENMOKO_URI}/${feed}" > ${S}/${sysconfdir}/opkg/${feed}-feed.conf
+ done
+}
+do_install () {
+ install -d ${D}${sysconfdir}/opkg
+ install -m 0644 ${S}/${sysconfdir}/opkg/* ${D}${sysconfdir}/opkg/
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+CONFFILES_${PN} += "${sysconfdir}/opkg/Multiverse-feed.conf"
+
+OPENMOKO_URI = "http://downloads.openmoko.org/repository"
diff --git a/recipes/openmoko-projects/paroli_git.bb b/recipes/openmoko-projects/paroli_git.bb
new file mode 100644
index 0000000000..e485996f4b
--- /dev/null
+++ b/recipes/openmoko-projects/paroli_git.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Paroli"
+SECTION = "x11"
+LICENSE = "GPL"
+PV = "0.2+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "git://git.paroli-project.org/paroli.git;protocol=http"
+S = "${WORKDIR}/git"
+
+inherit distutils
+
+RDEPENDS = "\
+ python-datetime \
+ python-subprocess \
+ python-textutils \
+ python-dbus \
+ python-pygobject \
+"
+
+FILES_${PN} += "${sysconfdir}/dbus-1 ${sysconfdir}/paroli ${datadir}"
diff --git a/recipes/openmoko-projects/pyefl-sudoku_svn.bb b/recipes/openmoko-projects/pyefl-sudoku_svn.bb
new file mode 100644
index 0000000000..0eedc1bf58
--- /dev/null
+++ b/recipes/openmoko-projects/pyefl-sudoku_svn.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Sudoku is a logic-based number-placement puzzle. The objective is to fill a 9×9 grid so that each column, each row, and each of the nine 3×3 boxes (also called blocks or regions) contains the digits from 1 to 9 only one time each."
+HOMEPAGE = "http://pyefl-sudoku.projects.openmoko.org/"
+SECTION = "openmoko/applications"
+LICENSE = "GPL"
+DEPENDS = "python-evas python-edje python-ecore"
+RDEPENDS = "python-evas python-edje python-ecore"
+PV = "0.0.2+svnr${SRCREV}"
+PR = "r2"
+
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/;module=pyefl-sudoku;proto=http"
+
+S = "${WORKDIR}/pyefl-sudoku"
+
+inherit setuptools
+
+PACKAGES = "${PN}"
+
+FILES_${PN} += "${prefix}/share/*"
diff --git a/recipes/openmoko-projects/tichy_git.bb b/recipes/openmoko-projects/tichy_git.bb
new file mode 100644
index 0000000000..4a1ffb500e
--- /dev/null
+++ b/recipes/openmoko-projects/tichy_git.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Python applets manager"
+SECTION = "x11"
+LICENSE = "GPL"
+DEPENDS += "python-pygame virtual/libsdl libsdl-image python-dbus python-pygobject"
+PV = "0.2+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "git://git.openmoko.org/git/tichy.git;protocol=git"
+S = "${WORKDIR}/git"
+
+inherit distutils
+
+FILES_${PN} += "${datadir}"
+RDEPENDS_${PN} += "python-pygame"
+# This is because pkg-config --libs --cflags sdl doesn't return the correct path (bug in libsdl recipe ?)
+CFLAGS += -I${STAGING_INCDIR}/SDL