aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openssl
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-23 20:23:53 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:53:41 -0700
commitbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (patch)
tree96f28e2f5133d68c3e3dadabaa2339340671454f /recipes/openssl
parentfab0af3aefee22b21541e403d3c356a6979bfa63 (diff)
downloadopenembedded-bf7d0467a0788a7fcc1c96e0dc35a25ae09278a0.tar.gz
Rename url params patch=<ignored>/pnum=<n> to apply={yes,no}/striplevel=<n>
I think this makes the behavior rather more clear. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/openssl')
-rw-r--r--recipes/openssl/openssl-native_0.9.7g.bb6
-rw-r--r--recipes/openssl/openssl-native_0.9.7m.bb6
-rw-r--r--recipes/openssl/openssl-native_0.9.8g.bb6
-rw-r--r--recipes/openssl/openssl-native_0.9.8m.bb6
-rw-r--r--recipes/openssl/openssl-native_1.0.0.bb8
-rw-r--r--recipes/openssl/openssl_0.9.7e.bb6
-rw-r--r--recipes/openssl/openssl_0.9.7g.bb12
-rw-r--r--recipes/openssl/openssl_0.9.7m.bb12
-rw-r--r--recipes/openssl/openssl_0.9.8g.bb6
-rw-r--r--recipes/openssl/openssl_0.9.8m.bb8
-rw-r--r--recipes/openssl/openssl_1.0.0.bb12
11 files changed, 44 insertions, 44 deletions
diff --git a/recipes/openssl/openssl-native_0.9.7g.bb b/recipes/openssl/openssl-native_0.9.7g.bb
index 41e6e21943..79ea490b36 100644
--- a/recipes/openssl/openssl-native_0.9.7g.bb
+++ b/recipes/openssl/openssl-native_0.9.7g.bb
@@ -4,9 +4,9 @@ require openssl.inc
PR = "${INC_PR}.0"
-SRC_URI += "file://debian.patch;patch=1 \
- file://armeb.patch;patch=1;pnum=0 \
- file://gnueabi-arm.patch;patch=1"
+SRC_URI += "file://debian.patch;apply=yes \
+ file://armeb.patch;apply=yes;striplevel=0 \
+ file://gnueabi-arm.patch;apply=yes"
do_install() {
:
diff --git a/recipes/openssl/openssl-native_0.9.7m.bb b/recipes/openssl/openssl-native_0.9.7m.bb
index ef680f1a3f..23f38dcf25 100644
--- a/recipes/openssl/openssl-native_0.9.7m.bb
+++ b/recipes/openssl/openssl-native_0.9.7m.bb
@@ -8,9 +8,9 @@ export BUILD_OPTIMIZATION = " "
PR = "${INC_PR}.0"
-SRC_URI += "file://debian.patch;patch=1 \
- file://armeb.patch;patch=1;pnum=0 \
- file://gnueabi-arm.patch;patch=1"
+SRC_URI += "file://debian.patch;apply=yes \
+ file://armeb.patch;apply=yes;striplevel=0 \
+ file://gnueabi-arm.patch;apply=yes"
do_install() {
:
diff --git a/recipes/openssl/openssl-native_0.9.8g.bb b/recipes/openssl/openssl-native_0.9.8g.bb
index 9de05ffe93..68372b45b5 100644
--- a/recipes/openssl/openssl-native_0.9.8g.bb
+++ b/recipes/openssl/openssl-native_0.9.8g.bb
@@ -8,9 +8,9 @@ PR = "${INC_PR}.0"
export FULL_OPTIMIZATION = " "
export BUILD_OPTIMIZATION = " "
-SRC_URI += "file://debian.patch;patch=1 \
- file://configure-targets.patch;patch=1 \
- file://shared-libs.patch;patch=1"
+SRC_URI += "file://debian.patch;apply=yes \
+ file://configure-targets.patch;apply=yes \
+ file://shared-libs.patch;apply=yes"
PARALLEL_MAKE = ""
diff --git a/recipes/openssl/openssl-native_0.9.8m.bb b/recipes/openssl/openssl-native_0.9.8m.bb
index 169f3ef981..e658063057 100644
--- a/recipes/openssl/openssl-native_0.9.8m.bb
+++ b/recipes/openssl/openssl-native_0.9.8m.bb
@@ -10,9 +10,9 @@ PR = "${INC_PR}.2"
export FULL_OPTIMIZATION = " "
export BUILD_OPTIMIZATION = " "
-SRC_URI += "file://configure-targets.patch;patch=1 \
- file://shared-libs.patch;patch=1 \
- file://debian.patch;patch=1"
+SRC_URI += "file://configure-targets.patch;apply=yes \
+ file://shared-libs.patch;apply=yes \
+ file://debian.patch;apply=yes"
PARALLEL_MAKE = ""
diff --git a/recipes/openssl/openssl-native_1.0.0.bb b/recipes/openssl/openssl-native_1.0.0.bb
index a4ae71528a..8614fb1a3a 100644
--- a/recipes/openssl/openssl-native_1.0.0.bb
+++ b/recipes/openssl/openssl-native_1.0.0.bb
@@ -14,10 +14,10 @@ export DIRS = "crypto ssl apps engines"
export FULL_OPTIMIZATION = " "
export BUILD_OPTIMIZATION = " "
-SRC_URI += "file://configure-targets.patch;patch=1 \
- file://shared-libs.patch;patch=1 \
- file://debian.patch;patch=1 \
- file://libdeps-first.patch;patch=1 \
+SRC_URI += "file://configure-targets.patch;apply=yes \
+ file://shared-libs.patch;apply=yes \
+ file://debian.patch;apply=yes \
+ file://libdeps-first.patch;apply=yes \
"
PARALLEL_MAKE = ""
diff --git a/recipes/openssl/openssl_0.9.7e.bb b/recipes/openssl/openssl_0.9.7e.bb
index 16d66428fc..5e873f5289 100644
--- a/recipes/openssl/openssl_0.9.7e.bb
+++ b/recipes/openssl/openssl_0.9.7e.bb
@@ -2,9 +2,9 @@ require openssl.inc
PR = "${INC_PR}.0"
-SRC_URI += "file://debian.patch;patch=1 \
- file://armeb.patch;patch=1 \
- file://gnueabi-arm.patch;patch=1"
+SRC_URI += "file://debian.patch;apply=yes \
+ file://armeb.patch;apply=yes \
+ file://gnueabi-arm.patch;apply=yes"
SRC_URI[src.md5sum] = "a8777164bca38d84e5eb2b1535223474"
SRC_URI[src.sha256sum] = "25121b5dbd2b830929519325e033086ce45861cff2d0000d928f48261b1e0b7c"
diff --git a/recipes/openssl/openssl_0.9.7g.bb b/recipes/openssl/openssl_0.9.7g.bb
index 0a54c3fb46..bac3c5dc89 100644
--- a/recipes/openssl/openssl_0.9.7g.bb
+++ b/recipes/openssl/openssl_0.9.7g.bb
@@ -4,12 +4,12 @@ require openssl.inc
PR = "${INC_PR}.0"
-SRC_URI += "file://debian.patch;patch=1 \
- file://armeb.patch;patch=1;pnum=0 \
- file://gnueabi-arm.patch;patch=1 \
- file://gnueabi-armeb.patch;patch=1 \
- file://uclibcgnueabi.patch;patch=1 \
- file://avr32.patch;patch=1;pnum=0"
+SRC_URI += "file://debian.patch;apply=yes \
+ file://armeb.patch;apply=yes;striplevel=0 \
+ file://gnueabi-arm.patch;apply=yes \
+ file://gnueabi-armeb.patch;apply=yes \
+ file://uclibcgnueabi.patch;apply=yes \
+ file://avr32.patch;apply=yes;striplevel=0"
SRC_URI[src.md5sum] = "991615f73338a571b6a1be7d74906934"
SRC_URI[src.sha256sum] = "e7e1a287141dd1be7f4b4fedd54ec29fa904655ed76a13ac87ae69a3fc76b062"
diff --git a/recipes/openssl/openssl_0.9.7m.bb b/recipes/openssl/openssl_0.9.7m.bb
index 9c614800fa..d429a50e7e 100644
--- a/recipes/openssl/openssl_0.9.7m.bb
+++ b/recipes/openssl/openssl_0.9.7m.bb
@@ -4,12 +4,12 @@ require openssl.inc
PR = "${INC_PR}.0"
-SRC_URI += "file://debian.patch;patch=1 \
- file://armeb.patch;patch=1;pnum=0 \
- file://gnueabi-arm.patch;patch=1 \
- file://gnueabi-armeb.patch;patch=1 \
- file://uclibcgnueabi.patch;patch=1 \
- file://avr32.patch;patch=1;pnum=0"
+SRC_URI += "file://debian.patch;apply=yes \
+ file://armeb.patch;apply=yes;striplevel=0 \
+ file://gnueabi-arm.patch;apply=yes \
+ file://gnueabi-armeb.patch;apply=yes \
+ file://uclibcgnueabi.patch;apply=yes \
+ file://avr32.patch;apply=yes;striplevel=0"
SRC_URI[src.md5sum] = "74a4d1b87e1e6e1ec95dbe58cb4c5b9a"
SRC_URI[src.sha256sum] = "c98b9703887e2dda6217b91405d0d94883f7c67e205fc4d7a81bb690d2e10572"
diff --git a/recipes/openssl/openssl_0.9.8g.bb b/recipes/openssl/openssl_0.9.8g.bb
index 921daad424..7aac9eaba4 100644
--- a/recipes/openssl/openssl_0.9.8g.bb
+++ b/recipes/openssl/openssl_0.9.8g.bb
@@ -4,9 +4,9 @@ require openssl.inc
PR = "${INC_PR}.0"
-SRC_URI += "file://debian.patch;patch=1 \
- file://configure-targets.patch;patch=1 \
- file://shared-libs.patch;patch=1"
+SRC_URI += "file://debian.patch;apply=yes \
+ file://configure-targets.patch;apply=yes \
+ file://shared-libs.patch;apply=yes"
PARALLEL_MAKE = ""
diff --git a/recipes/openssl/openssl_0.9.8m.bb b/recipes/openssl/openssl_0.9.8m.bb
index db3c48a1e0..20d4956162 100644
--- a/recipes/openssl/openssl_0.9.8m.bb
+++ b/recipes/openssl/openssl_0.9.8m.bb
@@ -8,9 +8,9 @@ PR = "${INC_PR}.0"
export OE_LDFLAGS="${LDFLAGS}"
-SRC_URI += "file://configure-targets.patch;patch=1 \
- file://shared-libs.patch;patch=1 \
- file://debian.patch;patch=1 \
- file://oe-ldflags.patch;patch=1"
+SRC_URI += "file://configure-targets.patch;apply=yes \
+ file://shared-libs.patch;apply=yes \
+ file://debian.patch;apply=yes \
+ file://oe-ldflags.patch;apply=yes"
PARALLEL_MAKE = ""
diff --git a/recipes/openssl/openssl_1.0.0.bb b/recipes/openssl/openssl_1.0.0.bb
index 9f63701174..e29f856f45 100644
--- a/recipes/openssl/openssl_1.0.0.bb
+++ b/recipes/openssl/openssl_1.0.0.bb
@@ -11,12 +11,12 @@ DEFAULT_PREFERENCE = "-1"
export DIRS = "crypto ssl apps engines"
export OE_LDFLAGS="${LDFLAGS}"
-SRC_URI += "file://configure-targets.patch;patch=1 \
- file://shared-libs.patch;patch=1 \
- file://debian.patch;patch=1 \
- file://oe-ldflags.patch;patch=1 \
- file://libdeps-first.patch;patch=1 \
- file://engines-install-in-libdir-ssl.patch;patch=1 \
+SRC_URI += "file://configure-targets.patch;apply=yes \
+ file://shared-libs.patch;apply=yes \
+ file://debian.patch;apply=yes \
+ file://oe-ldflags.patch;apply=yes \
+ file://libdeps-first.patch;apply=yes \
+ file://engines-install-in-libdir-ssl.patch;apply=yes \
"
PARALLEL_MAKE = ""