aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opensync
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-02 15:04:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-03 07:33:27 +0200
commitd4276bed389b7db06db58c7acebb83f92bff86a5 (patch)
tree2386574b6ab0c36a58a314a24d31f6b5c9291a65 /recipes/opensync
parent823aa270059259ca619e21a5d9b22e86afb12f3b (diff)
downloadopenembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.gz
recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDS
* there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/opensync')
-rw-r--r--recipes/opensync/libopensync-plugin-file_0.18.bb2
-rw-r--r--recipes/opensync/libopensync-plugin-gpe_0.18.bb2
-rw-r--r--recipes/opensync/libopensync-plugin-irmc_0.18.bb2
-rw-r--r--recipes/opensync/libopensync-plugin.inc2
-rw-r--r--recipes/opensync/libsyncml_0.5.4.bb2
5 files changed, 5 insertions, 5 deletions
diff --git a/recipes/opensync/libopensync-plugin-file_0.18.bb b/recipes/opensync/libopensync-plugin-file_0.18.bb
index cf44183836..510ed28256 100644
--- a/recipes/opensync/libopensync-plugin-file_0.18.bb
+++ b/recipes/opensync/libopensync-plugin-file_0.18.bb
@@ -3,7 +3,7 @@ SRC_URI = "http://ewi546.ewi.utwente.nl/OE/source/${P}.tar.gz"
LICENSE = "LGPL"
DEPENDS = "libopensync"
-RRECOMMENDS = "multisync"
+RRECOMMENDS_${PN} = "multisync"
HOMEPAGE = "http://www.opensync.org/"
inherit autotools pkgconfig
diff --git a/recipes/opensync/libopensync-plugin-gpe_0.18.bb b/recipes/opensync/libopensync-plugin-gpe_0.18.bb
index bfdaa342d8..18b2951242 100644
--- a/recipes/opensync/libopensync-plugin-gpe_0.18.bb
+++ b/recipes/opensync/libopensync-plugin-gpe_0.18.bb
@@ -3,7 +3,7 @@ SRC_URI = "http://ewi546.ewi.utwente.nl/OE/source/${P}.tar.gz"
LICENSE = "LGPL"
DEPENDS = "libopensync"
-RRECOMMENDS = "multisync"
+RRECOMMENDS_${PN} = "multisync"
HOMEPAGE = "http://www.opensync.org/"
inherit autotools pkgconfig
diff --git a/recipes/opensync/libopensync-plugin-irmc_0.18.bb b/recipes/opensync/libopensync-plugin-irmc_0.18.bb
index e418b6c979..9e8ff19a8e 100644
--- a/recipes/opensync/libopensync-plugin-irmc_0.18.bb
+++ b/recipes/opensync/libopensync-plugin-irmc_0.18.bb
@@ -3,7 +3,7 @@ SRC_URI = "http://ewi546.ewi.utwente.nl/OE/source/${P}.tar.gz"
LICENSE = "LGPL"
DEPENDS = "libopensync openobex bluez-libs"
-RRECOMMENDS = "multisync"
+RRECOMMENDS_${PN} = "multisync"
HOMEPAGE = "http://www.opensync.org/"
inherit autotools pkgconfig
diff --git a/recipes/opensync/libopensync-plugin.inc b/recipes/opensync/libopensync-plugin.inc
index b1986a9e64..99e0c783ba 100644
--- a/recipes/opensync/libopensync-plugin.inc
+++ b/recipes/opensync/libopensync-plugin.inc
@@ -7,7 +7,7 @@ S ?= "${WORKDIR}/${PLUGIN_NAME}"
LICENSE ?= "LGPL"
DEPENDS += " libopensync"
-RRECOMMENDS += " msynctool"
+RRECOMMENDS_${PN} += " msynctool"
HOMEPAGE ?= "http://www.opensync.org/"
inherit autotools pkgconfig
diff --git a/recipes/opensync/libsyncml_0.5.4.bb b/recipes/opensync/libsyncml_0.5.4.bb
index 4bda5ce2d4..edcdcf1605 100644
--- a/recipes/opensync/libsyncml_0.5.4.bb
+++ b/recipes/opensync/libsyncml_0.5.4.bb
@@ -5,7 +5,7 @@ PRIORITY = "optional"
LICENSE = "LGPL"
DEPENDS = "libxml2 glib-2.0"
-RRECOMMENDS = "wbxml2 openobex libsoup"
+RRECOMMENDS_${PN} = "wbxml2 openobex libsoup"
PR = "r1"