aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opensync
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 13:41:38 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-19 08:54:56 +0100
commitea85d940c79995c667eb39cc512b52da72af6144 (patch)
treea22ee4ce8c057468adb3c2b0c6187ddf005f25ac /recipes/opensync
parent5049a1fcc45c60067f5d96704bda851c234f2812 (diff)
downloadopenembedded-ea85d940c79995c667eb39cc512b52da72af6144.tar.gz
libsyncml: add version 0.5.4 from SHR
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/opensync')
-rw-r--r--recipes/opensync/libsyncml_0.5.4.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/opensync/libsyncml_0.5.4.bb b/recipes/opensync/libsyncml_0.5.4.bb
new file mode 100644
index 0000000000..cf5c5b9135
--- /dev/null
+++ b/recipes/opensync/libsyncml_0.5.4.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Libsyncml is an implementation of the SyncML protocol."
+HOMEPAGE = "https://libsyncml.opensync.org/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+
+DEPENDS = "libxml2 glib-2.0"
+RRECOMMENDS = "wbxml2 openobex libsoup"
+
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libsyncml/libsyncml-${PV}.tar.gz \
+ "
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE += " . -B${WORKDIR}/build "
+
+PACKAGES += "${PN}-tools"
+
+FILES_${PN}-tools = "${bindir}"
+FILES_${PN} = "${libdir}/*.so.*"
+
+do_build_prepend() {
+ cd ${WORKDIR}/build
+}
+
+do_install_prepend() {
+ cd ${WORKDIR}/build
+} \ No newline at end of file