aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opie-notes
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-11-18 14:26:39 -0800
committerKhem Raj <raj.khem@gmail.com>2010-11-18 14:28:06 -0800
commit6dd8fa67b3858353765921a2f648459f7170d653 (patch)
tree01acfd7746b6b0e378025348e8793c398fd07368 /recipes/opie-notes
parent8b8142421ee3ed80c9ab74c1c212428c80043d4c (diff)
downloadopenembedded-6dd8fa67b3858353765921a2f648459f7170d653.tar.gz
opie-notes_1.2.4.bb: Fix build errors encountered with gcc 4.5
* This should get us a step closer to compiling opie-image with gcc 4.5 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/opie-notes')
-rw-r--r--recipes/opie-notes/opie-notes-1.2.4/gcc-4.5-non-trivially-copyable-fix.patch62
-rw-r--r--recipes/opie-notes/opie-notes_1.2.4.bb5
2 files changed, 66 insertions, 1 deletions
diff --git a/recipes/opie-notes/opie-notes-1.2.4/gcc-4.5-non-trivially-copyable-fix.patch b/recipes/opie-notes/opie-notes-1.2.4/gcc-4.5-non-trivially-copyable-fix.patch
new file mode 100644
index 0000000000..6c3c625943
--- /dev/null
+++ b/recipes/opie-notes/opie-notes-1.2.4/gcc-4.5-non-trivially-copyable-fix.patch
@@ -0,0 +1,62 @@
+Index: notes/editwindow.cpp
+===================================================================
+--- notes/editwindow.cpp
++++ notes/editwindow.cpp
+@@ -22,7 +22,7 @@ void editWindowWidget::loadFile(QString
+ {
+ if (!file.open(IO_ReadOnly))
+ {
+- QMessageBox::warning(0, tr("File i/o error"), fileName.sprintf(tr("Could not read file '%s'"), fileName));
++ QMessageBox::warning(0, tr("File i/o error"), fileName.sprintf(tr("Could not read file '%s'"), fileName.data()));
+ }
+ else
+ {
+@@ -40,7 +40,7 @@ void editWindowWidget::saveFile(QString
+
+ if(!file.open(IO_WriteOnly))
+ {
+- QMessageBox::warning(0, tr("File i/o error"), fileName.sprintf(tr("Could not write file '%s'"), fileName));
++ QMessageBox::warning(0, tr("File i/o error"), fileName.sprintf(tr("Could not write file '%s'"), fileName.data()));
+ }
+ else
+ {
+Index: notes/mainwindow.cpp
+===================================================================
+--- notes/mainwindow.cpp
++++ notes/mainwindow.cpp
+@@ -57,7 +57,7 @@ mainWindowWidget::mainWindowWidget( QWid
+
+ if(!fileList.mkdir(fileList.absPath()))
+ {
+- QMessageBox::critical(0, tr("i/o error"), text.sprintf(tr("Could not create directory '%s'"), fileList.absPath()));
++ QMessageBox::critical(0, tr("i/o error"), text.sprintf(tr("Could not create directory '%s'"), fileList.absPath().data()).data());
+ }
+ else
+ {
+@@ -65,7 +65,7 @@ mainWindowWidget::mainWindowWidget( QWid
+
+ if(!fileList.mkdir(fileList.absPath()))
+ {
+- QMessageBox::critical(0, tr("i/o error"), text.sprintf(tr("Could not create directory '%s'"), fileList.absPath()));
++ QMessageBox::critical(0, tr("i/o error"), text.sprintf(tr("Could not create directory '%s'"), fileList.absPath().data()).data());
+ }
+ }
+ }
+@@ -154,7 +154,7 @@ void mainWindowWidget::slotItemDuplicate
+ {
+ if (!fileOld.open(IO_ReadOnly))
+ {
+- QMessageBox::warning(0, tr("File i/o error"), fileName.sprintf(tr("Could not read file '%s'"), fileName));
++ QMessageBox::warning(0, tr("File i/o error"), fileName.sprintf(tr("Could not read file '%s'"), fileName.data()));
+ }
+ else
+ {
+@@ -208,7 +208,7 @@ void mainWindowWidget::refreshList()
+
+ if (!file.open(IO_ReadOnly))
+ {
+- QMessageBox::warning(0, tr("File i/o error"), title.sprintf(tr("Could not read file '%s'"), fileList[item]));
++ QMessageBox::warning(0, tr("File i/o error"), title.sprintf(tr("Could not read file '%s'"), fileList[item].data()).data());
+ }
+ else
+ {
diff --git a/recipes/opie-notes/opie-notes_1.2.4.bb b/recipes/opie-notes/opie-notes_1.2.4.bb
index 89ed98e583..3ffe7e1900 100644
--- a/recipes/opie-notes/opie-notes_1.2.4.bb
+++ b/recipes/opie-notes/opie-notes_1.2.4.bb
@@ -1,5 +1,8 @@
require ${PN}.inc
+PR = "r1"
SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/pim/notes \
${HANDHELDS_CVS};tag=${TAG};module=opie/pics \
- ${HANDHELDS_CVS};tag=${TAG};module=opie/apps"
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/apps \
+ file://gcc-4.5-non-trivially-copyable-fix.patch \
+ "