summaryrefslogtreecommitdiffstats
path: root/recipes/opie-taskbar
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/opie-taskbar
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/opie-taskbar')
-rw-r--r--recipes/opie-taskbar/opie-taskbar-images.inc63
-rw-r--r--recipes/opie-taskbar/opie-taskbar-images/firstuse-320x320.jpgbin0 -> 16113 bytes
-rw-r--r--recipes/opie-taskbar/opie-taskbar-images/opie-background-320x320.jpgbin0 -> 7807 bytes
-rw-r--r--recipes/opie-taskbar/opie-taskbar-images_1.2.3+cvs20070922.bb5
-rw-r--r--recipes/opie-taskbar/opie-taskbar-images_1.2.3.bb6
-rw-r--r--recipes/opie-taskbar/opie-taskbar-images_1.2.4.bb6
-rw-r--r--recipes/opie-taskbar/opie-taskbar-images_cvs.bb5
-rw-r--r--recipes/opie-taskbar/opie-taskbar.inc64
-rw-r--r--recipes/opie-taskbar/opie-taskbar/firstuse-path.patch11
-rw-r--r--recipes/opie-taskbar/opie-taskbar/kbdlocks-runtime.patch35
-rw-r--r--recipes/opie-taskbar/opie-taskbar/no-builtin-qss-startup.patch11
-rw-r--r--recipes/opie-taskbar/opie-taskbar/nomax.patch30
-rw-r--r--recipes/opie-taskbar/opie-taskbar/restart-from-bindir.patch12
-rw-r--r--recipes/opie-taskbar/opie-taskbar/server.pro84
-rw-r--r--recipes/opie-taskbar/opie-taskbar_1.2.2.bb13
-rw-r--r--recipes/opie-taskbar/opie-taskbar_1.2.3.bb17
-rw-r--r--recipes/opie-taskbar/opie-taskbar_1.2.4.bb17
-rw-r--r--recipes/opie-taskbar/opie-taskbar_cvs.bb18
18 files changed, 397 insertions, 0 deletions
diff --git a/recipes/opie-taskbar/opie-taskbar-images.inc b/recipes/opie-taskbar/opie-taskbar-images.inc
new file mode 100644
index 0000000000..b35dd8d593
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar-images.inc
@@ -0,0 +1,63 @@
+DESCRIPTION = "Opie Launcher and Taskbar"
+SECTION = "opie/base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RPROVIDES = "${PN}"
+APPNAME = "qpe"
+
+S = "${WORKDIR}/pics"
+
+inherit opie
+
+# Wallpaper and welcome splash
+PIXMAP_SIZE = ""
+PIXMAP_SIZE_c7x0 = "-640x480"
+PIXMAP_SIZE_spitz = "-640x480"
+PIXMAP_SIZE_akita = "-640x480"
+PIXMAP_SIZE_tosa = "-480x640"
+PIXMAP_SIZE_simpad = "-800x600"
+PIXMAP_SIZE_asus730 = "-480x640"
+PIXMAP_SIZE_htcuniversal= "-480x640"
+PIXMAP_SIZE_hx4700 = "-480x640"
+PIXMAP_SIZE_palmz31 = "-160x160"
+PIXMAP_SIZE_palmz71 = "-320x320"
+PIXMAP_SIZE_palmz72 = "-320x320"
+PIXMAP_SIZE_palmt650 = "-320x320"
+PIXMAP_SIZE_palmt680 = "-320x320"
+PIXMAP_SIZE_palmt3 = "-320x480"
+PIXMAP_SIZE_palmt5 = "-320x480"
+PIXMAP_SIZE_palmtx = "-320x480"
+PIXMAP_SIZE_palmld = "-320x480"
+
+do_configure() {
+ :
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/launcher
+
+ install -m 0644 ${WORKDIR}/pics/launcher/firstuse.jpg ${D}${palmtopdir}/pics/launcher/firstuse-240x320.jpg
+ install -m 0644 ${WORKDIR}/pics/launcher/opie-background.jpg ${D}${palmtopdir}/pics/launcher/opie-background-240x320.jpg
+
+# for res in 320x240 240x320 320x320 320x480 480x320 480x640 640x480 600x800 800x600; do
+ for res in 240x240 320x320 320x480 480x320 480x640 640x480 800x600; do
+ install -m 0644 ${WORKDIR}/pics/launcher/firstuse-${res}.jpg ${D}${palmtopdir}/pics/launcher/firstuse-${res}.jpg
+ install -m 0644 ${WORKDIR}/pics/launcher/opie-background-${res}.jpg ${D}${palmtopdir}/pics/launcher/opie-background-${res}.jpg
+ done
+}
+
+python do_package_prepend () {
+ reslist = ['240x320','320x240', '320x320', '320x480', '480x320', '480x640','640x480', '800x600','600x800']
+ dir = bb.data.expand('${palmtopdir}/pics/launcher/', d)
+ ft = bb.data.expand('${palmtopdir}/pics/*/*-%s.*', d)
+ pn = bb.data.getVar('PN', d, 1)
+ for res in reslist:
+ bb.data.setVar('FILES_%s-%s' % (pn,res), ft % res, d )
+ postinst = ''
+ postinst = 'update-alternatives --install %sfirstuse.jpg opie-firstuse-pixmap %sfirstuse-%s.jpg 50\n' % (dir,dir,res)
+ postinst += 'update-alternatives --install %sopie-background.jpg opie-background-pixmap %sopie-background-%s.jpg 50\n' % (dir,dir,res)
+ bb.data.setVar('pkg_postinst_%s-%s' % (pn,res),postinst, d)
+}
+
+PACKAGE_ARCH = "all"
+PACKAGES = "${PN}-dbg ${PN}-320x480 ${PN}-480x320 ${PN}-480x640 ${PN}-640x480 ${PN}-800x600 ${PN}-600x800 ${PN}-320x240 ${PN}-240x320 ${PN}-320x320"
diff --git a/recipes/opie-taskbar/opie-taskbar-images/firstuse-320x320.jpg b/recipes/opie-taskbar/opie-taskbar-images/firstuse-320x320.jpg
new file mode 100644
index 0000000000..67523f1291
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar-images/firstuse-320x320.jpg
Binary files differ
diff --git a/recipes/opie-taskbar/opie-taskbar-images/opie-background-320x320.jpg b/recipes/opie-taskbar/opie-taskbar-images/opie-background-320x320.jpg
new file mode 100644
index 0000000000..194816f1e1
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar-images/opie-background-320x320.jpg
Binary files differ
diff --git a/recipes/opie-taskbar/opie-taskbar-images_1.2.3+cvs20070922.bb b/recipes/opie-taskbar/opie-taskbar-images_1.2.3+cvs20070922.bb
new file mode 100644
index 0000000000..a36e85b34d
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar-images_1.2.3+cvs20070922.bb
@@ -0,0 +1,5 @@
+require ${PN}.inc
+
+PR = "r1"
+SRCDATE = "20070922"
+SRC_URI = "${HANDHELDS_CVS};module=opie/pics"
diff --git a/recipes/opie-taskbar/opie-taskbar-images_1.2.3.bb b/recipes/opie-taskbar/opie-taskbar-images_1.2.3.bb
new file mode 100644
index 0000000000..74b6c5205e
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar-images_1.2.3.bb
@@ -0,0 +1,6 @@
+require ${PN}.inc
+
+PR = "r2"
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/pics"
+
+TAG = "${@'v' + bb.data.getVar('PV',d,1).replace('.', '_')}"
diff --git a/recipes/opie-taskbar/opie-taskbar-images_1.2.4.bb b/recipes/opie-taskbar/opie-taskbar-images_1.2.4.bb
new file mode 100644
index 0000000000..afffae51f0
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar-images_1.2.4.bb
@@ -0,0 +1,6 @@
+require ${PN}.inc
+
+PR = "r0"
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/pics"
+
+TAG = "${@'v' + bb.data.getVar('PV',d,1).replace('.', '_')}"
diff --git a/recipes/opie-taskbar/opie-taskbar-images_cvs.bb b/recipes/opie-taskbar/opie-taskbar-images_cvs.bb
new file mode 100644
index 0000000000..3d45118134
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar-images_cvs.bb
@@ -0,0 +1,5 @@
+require ${PN}.inc
+
+PV = "${OPIE_CVS_PV}"
+PR = "r7"
+SRC_URI = "${HANDHELDS_CVS};module=opie/pics"
diff --git a/recipes/opie-taskbar/opie-taskbar.inc b/recipes/opie-taskbar/opie-taskbar.inc
new file mode 100644
index 0000000000..4f43e550b9
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar.inc
@@ -0,0 +1,64 @@
+DESCRIPTION = "Opie Launcher and Taskbar"
+SECTION = "opie/base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "opie-libqrsync opie-qss"
+# Unfortunately, ipkg has buggy handling of Rdepends to multiple packages with the same Provides.
+# Instead of seeing if something in package package lists selects needed package among the rest
+# or errors out otherwise, it just install random package which has needed Provides. So, comment
+# this out.
+#RDEPENDS = "opie-taskbar-images"
+APPNAME = "qpe"
+
+S = "${WORKDIR}/launcher"
+
+inherit opie
+
+do_configure_prepend() {
+ ln -s ${WORKDIR}/calibrate ${S}/calibrate
+ ln -s ${WORKDIR}/mediummount ${S}/mediummount
+ install -m 0644 ${WORKDIR}/server.pro ${S}/server.pro
+}
+
+do_stage() {
+ install obexinterface.h ${STAGING_INCDIR}/
+
+}
+
+SECTIONS = "1Pim Applications Examples Games Opie-SH Python Settings"
+PICS = "opielogo32x32.png start_button.png new_wait.png opielogo16x16.png sidebar.png"
+
+do_install() {
+ install -d ${D}${bindir}
+ for i in ${SECTIONS}
+ do
+ install -d ${D}${palmtopdir}/apps/$i/
+ install -m 0644 ${WORKDIR}/apps/$i/.directory ${D}${palmtopdir}/apps/$i/
+ done
+ install -d ${D}${palmtopdir}/pics/launcher
+ install -d ${D}${palmtopdir}/pics/logo
+ install -d ${D}${palmtopdir}/pics/RoH/star/
+ install -d ${D}${palmtopdir}/etc/colors
+ install -d ${D}${palmtopdir}/etc/skel
+ install -d ${D}${sysconfdir}
+
+ install -m 0755 ${S}/qpe ${D}${bindir}/qpe
+ install -m 0644 ${WORKDIR}/apps/Settings/calibrate.desktop ${D}${palmtopdir}/apps/Settings/
+ install -m 0644 ${WORKDIR}/apps/Settings/quit.desktop ${D}${palmtopdir}/apps/Settings/
+
+ for p in ${PICS}
+ do
+ install -m 0644 ${WORKDIR}/pics/launcher/$p ${D}${palmtopdir}/pics/launcher/$p
+ done
+
+ install -m 0644 ${WORKDIR}/pics/logo/*.* ${D}${palmtopdir}/pics/logo/
+ install -m 0644 ${WORKDIR}/pics/RoH/star/*.png ${D}${palmtopdir}/pics/RoH/star/
+
+ install -m 0644 ${WORKDIR}/etc/colors/*.scheme ${D}${palmtopdir}/etc/colors/
+ install -m 0644 ${WORKDIR}/etc/mime.types ${D}${sysconfdir}/
+
+ install -m 0644 ${WORKDIR}/pics/capslock.xpm ${D}${palmtopdir}/pics/
+ install -m 0644 ${WORKDIR}/pics/numlock.xpm ${D}${palmtopdir}/pics/
+}
+
+FILES_opie-taskbar_append = " ${sysconfdir} ${palmtopdir}/apps ${palmtopdir}/pics"
diff --git a/recipes/opie-taskbar/opie-taskbar/firstuse-path.patch b/recipes/opie-taskbar/opie-taskbar/firstuse-path.patch
new file mode 100644
index 0000000000..636eb81675
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar/firstuse-path.patch
@@ -0,0 +1,11 @@
+--- launcher/firstuse.cpp 2007-10-14 12:47:55.000000000 +1300
++++ launcher/firstuse.cpp 2007-10-14 13:58:54.000000000 +1300
+@@ -124,7 +124,7 @@
+ #endif
+
+ for ( int i = 0; settingsTable[i].app; i++ ) {
+- QString file = QPEApplication::qpeDir() + "bin/";
++ QString file = OPIE_BINDIR + QString("/");
+ file += settingsTable[i].app;
+ file += exeSuffix;
+ if ( QFile::exists(file) )
diff --git a/recipes/opie-taskbar/opie-taskbar/kbdlocks-runtime.patch b/recipes/opie-taskbar/opie-taskbar/kbdlocks-runtime.patch
new file mode 100644
index 0000000000..e356682768
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar/kbdlocks-runtime.patch
@@ -0,0 +1,35 @@
+--- launcher/taskbar.h.org 2004-08-23 00:35:22.000000000 +0300
++++ launcher/taskbar.h 2007-07-04 19:23:54.000000000 +0300
+@@ -84,6 +84,7 @@
+ LockKeyState* lockState;
+ StartMenu *sm;
+ bool resizeRunningApp;
++ bool showKbdLockState;
+ };
+
+
+--- launcher/taskbar.cpp.org 2005-07-04 01:13:00.000000000 +0300
++++ launcher/taskbar.cpp 2007-07-04 19:24:48.000000000 +0300
+@@ -213,12 +213,9 @@
+ (void)new SafeMode( this );
+ #endif
+
+- // ## make customizable in some way?
+-#ifdef OPIE_TASKBAR_LOCK_KEY_STATE
+- lockState = new LockKeyState( this );
+-#else
+ lockState = 0;
+-#endif
++ if ( showKbdLockState )
++ lockState = new LockKeyState( this );
+
+ #if defined(Q_WS_QWS)
+ #if !defined(QT_NO_COP)
+@@ -388,6 +385,7 @@
+ Config cfg( "Launcher" );
+ cfg.setGroup( "InputMethods" );
+ resizeRunningApp = cfg.readBoolEntry( "Resize", true );
++ showKbdLockState = cfg.readBoolEntry( "ShowKbdLocks", true );
+ }
+
+ #include "taskbar.moc"
diff --git a/recipes/opie-taskbar/opie-taskbar/no-builtin-qss-startup.patch b/recipes/opie-taskbar/opie-taskbar/no-builtin-qss-startup.patch
new file mode 100644
index 0000000000..349b28675b
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar/no-builtin-qss-startup.patch
@@ -0,0 +1,11 @@
+--- launcher/server.cpp.org 2007-05-01 20:55:01.000000000 +0000
++++ launcher/server.cpp 2007-05-03 04:48:45.000000000 +0000
+@@ -1009,6 +1009,8 @@
+ }
+
+ void Server::startSoundServer() {
++ owarn << "Sound server (qss) now needs to be started standalone" << oendl;
++ return;
+ if ( !process ) {
+ process = new Opie::Core::OProcess( this );
+ connect(process, SIGNAL(processExited(Opie::Core::OProcess*)),
diff --git a/recipes/opie-taskbar/opie-taskbar/nomax.patch b/recipes/opie-taskbar/opie-taskbar/nomax.patch
new file mode 100644
index 0000000000..468038b377
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar/nomax.patch
@@ -0,0 +1,30 @@
+--- opie-x86/core/launcher/server.cpp~nomax
++++ opie-x86/core/launcher/server.cpp
+@@ -76,7 +76,7 @@
+ return 0;
+ #endif
+ }
+-
++#ifndef OPIE_NO_WINDOWED
+ #define FACTORY(T) \
+ static QWidget *new##T( bool maximized ) { \
+ QWidget *w = new T( 0, 0, QWidget::WDestructiveClose | QWidget::WGroupLeader ); \
+@@ -90,7 +90,18 @@
+ w->show(); \
+ return w; \
+ }
++#else
++#define FACTORY(T) \
++ static QWidget *new##T( bool maximized ) { \
++ QWidget *w = new T( 0, 0, QWidget::WDestructiveClose | QWidget::WGroupLeader ); \
++ if ( maximized ) { \
++ w->showMaximized(); \
++} \
++ w->show(); \
++ return w; \
++}
+
++#endif
+
+ #ifdef SINGLE_APP
+ #define APP(a,b,c,d) FACTORY(b)
diff --git a/recipes/opie-taskbar/opie-taskbar/restart-from-bindir.patch b/recipes/opie-taskbar/opie-taskbar/restart-from-bindir.patch
new file mode 100644
index 0000000000..1a73588409
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar/restart-from-bindir.patch
@@ -0,0 +1,12 @@
+diff --git a/serverapp.cpp b/serverapp.cpp
+index 0e92040..b933340 100644
+--- a/serverapp.cpp
++++ b/serverapp.cpp
+@@ -763,6 +763,7 @@ void ServerApplication::restart()
+ for ( int fd = 3; fd < 100; fd++ )
+ close( fd );
+ execl( ( qpeDir() + "/bin/qpe" ).local8Bit(), "qpe", NULL );
++ execl( OPIE_BINDIR "/qpe", "qpe", NULL );
+ exit( 1 );
+ #endif
+ }
diff --git a/recipes/opie-taskbar/opie-taskbar/server.pro b/recipes/opie-taskbar/opie-taskbar/server.pro
new file mode 100644
index 0000000000..2dee9a973a
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar/server.pro
@@ -0,0 +1,84 @@
+TEMPLATE = app
+
+CONFIG += qt warn_on
+
+DESTDIR =
+
+HEADERS += server.h \
+ qrr.h \
+ serverinterface.h \
+ launchertab.h \
+ documentlist.h \
+ appicons.h \
+ taskbar.h \
+ runningappbar.h \
+ applauncher.h \
+ stabmon.h \
+ inputmethods.h \
+ systray.h \
+ wait.h \
+ shutdownimpl.h \
+ launcher.h \
+ launcherview.h \
+ calibrate/calibrate.h \
+ startmenu.h \
+ transferserver.h \
+ qcopbridge.h \
+ packageslave.h \
+ irserver.h \
+ firstuse.h \
+ syncdialog.h \
+ serverapp.h \
+ qprocess.h \
+ screensaver.h \
+ mediummount/mediumwidget.h \
+ mediadlg.h
+
+SOURCES += server.cpp \
+ qrr.cpp \
+ serverinterface.cpp \
+ launchertab.cpp \
+ documentlist.cpp \
+ appicons.cpp \
+ taskbar.cpp \
+ runningappbar.cpp \
+ applauncher.cpp \
+ stabmon.cpp \
+ inputmethods.cpp \
+ systray.cpp \
+ wait.cpp \
+ shutdownimpl.cpp \
+ launcher.cpp \
+ launcherview.cpp \
+ calibrate/calibrate.cpp \
+ transferserver.cpp \
+ packageslave.cpp \
+ irserver.cpp \
+ qcopbridge.cpp \
+ startmenu.cpp \
+ main.cpp \
+ firstuse.cpp \
+ syncdialog.cpp \
+ serverapp.cpp \
+ qprocess.cpp \
+ qprocess_unix.cpp \
+ screensaver.cpp \
+ mediummount/mediumwidget.cc \
+ mediadlg.cpp
+
+
+INCLUDEPATH += calibrate
+DEPENDPATH += calibrate
+
+INCLUDEPATH += $(OPIEDIR)/include rsync
+DEPENDPATH += rsync
+
+INCLUDEPATH += mediummount
+DEPENDPATH += mediummount
+
+
+TARGET = qpe
+
+LIBS = -lqpe -lopiecore2 -lopieui2 -lopiesecurity2 -lqrsync
+
+include ( $(OPIEDIR)/include.pro )
diff --git a/recipes/opie-taskbar/opie-taskbar_1.2.2.bb b/recipes/opie-taskbar/opie-taskbar_1.2.2.bb
new file mode 100644
index 0000000000..497bff0953
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar_1.2.2.bb
@@ -0,0 +1,13 @@
+require ${PN}.inc
+PR = "r7"
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/apps/calibrate \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/settings/mediummount \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/core/launcher \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/pics \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/apps \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/root \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/etc \
+ file://nomax.patch;patch=1;pnum=3 \
+ file://server.pro \
+ "
diff --git a/recipes/opie-taskbar/opie-taskbar_1.2.3.bb b/recipes/opie-taskbar/opie-taskbar_1.2.3.bb
new file mode 100644
index 0000000000..c22e3bed5f
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar_1.2.3.bb
@@ -0,0 +1,17 @@
+require ${PN}.inc
+PR = "r0"
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/apps/calibrate \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/settings/mediummount \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/core/launcher \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/pics \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/apps \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/root \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/etc \
+ file://nomax.patch;patch=1;pnum=3 \
+ file://no-builtin-qss-startup.patch;patch=1 \
+ file://kbdlocks-runtime.patch;patch=1 \
+ file://restart-from-bindir.patch;patch=1 \
+ file://server.pro \
+ file://firstuse-path.patch;patch=1 \
+ "
diff --git a/recipes/opie-taskbar/opie-taskbar_1.2.4.bb b/recipes/opie-taskbar/opie-taskbar_1.2.4.bb
new file mode 100644
index 0000000000..c22e3bed5f
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar_1.2.4.bb
@@ -0,0 +1,17 @@
+require ${PN}.inc
+PR = "r0"
+
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/apps/calibrate \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/settings/mediummount \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/core/launcher \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/pics \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/apps \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/root \
+ ${HANDHELDS_CVS};tag=${TAG};module=opie/etc \
+ file://nomax.patch;patch=1;pnum=3 \
+ file://no-builtin-qss-startup.patch;patch=1 \
+ file://kbdlocks-runtime.patch;patch=1 \
+ file://restart-from-bindir.patch;patch=1 \
+ file://server.pro \
+ file://firstuse-path.patch;patch=1 \
+ "
diff --git a/recipes/opie-taskbar/opie-taskbar_cvs.bb b/recipes/opie-taskbar/opie-taskbar_cvs.bb
new file mode 100644
index 0000000000..e84e35d820
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar_cvs.bb
@@ -0,0 +1,18 @@
+require ${PN}.inc
+PV = "${OPIE_CVS_PV}"
+PR = "r16"
+
+SRC_URI = "${HANDHELDS_CVS};module=opie/core/apps/calibrate \
+ ${HANDHELDS_CVS};module=opie/noncore/settings/mediummount \
+ ${HANDHELDS_CVS};module=opie/core/launcher \
+ ${HANDHELDS_CVS};module=opie/pics \
+ ${HANDHELDS_CVS};module=opie/apps \
+ ${HANDHELDS_CVS};module=opie/root \
+ ${HANDHELDS_CVS};module=opie/etc \
+ file://nomax.patch;patch=1;pnum=3 \
+ file://no-builtin-qss-startup.patch;patch=1 \
+ file://kbdlocks-runtime.patch;patch=1 \
+ file://restart-from-bindir.patch;patch=1 \
+ file://server.pro \
+ file://firstuse-path.patch;patch=1 \
+ "