summaryrefslogtreecommitdiffstats
path: root/recipes/opie-taskbar
diff options
context:
space:
mode:
authorPaul Eggleton <bluelightning@bluelightning.org>2010-04-04 21:44:01 +0100
committerPaul Eggleton <bluelightning@bluelightning.org>2010-04-04 21:44:01 +0100
commitb78d3343acaa77109130ee48050942e7325a7319 (patch)
tree4f9448e55344c32b6dea09e31baa4ce2f7ccd989 /recipes/opie-taskbar
parent96f0c3857053e91feeb4ebbcdf3136553799abac (diff)
downloadopenembedded-b78d3343acaa77109130ee48050942e7325a7319.tar.gz
opie-taskbar: force calibration on first start
Since we install default /etc/pointercal files that aren't perfect for all devices, this patch forces Opie to do a screen calibration during the first start wizard regardless of whether the pointercal file exists or not. Signed-off-by: Paul Eggleton <bluelightning@bluelightning.org>
Diffstat (limited to 'recipes/opie-taskbar')
-rw-r--r--recipes/opie-taskbar/opie-taskbar/force-firstuse-calibrate.patch20
-rw-r--r--recipes/opie-taskbar/opie-taskbar_1.2.4.bb3
2 files changed, 22 insertions, 1 deletions
diff --git a/recipes/opie-taskbar/opie-taskbar/force-firstuse-calibrate.patch b/recipes/opie-taskbar/opie-taskbar/force-firstuse-calibrate.patch
new file mode 100644
index 0000000000..44d5d25659
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar/force-firstuse-calibrate.patch
@@ -0,0 +1,20 @@
+diff --git a/core/launcher/firstuse.cpp b/core/launcher/firstuse.cpp
+index 8c02ab0..cf731c2 100644
+--- launcher/firstuse.cpp
++++ launcher/firstuse.cpp
+@@ -175,10 +175,13 @@ FirstUse::FirstUse(QWidget* parent, const char * name, WFlags wf) :
+ m_calHandler = ( QWSServer::mouseHandler() && QWSServer::mouseHandler()->inherits("QCalibratedMouseHandler") ) ? true : false;
+
+ if ( m_calHandler) {
+- if ( !QFile::exists("/etc/pointercal") ) {
++ // Since Angstrom is installing default pointer calibration files
++ // that don't match everyone's devices, we need to force calibration
++ // on first use.
++// if ( !QFile::exists("/etc/pointercal") ) {
+ needCalibrate = TRUE;
+ grabMouse();
+- }
++// }
+ }
+
+ Config config("locale");
diff --git a/recipes/opie-taskbar/opie-taskbar_1.2.4.bb b/recipes/opie-taskbar/opie-taskbar_1.2.4.bb
index b5660451a6..a9df7c9527 100644
--- a/recipes/opie-taskbar/opie-taskbar_1.2.4.bb
+++ b/recipes/opie-taskbar/opie-taskbar_1.2.4.bb
@@ -1,5 +1,5 @@
require ${PN}.inc
-PR = "r3"
+PR = "r4"
SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/apps/calibrate \
${HANDHELDS_CVS};tag=${TAG};module=opie/noncore/settings/mediummount \
@@ -14,4 +14,5 @@ SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/apps/calibrate \
file://restart-from-bindir.patch;patch=1 \
file://server-pro-1.2.4.patch;patch=1 \
file://firstuse-path.patch;patch=1 \
+ file://force-firstuse-calibrate.patch;patch=1 \
"