summaryrefslogtreecommitdiffstats
path: root/recipes/opkg-utils
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/opkg-utils
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/opkg-utils')
-rw-r--r--recipes/opkg-utils/opkg-utils-native_svn.bb10
-rw-r--r--recipes/opkg-utils/opkg-utils_svn.bb18
2 files changed, 28 insertions, 0 deletions
diff --git a/recipes/opkg-utils/opkg-utils-native_svn.bb b/recipes/opkg-utils/opkg-utils-native_svn.bb
new file mode 100644
index 0000000000..0495b1eda3
--- /dev/null
+++ b/recipes/opkg-utils/opkg-utils-native_svn.bb
@@ -0,0 +1,10 @@
+require opkg-utils_svn.bb
+
+RDEPENDS = ""
+
+inherit native
+
+# Avoid circular dependencies from package_ipk.bbclass
+PACKAGES = ""
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/opkg-utils"
+
diff --git a/recipes/opkg-utils/opkg-utils_svn.bb b/recipes/opkg-utils/opkg-utils_svn.bb
new file mode 100644
index 0000000000..4c3c0905ea
--- /dev/null
+++ b/recipes/opkg-utils/opkg-utils_svn.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "OPKG Package Manager Utilities"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "python"
+PR = "r2"
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http"
+
+S = "${WORKDIR}/opkg-utils"
+
+inherit autotools
+
+S = "${WORKDIR}/opkg-utils"
+
+do_stage () {
+ autotools_stage_all
+}