aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opkg
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2009-12-05 00:13:48 -0600
committerMike Westerhof <mwester@dls.net>2009-12-05 00:13:48 -0600
commit61a645370233e5f5fd3b5ae7a3019e4ecf2aad5c (patch)
treefcc0261c2b7afadcc31393f18d6a96c7322f64e3 /recipes/opkg
parent0eaa9e1083907b93976bca23499077e990ed3279 (diff)
downloadopenembedded-61a645370233e5f5fd3b5ae7a3019e4ecf2aad5c.tar.gz
opkg: add opkg-nogpg-nocurl-slugos recipe, update slugos.conf to use it.
This is a temporary measure made necessary by a major set of changes to the entire set of opkg recipes that not only rendered older versions of opkg sources unbuildable, it also removed a patch that has not yet been accepted by opkg upstream. Until these issues can be resolved and adequate testing on small-memory devices performed, this copy of the original recipe is a necessary evil that just has to be tolerated.
Diffstat (limited to 'recipes/opkg')
-rw-r--r--recipes/opkg/opkg-nogpg-nocurl-slugos_svn.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/recipes/opkg/opkg-nogpg-nocurl-slugos_svn.bb b/recipes/opkg/opkg-nogpg-nocurl-slugos_svn.bb
new file mode 100644
index 0000000000..5491a28914
--- /dev/null
+++ b/recipes/opkg/opkg-nogpg-nocurl-slugos_svn.bb
@@ -0,0 +1,62 @@
+# This recipe is a regeneration of the original opkg-nogpg-nocurl_svn.bb
+# recipe, intended for temporary use by the SlugOS distro.
+
+# DO NOT USE this recipe for anything other than SlugOS and svn version 160
+# of the opkg sources. Also note that This recipe will be removed without
+# notice when the unfortunate commits to the original opkg-nogpg-nocurl_svn.bb
+# recipe are repaired, the small-memory patches updated to a newer opkg svn
+# version, and appropriate testing confirms that the resulting binary actually
+# works correctly on a 32MB system.
+
+# DO NOT CHANGE THIS RECIPE!
+
+require opkg.inc
+
+DEPENDS = ""
+PROVIDES += "opkg"
+
+SRC_URI += " \
+ file://isatty.patch;patch=1 \
+ file://opkg_wget.patch;patch=1;maxrev=180 \
+ file://reduce-nogpg-noise.patch;patch=1;maxrev=180 \
+ file://opkg_wget_nogpg_01_use_vfork_gunzip.patch;patch=1 \
+ file://opkg_wget_nogpg_02_use_vfork_system.patch;patch=1 \
+ file://opkg_wget_nogpg_03_fix_tmpdirs.patch;patch=1 \
+ file://opkg_wget_nogpg_04_default_tmpdir.patch;patch=1 \
+ "
+PR = "${INC_PR}"
+
+SRCREV = "${SRCREV_pn-opkg}"
+
+EXTRA_OECONF += "--disable-gpg --enable-static --disable-shared"
+
+# Not sure this is needed; needs to be investigated and removed if not
+do_stage() {
+ autotools_stage_all
+}
+
+# The nogpg version isn't getting much love and has an unused variable which trips up -Werror
+do_configure_prepend() {
+ sed -i -e s:-Werror::g ${S}/libopkg/Makefile.am
+}
+
+PACKAGES =+ "libopkg-dev"
+
+FILES_libopkg-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so"
+# not happens automatically for opkg-nogpg:
+FILES_${PN} += "${datadir}/opkg/intercept"
+
+# Define a variable to allow distros to run configure earlier.
+# (for example, to enable loading of ethernet kernel modules before networking starts)
+OPKG_INIT_POSITION = "98"
+OPKG_INIT_POSITION_slugos = "41"
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
+}
+
+pkg_postrm_${PN} () {
+ update-alternatives --remove opkg ${bindir}/opkg-cl
+}
+
+DEFAULT_PREFERENCE = "-1"