aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opkg
diff options
context:
space:
mode:
authorMario Domenech Goulart <mario@ossystems.com.br>2009-06-23 16:07:19 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2009-07-10 14:25:48 -0300
commit9756c8d5940e5f067c97dd37e2f30704eaa0927f (patch)
treed426d77cee9cc94af2b57d9a12543ff0f778ff80 /recipes/opkg
parent68c5927ab4971e93f4a5929b6e28edce92c53b8b (diff)
downloadopenembedded-9756c8d5940e5f067c97dd37e2f30704eaa0927f.tar.gz
opkg-native: use OE's libdir instead of hardcoded /usr/lib for update-alternatives
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes/opkg')
-rw-r--r--recipes/opkg/files/opkg-libdir.patch11
-rw-r--r--recipes/opkg/opkg-native_svn.bb2
2 files changed, 13 insertions, 0 deletions
diff --git a/recipes/opkg/files/opkg-libdir.patch b/recipes/opkg/files/opkg-libdir.patch
new file mode 100644
index 0000000000..1d48b9a6bf
--- /dev/null
+++ b/recipes/opkg/files/opkg-libdir.patch
@@ -0,0 +1,11 @@
+--- trunk/utils/update-alternatives.orig 2009-06-23 15:33:56.000000000 -0300
++++ trunk/utils/update-alternatives 2009-06-23 15:34:10.000000000 -0300
+@@ -21,7 +21,7 @@
+ set -e
+
+ # admin dir
+-ad="$OPKG_OFFLINE_ROOT/usr/lib/opkg/alternatives"
++ad="$OPKG_OFFLINE_ROOT/${libdir}/opkg/alternatives"
+
+ usage() {
+ echo "update-alternatives: $*
diff --git a/recipes/opkg/opkg-native_svn.bb b/recipes/opkg/opkg-native_svn.bb
index 82c74e0b86..acd681cb35 100644
--- a/recipes/opkg/opkg-native_svn.bb
+++ b/recipes/opkg/opkg-native_svn.bb
@@ -3,6 +3,8 @@ require opkg.inc
DEPENDS = "curl-native"
PR = "r3"
+SRC_URI += "file://opkg-libdir.patch;patch=1"
+
target_libdir := "${libdir}"
inherit native