aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ortp
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2009-05-09 11:34:04 -0400
committerPhilip Balister <philip@balister.org>2009-05-09 11:34:04 -0400
commit6f53c97f549d7a028bcac511d3430d15dc1b27f8 (patch)
tree2a7b2fb5b082f40e01c762009e77fa899afa0c08 /recipes/ortp
parent2d94bdad65f77ccb1e71c8c34e14cadc4e2dcfe8 (diff)
downloadopenembedded-6f53c97f549d7a028bcac511d3430d15dc1b27f8.tar.gz
ortp-0.13.1 : Add later version of ortp. Convert to use .inc.
* There are later versions, but this version is needed for openbts.
Diffstat (limited to 'recipes/ortp')
-rw-r--r--recipes/ortp/ortp.inc20
-rw-r--r--recipes/ortp/ortp_0.13.1.bb2
-rw-r--r--recipes/ortp/ortp_0.7.1.bb18
3 files changed, 23 insertions, 17 deletions
diff --git a/recipes/ortp/ortp.inc b/recipes/ortp/ortp.inc
new file mode 100644
index 0000000000..c05e9d51cb
--- /dev/null
+++ b/recipes/ortp/ortp.inc
@@ -0,0 +1,20 @@
+DESCRIPTION = "An LGPL implementation of RTP - RFC3550"
+LICENSE = "LGPL"
+DEPENDS = "glibc "
+
+PR = "r1"
+
+inherit autotools pkgconfig
+
+SRC_URI = "http://download.savannah.nongnu.org/releases/linphone/${PN}/sources/${P}.tar.gz"
+
+do_compile_append() {
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ ortp.pc
+
+}
+
+do_stage () {
+ autotools_stage_all
+}
diff --git a/recipes/ortp/ortp_0.13.1.bb b/recipes/ortp/ortp_0.13.1.bb
new file mode 100644
index 0000000000..ae06320421
--- /dev/null
+++ b/recipes/ortp/ortp_0.13.1.bb
@@ -0,0 +1,2 @@
+require ortp.inc
+
diff --git a/recipes/ortp/ortp_0.7.1.bb b/recipes/ortp/ortp_0.7.1.bb
index c05e9d51cb..0318301cfd 100644
--- a/recipes/ortp/ortp_0.7.1.bb
+++ b/recipes/ortp/ortp_0.7.1.bb
@@ -1,20 +1,4 @@
-DESCRIPTION = "An LGPL implementation of RTP - RFC3550"
-LICENSE = "LGPL"
-DEPENDS = "glibc "
+require ortp.inc
PR = "r1"
-inherit autotools pkgconfig
-
-SRC_URI = "http://download.savannah.nongnu.org/releases/linphone/${PN}/sources/${P}.tar.gz"
-
-do_compile_append() {
- sed -i -e s:${STAGING_DIR_TARGET}::g \
- -e s:/${TARGET_SYS}::g \
- ortp.pc
-
-}
-
-do_stage () {
- autotools_stage_all
-}