aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pad
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pad
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pad')
-rw-r--r--recipes/pad/pad-native.bb15
-rwxr-xr-xrecipes/pad/pad/pad.c40
2 files changed, 55 insertions, 0 deletions
diff --git a/recipes/pad/pad-native.bb b/recipes/pad/pad-native.bb
new file mode 100644
index 0000000000..e8c2b6d579
--- /dev/null
+++ b/recipes/pad/pad-native.bb
@@ -0,0 +1,15 @@
+SECTION = "console/utils"
+DESCRIPTION = "Console utility for padding a file (filling with 0 to reach a specified length)"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/pad"
+SRC_URI = "file://pad.c"
+LICENSE = "PD"
+inherit native
+
+do_compile() {
+ cp ${WORKDIR}/pad.c .
+ ${CC} -I. -o pad pad.c
+}
+
+do_stage() {
+ install -m 0755 pad ${STAGING_BINDIR}/
+}
diff --git a/recipes/pad/pad/pad.c b/recipes/pad/pad/pad.c
new file mode 100755
index 0000000000..e81e22504d
--- /dev/null
+++ b/recipes/pad/pad/pad.c
@@ -0,0 +1,40 @@
+#include <stdio.h>
+#include <stdlib.h>
+#include <sys/types.h>
+#include <sys/stat.h>
+#include <unistd.h>
+
+int stat(const char *file_name, struct stat *buf);
+
+int syntax(void)
+{
+ printf("syntax:\n");
+ printf(" pad padnum filename\n");
+ return(0);
+}
+
+int main(int argc, char **argv)
+{
+ FILE *fp;
+ long int i=0L, padsize=0L;
+ unsigned char data=0xff;
+ struct stat fileinfo;
+ if(argc<3){
+ syntax();
+ exit(1);
+ }
+ if((fp=fopen(argv[2],"a"))==NULL){
+ printf("error opening %s.\n",argv[2]);
+ exit(1);
+ }
+ if(stat(argv[2],&fileinfo)!=0){
+ printf("error in stat of %s.\n",argv[2]);
+ exit(1);
+ }
+ padsize = strtol(argv[1],NULL,10) - fileinfo.st_size;
+ for(i=0;i<padsize;i++){
+ fwrite(&data,1,1,fp);
+ }
+ fclose(fp);
+ return(0);
+}