aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pciutils/pciutils_2.2.4.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pciutils/pciutils_2.2.4.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pciutils/pciutils_2.2.4.bb')
-rw-r--r--recipes/pciutils/pciutils_2.2.4.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/recipes/pciutils/pciutils_2.2.4.bb b/recipes/pciutils/pciutils_2.2.4.bb
new file mode 100644
index 0000000000..70a95ca11e
--- /dev/null
+++ b/recipes/pciutils/pciutils_2.2.4.bb
@@ -0,0 +1,60 @@
+DESCRIPTION = 'The PCI Utilities package contains a library for portable access \
+to PCI bus configuration space and several utilities based on this library.'
+DESCRIPTION_pciutils-ids = 'The list of PCI IDs for pciutils'
+SECTION = "console/utils"
+HOMEPAGE = "http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml"
+LICENSE = "GPLv2"
+DEPENDS = "zlib"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/software/utils/pciutils/pciutils-${PV}.tar.bz2 \
+ file://configure.patch;patch=1 \
+ file://configure-uclibc.patch;patch=1 \
+ file://pcimodules-pciutils.diff;patch=1"
+
+PARALLEL_MAKE = ""
+
+PR ="r3"
+
+do_configure () {
+ (cd lib && ./configure ${datadir} ${PV} ${TARGET_OS} 2.4.21 ${TARGET_ARCH})
+}
+
+export PREFIX = "${D}${prefix}"
+export SBINDIR = "${D}${sbindir}"
+export SHAREDIR = "${D}${datadir}"
+export MANDIR = "${D}${mandir}"
+
+LDFLAGS += "-lz"
+
+do_install () {
+ oe_runmake install
+}
+
+do_install_append () {
+ install -d ${D}/${prefix}/share
+ install -m 6440 ${WORKDIR}/${PN}-${PV}/pci.ids ${D}/${prefix}/share
+
+ # The makefile does not install the development files:
+ # libpci.a pci.h header.h config.h types.s
+ install -d ${D}/${libdir}
+ install -d ${D}/${includedir}/pci
+
+ oe_libinstall -a -C lib libpci ${D}/${libdir}
+ install -m 0644 ${S}/lib/pci.h ${D}/${includedir}/pci/
+ install -m 0644 ${S}/lib/header.h ${D}/${includedir}/pci/
+ install -m 0644 ${S}/lib/config.h ${D}/${includedir}/pci/
+ install -m 0644 ${S}/lib/types.h ${D}/${includedir}/pci/
+}
+
+do_stage () {
+ oe_libinstall -a -C lib libpci ${STAGING_LIBDIR}
+ install -m 0755 -d ${STAGING_INCDIR}/pci
+ install -m 0644 ${S}/lib/pci.h ${STAGING_INCDIR}/pci/
+ install -m 0644 ${S}/lib/header.h ${STAGING_INCDIR}/pci/
+ install -m 0644 ${S}/lib/config.h ${STAGING_INCDIR}/pci/
+ install -m 0644 ${S}/lib/types.h ${STAGING_INCDIR}/pci/
+}
+
+
+PACKAGES =+ "pciutils-ids"
+FILES_pciutils-ids="${prefix}/share/pci.ids"