aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pciutils
diff options
context:
space:
mode:
authorJosh Mahonin <jmahonin@cbnco.com>2009-07-20 11:41:00 +0000
committerKoen Kooi <koen@openembedded.org>2009-07-21 12:03:54 +0200
commit1137409282578989b8fb962946d39a9744e2122b (patch)
tree5a369e58e5ab15f5bd78c101177a99175a119f26 /recipes/pciutils
parent614ca036058df95065296fc4f67996af58111788 (diff)
downloadopenembedded-1137409282578989b8fb962946d39a9744e2122b.tar.gz
pciutils_3.1.2.bb: Make sure lspci reads pci.ids.gz from right location
Previously this version of 'lspci' would attempt to open pci.ids, because of incorrect paths at configure-time. New pciutils Makefile makes use of a 'DESTDIR' flag that we can set as the staging directory, and an 'IDSDIR' flag which holds the location of the pci.ids{.gz} files. Also bumped PR. Signed-off-by: Josh Mahonin <jmahonin@cbnco.com> Signed-off-by: Koen Kooi <koen@openembedded.org>
Diffstat (limited to 'recipes/pciutils')
-rw-r--r--recipes/pciutils/pciutils_3.1.2.bb18
1 files changed, 10 insertions, 8 deletions
diff --git a/recipes/pciutils/pciutils_3.1.2.bb b/recipes/pciutils/pciutils_3.1.2.bb
index d7458a1c7a..ae7317ebbf 100644
--- a/recipes/pciutils/pciutils_3.1.2.bb
+++ b/recipes/pciutils/pciutils_3.1.2.bb
@@ -12,7 +12,7 @@ SRC_URI_append_nylon = "file://gcc-3-compatibility.patch;patch=1 "
PARALLEL_MAKE = ""
-PR ="r2"
+PR ="r3"
EXTRA_OEMAKE += "'STRIP = '"
export SHARED=yes
@@ -21,18 +21,20 @@ do_configure () {
(cd lib && ./configure ${datadir} ${PV} ${TARGET_OS} 2.4.21 ${TARGET_ARCH})
}
-export PREFIX = "${D}${prefix}"
-export SBINDIR = "${D}${sbindir}"
-export SHAREDIR = "${D}${datadir}"
-export MANDIR = "${D}${mandir}"
+export DESTDIR = "${D}"
+export PREFIX = "${prefix}"
+export SBINDIR = "${sbindir}"
+export SHAREDIR = "${datadir}"
+export MANDIR = "${mandir}"
+export IDSDIR = "${datadir}"
do_install () {
oe_runmake install
}
do_install_append () {
- install -d ${D}/${prefix}/share
- install -m 6440 ${WORKDIR}/${PN}-${PV}/pci.ids ${D}/${prefix}/share
+ install -d ${D}/${datadir}
+ install -m 6440 ${WORKDIR}/${PN}-${PV}/pci.ids.gz ${D}/${datadir}
# The makefile does not install the development files:
# libpci.so pci.h header.h config.h types.h
@@ -57,4 +59,4 @@ do_stage () {
PACKAGES =+ "pciutils-ids"
-FILES_pciutils-ids="${prefix}/share/pci.ids"
+FILES_pciutils-ids="${datadir}/pci.ids.gz"