aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pciutils
diff options
context:
space:
mode:
authorMartin Dietze <di@fh-wedel.de>2009-05-20 09:41:34 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-20 10:12:39 +0200
commit24db351c88feaa1b7ef23dd20a95d2ce78fb5bd4 (patch)
tree7a96af3157bb280d63e9580e2e5fa300748b5b2a /recipes/pciutils
parent6f393268e4b5d687bc2ca50d63e0bb25050d8439 (diff)
downloadopenembedded-24db351c88feaa1b7ef23dd20a95d2ce78fb5bd4.tar.gz
pciutils: filter out flags that break gcc3
* this is done with a nylon override since we lack gcc3 overrides
Diffstat (limited to 'recipes/pciutils')
-rw-r--r--recipes/pciutils/pciutils-3.1.2/gcc-3-compatibility.patch11
-rw-r--r--recipes/pciutils/pciutils_3.1.2.bb1
2 files changed, 12 insertions, 0 deletions
diff --git a/recipes/pciutils/pciutils-3.1.2/gcc-3-compatibility.patch b/recipes/pciutils/pciutils-3.1.2/gcc-3-compatibility.patch
new file mode 100644
index 0000000000..3a10209323
--- /dev/null
+++ b/recipes/pciutils/pciutils-3.1.2/gcc-3-compatibility.patch
@@ -0,0 +1,11 @@
+--- pciutils-3.1.2/lib/Makefile-orig 2009-02-27 11:31:24.000000000 +0100
++++ pciutils-3.1.2/lib/Makefile 2009-02-27 11:31:32.000000000 +0100
+@@ -50,7 +50,7 @@
+ $(AR) rcs $@ $^
+ $(RANLIB) $@
+ else
+-CFLAGS += -fPIC -fvisibility=hidden
++CFLAGS += -fPIC
+ $(PCILIB): $(addsuffix .o,$(OBJS))
+ $(CC) -shared $(LDFLAGS) $(SONAME) -Wl,--version-script=libpci.ver -o $@ $^ $(LIB_LDLIBS)
+ endif
diff --git a/recipes/pciutils/pciutils_3.1.2.bb b/recipes/pciutils/pciutils_3.1.2.bb
index 25782a5549..d7458a1c7a 100644
--- a/recipes/pciutils/pciutils_3.1.2.bb
+++ b/recipes/pciutils/pciutils_3.1.2.bb
@@ -8,6 +8,7 @@ DEPENDS = "zlib"
SRC_URI = "ftp://ftp.kernel.org/pub/software/utils/pciutils/pciutils-${PV}.tar.bz2 \
file://pciutils.patch;patch=1 "
+SRC_URI_append_nylon = "file://gcc-3-compatibility.patch;patch=1 "
PARALLEL_MAKE = ""