aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-07-26 20:18:50 -0700
committerChris Larson <chris_larson@mentor.com>2010-07-26 20:18:50 -0700
commit1f9ca3be2cf4364dd86032a89704951b30944705 (patch)
tree68aea55f77606cb96224e01a422725f790879a20 /recipes/perl
parent45fc36a32fb23c513833d7e27fb4b9cd8be68fb5 (diff)
downloadopenembedded-1f9ca3be2cf4364dd86032a89704951b30944705.tar.gz
Fix siteinfo issue in perl 5.8.8 and 5.10.1.
Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/perl_5.10.1.bb6
-rw-r--r--recipes/perl/perl_5.8.8.bb4
2 files changed, 6 insertions, 4 deletions
diff --git a/recipes/perl/perl_5.10.1.bb b/recipes/perl/perl_5.10.1.bb
index e7c90d8fc3..f40c896214 100644
--- a/recipes/perl/perl_5.10.1.bb
+++ b/recipes/perl/perl_5.10.1.bb
@@ -35,6 +35,8 @@ SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz;name=perl-${PV} \
SRC_URI[perl-5.10.1.md5sum] = "b9b2fdb957f50ada62d73f43ee75d044"
SRC_URI[perl-5.10.1.sha256sum] = "cb7f26ea4b2b28d6644354d87a269d01cac1b635287dae64e88eeafa24b44f35"
+inherit siteinfo
+
# Where to find the native perl
HOSTPERL = "${STAGING_BINDIR_NATIVE}/perl${PV}"
@@ -57,8 +59,8 @@ do_configure() {
# Generate configuration
rm -f config.sh-${TARGET_ARCH}-${TARGET_OS}
for i in ${WORKDIR}/config.sh \
- ${WORKDIR}/config.sh-${@siteinfo_get_bits(d)} \
- ${WORKDIR}/config.sh-${@siteinfo_get_bits(d)}-${@siteinfo_get_endianess(d)}; do
+ ${WORKDIR}/config.sh-${SITEINFO_BITS} \
+ ${WORKDIR}/config.sh-${SITEINFO_BITS}-${SITEINFO_ENDIANNESS}; do
cat $i >> config.sh-${TARGET_ARCH}-${TARGET_OS}
done
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index 29ae66c66b..bc6cc225aa 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -62,8 +62,8 @@ do_configure() {
# Generate configuration
rm -f config.sh-${TARGET_ARCH}-${TARGET_OS}
for i in ${WORKDIR}/config.sh \
- ${WORKDIR}/config.sh-${@siteinfo_get_bits(d)} \
- ${WORKDIR}/config.sh-${@siteinfo_get_bits(d)}-${@siteinfo_get_endianess(d)}; do
+ ${WORKDIR}/config.sh-${SITEINFO_BITS} \
+ ${WORKDIR}/config.sh-${SITEINFO_BITS}-${SITEINFO_ENDIANNESS}; do
cat $i >> config.sh-${TARGET_ARCH}-${TARGET_OS}
done