aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-03-18 18:07:38 +0300
committerRoman I Khimov <khimov@altell.ru>2010-03-24 00:48:13 +0300
commit23e62756902c2739fdd4ffb628c4cea98f72aaa8 (patch)
tree1564054180d6487d194909dbb929981465b4008c /recipes/perl
parentd0b135ec2b3fccec83b1d6aa93099ae52aaf5d63 (diff)
downloadopenembedded-23e62756902c2739fdd4ffb628c4cea98f72aaa8.tar.gz
libwww-perl: update to version 5.834
Add more dependencies along the way, fix PACKAGE_ARCH. Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/libwww-perl_5.808.bb18
-rw-r--r--recipes/perl/libwww-perl_5.834.bb24
2 files changed, 24 insertions, 18 deletions
diff --git a/recipes/perl/libwww-perl_5.808.bb b/recipes/perl/libwww-perl_5.808.bb
deleted file mode 100644
index 886b5b7e7d..0000000000
--- a/recipes/perl/libwww-perl_5.808.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-DESCRIPTION = "libwww-perl provides a simple and consistent API to the World Wide Web"
-SECTION = "libs"
-LICENSE = "Artistic"
-DEPENDS = "liburi-perl-native"
-RDEPENDS = "liburi-perl"
-PR = "r3"
-
-SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/libwww-perl-${PV}.tar.gz"
-
-S = "${WORKDIR}/libwww-perl-${PV}"
-
-inherit cpan
-
-do_configure_append() {
- sed -i -e "s|PERL_ARCHLIB = /usr/lib/perl/5.8|PERL_ARCHLIB = ${STAGING_LIBDIR_NATIVE}/perl/5.8.8|" Makefile
-}
-
-BBCLASSEXTEND="native"
diff --git a/recipes/perl/libwww-perl_5.834.bb b/recipes/perl/libwww-perl_5.834.bb
new file mode 100644
index 0000000000..784a0c9c29
--- /dev/null
+++ b/recipes/perl/libwww-perl_5.834.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "libwww-perl provides a simple and consistent API to the World Wide Web"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+DEPENDS = "liburi-perl-native libhtml-parser-perl-native libhtml-tagset-perl-native"
+RDEPENDS_${PN} += " \
+ libhtml-parser-perl \
+ libhtml-tagset-perl \
+ liburi-perl \
+ perl-module-digest-md5 \
+ perl-module-net-ftp \
+ "
+BBCLASSEXTEND = "native"
+
+PR = "r0"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/libwww-perl-${PV}.tar.gz;name=libwww-perl-${PV}"
+SRC_URI[libwww-perl-5.834.md5sum] = "f2ed8a461f76556c9caed9087f47c86c"
+SRC_URI[libwww-perl-5.834.sha256sum] = "1a50eb91d1deeca3be10982e129e786809ad6f0f8049b156e91e889e5a7288ff"
+
+S = "${WORKDIR}/libwww-perl-${PV}"
+
+inherit cpan
+
+PACKAGE_ARCH = "all"