aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-05-07 16:59:25 +0200
committerKoen Kooi <koen@openembedded.org>2010-05-07 16:59:25 +0200
commit6267e295d438ec25263529d64f8aef3f14d45342 (patch)
tree34aa6c3083a01285a30b39f03994eaa6e2889129 /recipes/perl
parentc302f739d40c7caa399af1b8d0c6724ac0d5cda2 (diff)
downloadopenembedded-6267e295d438ec25263529d64f8aef3f14d45342.tar.gz
perl-native: fix do_install a bit more
* this doesn't solve the build problem with perl, though
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/perl-native_5.10.1.bb12
-rw-r--r--recipes/perl/perl-native_5.8.8.bb10
2 files changed, 11 insertions, 11 deletions
diff --git a/recipes/perl/perl-native_5.10.1.bb b/recipes/perl/perl-native_5.10.1.bb
index aec8339015..a2b4c76d85 100644
--- a/recipes/perl/perl-native_5.10.1.bb
+++ b/recipes/perl/perl-native_5.10.1.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r2"
+PR = "r3"
NATIVE_INSTALL_WORKS = "1"
# Not tested enough
@@ -74,12 +74,12 @@ do_install() {
ln -sf perl${PV} ${D}${bindir}/hostperl
# Store native config in non-versioned directory
install -d ${D}${libdir}/perl/${PV}/CORE \
- ${D}${STAGING_DATADIR_NATIVE}/perl/${PV}/ExtUtils
- install config.sh ${D}${STAGING_LIBDIR}/perl
+ ${D}${datadir}/perl/${PV}/ExtUtils
+ install config.sh ${D}${libdir}/perl
# target configuration
install lib/Config.pm ${D}${libdir}/perl/${PV}/
- install lib/ExtUtils/xsubpp ${D}${STAGING_DATADIR_NATIVE}/perl/${PV}/ExtUtils/
- install lib/ExtUtils/typemap ${D}${STAGING_DATADIR_NATIVE}/perl/${PV}/ExtUtils/
+ install lib/ExtUtils/xsubpp ${D}${datadir}/perl/${PV}/ExtUtils/
+ install lib/ExtUtils/typemap ${D}${datadir}/perl/${PV}/ExtUtils/
# perl shared library headers
for i in av.h embed.h gv.h keywords.h op.h perlio.h pp.h regexp.h \
uconfig.h XSUB.h cc_runtime.h embedvar.h handy.h opnames.h \
@@ -98,7 +98,7 @@ do_install() {
}
do_install_append_nylon() {
# get rid of definitions not supported by the gcc version we use for nylon...
- for i in ${D}${libdir}/perl/${PV}/Config_heavy.pl ${D}${STAGING_LIBDIR}/perl/config.sh; do
+ for i in ${D}${libdir}/perl/${PV}/Config_heavy.pl ${D}${libdir}/perl/config.sh; do
perl -pi -e 's/-Wdeclaration-after-statement //g' ${i}
done
}
diff --git a/recipes/perl/perl-native_5.8.8.bb b/recipes/perl/perl-native_5.8.8.bb
index e8706e8f24..fa27326ccf 100644
--- a/recipes/perl/perl-native_5.8.8.bb
+++ b/recipes/perl/perl-native_5.8.8.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r18"
+PR = "r19"
NATIVE_INSTALL_WORKS = "1"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/perl-${PV}"
@@ -71,13 +71,13 @@ do_install() {
ln -sf perl${PV} ${D}${bindir}/hostperl
# Store native config in non-versioned directory
install -d ${D}${libdir}/perl/${PV}/CORE \
- ${D}${STAGING_DATADIR_NATIVE}/perl/${PV}/ExtUtils
- install config.sh ${D}${STAGING_LIBDIR}/perl
+ ${D}${datadir}/perl/${PV}/ExtUtils
+ install config.sh ${D}${libdir}/perl
# Fix Errno.pm for target builds
sed -i -r "s,^\tdie\ (\"Errno\ architecture.+)$,\twarn\ \1," ${D}${libdir}/perl/${PV}/Errno.pm
# target configuration
install lib/Config.pm ${D}${libdir}/perl/${PV}/
- install lib/ExtUtils/typemap ${D}${STAGING_DATADIR_NATIVE}/perl/${PV}/ExtUtils/
+ install lib/ExtUtils/typemap ${D}${datadir}/perl/${PV}/ExtUtils/
# perl shared library headers
for i in av.h embed.h gv.h keywords.h op.h perlio.h pp.h regexp.h \
uconfig.h XSUB.h cc_runtime.h embedvar.h handy.h opnames.h \
@@ -94,7 +94,7 @@ do_install() {
do_install_append_nylon() {
# get rid of definitions not supported by the gcc version we use for nylon...
- for i in ${D}${libdir}/perl/${PV}/Config_heavy.pl ${D}${STAGING_LIBDIR}/perl/config.sh; do
+ for i in ${D}${libdir}/perl/${PV}/Config_heavy.pl ${D}${libdir}/perl/config.sh; do
perl -pi -e 's/-Wdeclaration-after-statement //g' ${i}
done
}