aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2010-07-07 10:04:27 -0700
committerTom Rini <tom_rini@mentor.com>2010-07-07 10:06:06 -0700
commit71a16be679041bb042c02f0f59c56141d963562c (patch)
tree8347f18665270c635292ef5f717aaf3c01d7f88a /recipes/perl
parent38b4324c740e4495dc352ee8514a4cce514c3f35 (diff)
downloadopenembedded-71a16be679041bb042c02f0f59c56141d963562c.tar.gz
perl-native: Add a CPAN/Config.pm file
Without this, cpan stuff can get in an infinite loop. We try and pick a good enough mirror but if needed could add CPAN_MIRROR to bitbake.conf and regex that in as well. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/perl-native/CPAN-Config.pm44
-rw-r--r--recipes/perl/perl-native_5.10.1.bb6
-rw-r--r--recipes/perl/perl-native_5.8.8.bb6
3 files changed, 54 insertions, 2 deletions
diff --git a/recipes/perl/perl-native/CPAN-Config.pm b/recipes/perl/perl-native/CPAN-Config.pm
new file mode 100644
index 0000000000..c09b8a15bd
--- /dev/null
+++ b/recipes/perl/perl-native/CPAN-Config.pm
@@ -0,0 +1,44 @@
+
+# This is CPAN.pm's systemwide configuration file. This file provides
+# defaults for users, and the values can be changed in a per-user
+# configuration file. The user-config file is being looked for as
+# ~/.cpan/CPAN/MyConfig.pm.
+
+$CPAN::Config = {
+ 'build_cache' => q[10],
+ 'build_dir' => q[@SYSROOTBASE@/.cpan/build],
+ 'cache_metadata' => q[1],
+ 'cpan_home' => q[@SYSROOTBASE@/.cpan],
+ 'dontload_hash' => { },
+ 'ftp' => q[/usr/bin/ftp],
+ 'ftp_proxy' => q[],
+ 'getcwd' => q[cwd],
+ 'gpg' => q[/usr/bin/gpg],
+ 'gzip' => q[/bin/gzip],
+ 'histfile' => q[@SYSROOTBASE@/.cpan/histfile],
+ 'histsize' => q[100],
+ 'http_proxy' => q[],
+ 'inactivity_timeout' => q[0],
+ 'index_expire' => q[1],
+ 'inhibit_startup_message' => q[0],
+ 'keep_source_where' => q[@SYSROOTBASE@/.cpan/sources],
+ 'lynx' => q[],
+ 'make' => q[/usr/bin/make],
+ 'make_arg' => q[],
+ 'make_install_arg' => q[],
+ 'makepl_arg' => q[],
+ 'ncftp' => q[],
+ 'ncftpget' => q[],
+ 'no_proxy' => q[],
+ 'pager' => q[less],
+ 'prerequisites_policy' => q[ask],
+ 'scan_cache' => q[atstart],
+ 'shell' => q[/bin/bash],
+ 'tar' => q[/bin/tar],
+ 'term_is_latin' => q[1],
+ 'unzip' => q[/usr/bin/unzip],
+ 'urllist' => [q[ftp://mirrors.kernel.org/pub/CPAN]],
+ 'wget' => q[/usr/bin/wget],
+};
+1;
+__END__
diff --git a/recipes/perl/perl-native_5.10.1.bb b/recipes/perl/perl-native_5.10.1.bb
index 8bafff0b34..0e0854b6d1 100644
--- a/recipes/perl/perl-native_5.10.1.bb
+++ b/recipes/perl/perl-native_5.10.1.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r3"
+PR = "r4"
NATIVE_INSTALL_WORKS = "1"
# Not tested enough
@@ -12,6 +12,7 @@ DEFAULT_PREFERENCE = "-1"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/perl-${PV}"
SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz;name=perl-${PV} \
+ file://CPAN-Config.pm \
file://Configure-multilib.patch \
file://perl-configpm-switch.patch \
file://native-nopacklist.patch \
@@ -92,6 +93,9 @@ do_install() {
thread.h warnings.h; do
install $i ${D}${libdir}/perl/${PV}/CORE
done
+ # Make sure CPAN is configured
+ sed -e "s,@SYSROOTBASE@,${base_prefix}," ${WORKDIR}/CPAN-Config.pm > \
+ ${D}${libdir}/perl/${PV}/CPAN/Config.pm
# Fix Errno.pm for target builds
sed -i -r "s,^\tdie\ (\"Errno\ architecture.+)$,\twarn\ \1," ${D}${libdir}/perl/${PV}/Errno.pm
diff --git a/recipes/perl/perl-native_5.8.8.bb b/recipes/perl/perl-native_5.8.8.bb
index 336b419e95..fe1bc846fc 100644
--- a/recipes/perl/perl-native_5.8.8.bb
+++ b/recipes/perl/perl-native_5.8.8.bb
@@ -3,12 +3,13 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r19"
+PR = "r20"
NATIVE_INSTALL_WORKS = "1"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/perl-${PV}"
SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/5.0/perl-${PV}.tar.gz \
+ file://CPAN-Config.pm \
file://perl-5.8.8-gcc-4.2.patch \
file://Configure-multilib.patch \
file://perl-configpm-switch.patch \
@@ -90,6 +91,9 @@ do_install() {
thread.h warnings.h; do
install $i ${D}${libdir}/perl/${PV}/CORE
done
+ # Make sure CPAN is configured
+ sed -e "s,@SYSROOTBASE@,${base_prefix}," ${WORKDIR}/CPAN-Config.pm > \
+ ${D}${libdir}/perl/${PV}/CPAN/Config.pm
}
do_install_append_nylon() {