aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-02 15:04:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-03 07:33:27 +0200
commitd4276bed389b7db06db58c7acebb83f92bff86a5 (patch)
tree2386574b6ab0c36a58a314a24d31f6b5c9291a65 /recipes/perl
parent823aa270059259ca619e21a5d9b22e86afb12f3b (diff)
downloadopenembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.gz
recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDS
* there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/libalgorithm-diff-perl_1.1902.bb2
-rw-r--r--recipes/perl/libarchive-tar-perl_1.30.bb2
-rw-r--r--recipes/perl/libarchive-zip-perl_1.30.bb2
-rw-r--r--recipes/perl/libauthen-pam-perl_0.16.bb2
-rw-r--r--recipes/perl/libcache-cache-perl_1.06.bb2
-rw-r--r--recipes/perl/libclass-container-perl_0.12.bb2
-rw-r--r--recipes/perl/libdata-optlist-perl_0.101.bb2
-rw-r--r--recipes/perl/libdate-manip-perl_5.54.bb2
-rw-r--r--recipes/perl/libdbd-mysql-perl_4.010.bb2
-rw-r--r--recipes/perl/libdbi-perl_1.607.bb2
-rw-r--r--recipes/perl/libdevice-serialport-perl_1.04.bb2
-rw-r--r--recipes/perl/libemail-date-format-perl_1.002.bb2
-rw-r--r--recipes/perl/libexception-class-perl_1.23.bb2
-rw-r--r--recipes/perl/libhtml-parser-perl_3.60.bb2
-rw-r--r--recipes/perl/libhtml-parser-perl_3.64.bb2
-rw-r--r--recipes/perl/libhtml-treebuilder-perl_3.23.bb2
-rw-r--r--recipes/perl/libintl-perl_1.11.bb2
-rw-r--r--recipes/perl/libintl-perl_1.16.bb2
-rw-r--r--recipes/perl/libintl-perl_1.20.bb2
-rw-r--r--recipes/perl/libio-zlib-perl_1.04.bb2
-rw-r--r--recipes/perl/libio-zlib-perl_1.10.bb2
-rw-r--r--recipes/perl/libmath-bigint-gmp-perl_1.18.bb2
-rw-r--r--recipes/perl/libmime-lite-perl_3.024.bb2
-rw-r--r--recipes/perl/libmodule-build-perl_0.2805.bb2
-rw-r--r--recipes/perl/libmodule-load-perl_0.16.bb2
-rw-r--r--recipes/perl/libnet-dbus-perl_0.33.5.bb2
-rw-r--r--recipes/perl/libnet-dbus-perl_0.33.6.bb2
-rw-r--r--recipes/perl/libnet-ip-perl_1.25.bb2
-rw-r--r--recipes/perl/libnet-rawip-perl_0.25.bb2
-rw-r--r--recipes/perl/libparams-util-perl_0.20.bb2
-rw-r--r--recipes/perl/libsub-exporter-perl_0.970.bb2
-rw-r--r--recipes/perl/libsub-install-perl_0.922.bb2
-rw-r--r--recipes/perl/libsub-uplevel-perl_0.13.bb2
-rw-r--r--recipes/perl/libtest-builder-tester-perl_1.01.bb2
-rw-r--r--recipes/perl/libtest-differences-perl_0.47.bb2
-rw-r--r--recipes/perl/libtest-exception-perl_0.22.bb2
-rw-r--r--recipes/perl/libtest-mockmodule-perl_0.05.bb2
-rw-r--r--recipes/perl/libtest-output-perl_0.10.bb2
-rw-r--r--recipes/perl/libtext-diff-perl_0.35.bb2
-rw-r--r--recipes/perl/libtimedate-perl_1.20.bb2
-rw-r--r--recipes/perl/liburi-perl_1.52.bb2
-rw-r--r--recipes/perl/libxml-dom-perl_1.44.bb2
-rw-r--r--recipes/perl/libyaml-perl_0.62.bb2
43 files changed, 43 insertions, 43 deletions
diff --git a/recipes/perl/libalgorithm-diff-perl_1.1902.bb b/recipes/perl/libalgorithm-diff-perl_1.1902.bb
index 1180894a09..d932760373 100644
--- a/recipes/perl/libalgorithm-diff-perl_1.1902.bb
+++ b/recipes/perl/libalgorithm-diff-perl_1.1902.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Algorithm::Diff - Compute intelligent differences between two files / lists"
SECTION = "libs"
LICENSE = "Artistic|GPL"
-RDEPENDS += "perl-module-exporter perl-module-strict perl-module-vars \
+RDEPENDS_${PN} += "perl-module-exporter perl-module-strict perl-module-vars \
perl-module-strict perl-module-vars"
PR = "r4"
diff --git a/recipes/perl/libarchive-tar-perl_1.30.bb b/recipes/perl/libarchive-tar-perl_1.30.bb
index 840f08efb6..33acdfe966 100644
--- a/recipes/perl/libarchive-tar-perl_1.30.bb
+++ b/recipes/perl/libarchive-tar-perl_1.30.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Archive::Tar - module for manipulations of tar archives"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS += "libio-zlib-perl-native"
-RDEPENDS += "libio-zlib-perl"
+RDEPENDS_${PN} += "libio-zlib-perl"
PR = "r5"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/K/KA/KANE/Archive-Tar-${PV}.tar.gz"
diff --git a/recipes/perl/libarchive-zip-perl_1.30.bb b/recipes/perl/libarchive-zip-perl_1.30.bb
index 672f1eab96..12b644c98e 100644
--- a/recipes/perl/libarchive-zip-perl_1.30.bb
+++ b/recipes/perl/libarchive-zip-perl_1.30.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS += "libio-zlib-perl-native"
-RDEPENDS += "libio-zlib-perl"
+RDEPENDS_${PN} += "libio-zlib-perl"
PR= "r0"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/Archive-Zip-${PV}.tar.gz"
diff --git a/recipes/perl/libauthen-pam-perl_0.16.bb b/recipes/perl/libauthen-pam-perl_0.16.bb
index c8fdfa448d..f1910055b4 100644
--- a/recipes/perl/libauthen-pam-perl_0.16.bb
+++ b/recipes/perl/libauthen-pam-perl_0.16.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Authen::PAM - Perl interface to PAM library"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "libpam"
-RDEPENDS = "perl-module-posix"
+RDEPENDS_${PN} = "perl-module-posix"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/N/NI/NIKIP/Authen-PAM-${PV}.tar.gz;name=authen-pam-perl-${PV}"
SRC_URI[authen-pam-perl-0.16.md5sum] = "7278471dfa694d9ef312bc92d7099af2"
diff --git a/recipes/perl/libcache-cache-perl_1.06.bb b/recipes/perl/libcache-cache-perl_1.06.bb
index f441b44b49..cee4455c17 100644
--- a/recipes/perl/libcache-cache-perl_1.06.bb
+++ b/recipes/perl/libcache-cache-perl_1.06.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "libdigest-sha1-perl-native liberror-perl-native \
libipc-sharelite-perl-native"
-RDEPENDS = "libdigest-sha1-perl liberror-perl libipc-sharelite-perl"
+RDEPENDS_${PN} = "libdigest-sha1-perl liberror-perl libipc-sharelite-perl"
PR = "r0"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/J/JS/JSWARTZ/Cache-Cache-${PV}.tar.gz"
diff --git a/recipes/perl/libclass-container-perl_0.12.bb b/recipes/perl/libclass-container-perl_0.12.bb
index 8522107225..beffb373ca 100644
--- a/recipes/perl/libclass-container-perl_0.12.bb
+++ b/recipes/perl/libclass-container-perl_0.12.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Class::Container - Glues object frameworks together transparently
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "libparams-validate-perl-native"
-RDEPENDS = "libparams-validate-perl"
+RDEPENDS_${PN} = "libparams-validate-perl"
PR = "r7"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/K/KW/KWILLIAMS/Class-Container-${PV}.tar.gz"
diff --git a/recipes/perl/libdata-optlist-perl_0.101.bb b/recipes/perl/libdata-optlist-perl_0.101.bb
index 1369f11f8d..44ccf43add 100644
--- a/recipes/perl/libdata-optlist-perl_0.101.bb
+++ b/recipes/perl/libdata-optlist-perl_0.101.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Data::OptList - parse and validate simple name/value option pairs
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS += "libsub-install-perl-native libparams-util-perl-native"
-RDEPENDS += "perl-module-list-util libparams-util-perl perl-module-strict \
+RDEPENDS_${PN} += "perl-module-list-util libparams-util-perl perl-module-strict \
libsub-install-perl perl-module-warnings "
PR = "r4"
diff --git a/recipes/perl/libdate-manip-perl_5.54.bb b/recipes/perl/libdate-manip-perl_5.54.bb
index 790dc17c86..381e7f0ed2 100644
--- a/recipes/perl/libdate-manip-perl_5.54.bb
+++ b/recipes/perl/libdate-manip-perl_5.54.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "Artistic|GPL"
PR = "r1"
-RDEPENDS = "perl-module-test-more \
+RDEPENDS_${PN} = "perl-module-test-more \
perl-module-io-file \
perl-module-carp"
diff --git a/recipes/perl/libdbd-mysql-perl_4.010.bb b/recipes/perl/libdbd-mysql-perl_4.010.bb
index b77f05eed5..2030ca9ade 100644
--- a/recipes/perl/libdbd-mysql-perl_4.010.bb
+++ b/recipes/perl/libdbd-mysql-perl_4.010.bb
@@ -1,7 +1,7 @@
require libdbd-mysql-perl.inc
DEPENDS = "libdbi-perl mysql"
-RDEPENDS = "perl-module-data-dumper \
+RDEPENDS_${PN} = "perl-module-data-dumper \
libdbi-perl \
perl-module-scalar-util \
perl-module-file-spec \
diff --git a/recipes/perl/libdbi-perl_1.607.bb b/recipes/perl/libdbi-perl_1.607.bb
index 7bb7745e4b..2d52376cf1 100644
--- a/recipes/perl/libdbi-perl_1.607.bb
+++ b/recipes/perl/libdbi-perl_1.607.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "Artistic|GPL"
PR = "r1"
-RDEPENDS = "perl-module-scalar-util \
+RDEPENDS_${PN} = "perl-module-scalar-util \
perl-module-file-spec \
perl-module-storable \
perl-module-test-simple"
diff --git a/recipes/perl/libdevice-serialport-perl_1.04.bb b/recipes/perl/libdevice-serialport-perl_1.04.bb
index fa39694852..583a818ae1 100644
--- a/recipes/perl/libdevice-serialport-perl_1.04.bb
+++ b/recipes/perl/libdevice-serialport-perl_1.04.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Device::SerialPort - Linux/POSIX emulation of Win32::SerialPort functions."
SECTION = "libs"
LICENSE = "GPL"
-RDEPENDS += "perl-module-carp perl-module-posix perl-module-io-handle \
+RDEPENDS_${PN} += "perl-module-carp perl-module-posix perl-module-io-handle \
perl-module-strict perl-module-warnings perl-module-vars \
perl-module-xsloader"
PR= "r1"
diff --git a/recipes/perl/libemail-date-format-perl_1.002.bb b/recipes/perl/libemail-date-format-perl_1.002.bb
index 13ee4b612a..0885a065df 100644
--- a/recipes/perl/libemail-date-format-perl_1.002.bb
+++ b/recipes/perl/libemail-date-format-perl_1.002.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "Artistic|GPL"
PR = "r1"
-RDEPENDS = "perl-module-test-more \
+RDEPENDS_${PN} = "perl-module-test-more \
perl-module-time-local"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Email-Date-Format-${PV}.tar.gz"
diff --git a/recipes/perl/libexception-class-perl_1.23.bb b/recipes/perl/libexception-class-perl_1.23.bb
index a28f8f6f7a..e242f0d238 100644
--- a/recipes/perl/libexception-class-perl_1.23.bb
+++ b/recipes/perl/libexception-class-perl_1.23.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Exception::Class - A module that allows you to declare real excep
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "libclass-data-inheritable-perl-native libdevel-stacktrace-perl-native"
-RDEPENDS = "libclass-data-inheritable-perl libdevel-stacktrace-perl"
+RDEPENDS_${PN} = "libclass-data-inheritable-perl libdevel-stacktrace-perl"
PR = "r8"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Exception-Class-${PV}.tar.gz"
diff --git a/recipes/perl/libhtml-parser-perl_3.60.bb b/recipes/perl/libhtml-parser-perl_3.60.bb
index b87f78d672..522e4c0d78 100644
--- a/recipes/perl/libhtml-parser-perl_3.60.bb
+++ b/recipes/perl/libhtml-parser-perl_3.60.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "Artistic|GPL"
PR = "r1"
-RDEPENDS = "perl-module-test-more \
+RDEPENDS_${PN} = "perl-module-test-more \
perl-module-xsloader \
perl-module-test-simple \
libhtml-tagset-perl"
diff --git a/recipes/perl/libhtml-parser-perl_3.64.bb b/recipes/perl/libhtml-parser-perl_3.64.bb
index 00199f8747..fdc59e0c7f 100644
--- a/recipes/perl/libhtml-parser-perl_3.64.bb
+++ b/recipes/perl/libhtml-parser-perl_3.64.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "Artistic|GPL"
PR = "r1"
-RDEPENDS = "perl-module-test-more \
+RDEPENDS_${PN} = "perl-module-test-more \
perl-module-xsloader \
perl-module-test-simple \
libhtml-tagset-perl"
diff --git a/recipes/perl/libhtml-treebuilder-perl_3.23.bb b/recipes/perl/libhtml-treebuilder-perl_3.23.bb
index ac0a5b8e27..7063918060 100644
--- a/recipes/perl/libhtml-treebuilder-perl_3.23.bb
+++ b/recipes/perl/libhtml-treebuilder-perl_3.23.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "Artistic|GPL"
PR = "r3"
-RDEPENDS = "perl-module-extutils-makemaker"
+RDEPENDS_${PN} = "perl-module-extutils-makemaker"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/P/PE/PETEK/HTML-Tree-${PV}.tar.gz"
diff --git a/recipes/perl/libintl-perl_1.11.bb b/recipes/perl/libintl-perl_1.11.bb
index cf5af66e42..4272022c04 100644
--- a/recipes/perl/libintl-perl_1.11.bb
+++ b/recipes/perl/libintl-perl_1.11.bb
@@ -9,7 +9,7 @@ SRC_URI[md5sum] = "091e05542e36f030c785f2919f05b73f"
SRC_URI[sha256sum] = "71e397949e79eb0f789f73259db5fc7be1e2ba1c604510c8d44b101d7d6e6479"
DEPENDS = "perl"
-RDEPENDS = "perl-module-vars perl-module-locale perl-module-io-handle perl-module-symbol perl-module-selectsaver perl-module-io perl-module-integer perl-module-exporter-heavy"
+RDEPENDS_${PN} = "perl-module-vars perl-module-locale perl-module-io-handle perl-module-symbol perl-module-selectsaver perl-module-io perl-module-integer perl-module-exporter-heavy"
S = "${WORKDIR}/libintl-perl-${PV}"
diff --git a/recipes/perl/libintl-perl_1.16.bb b/recipes/perl/libintl-perl_1.16.bb
index 50c61452e5..c7a82117ff 100644
--- a/recipes/perl/libintl-perl_1.16.bb
+++ b/recipes/perl/libintl-perl_1.16.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "libintl-perl is an internationalization library for Perl"
SECTION = "libs"
LICENSE = "Artistic|GPL"
-RDEPENDS = "perl-module-vars perl-module-locale perl-module-io-handle \
+RDEPENDS_${PN} = "perl-module-vars perl-module-locale perl-module-io-handle \
perl-module-symbol perl-module-selectsaver perl-module-io \
perl-module-integer perl-module-exporter-heavy"
PR = "r4"
diff --git a/recipes/perl/libintl-perl_1.20.bb b/recipes/perl/libintl-perl_1.20.bb
index 0905f66079..4c41c33494 100644
--- a/recipes/perl/libintl-perl_1.20.bb
+++ b/recipes/perl/libintl-perl_1.20.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "libintl-perl is an internationalization library for Perl"
SECTION = "libs"
LICENSE = "Artistic|GPL"
-RDEPENDS = "perl-module-vars perl-module-locale perl-module-io-handle \
+RDEPENDS_${PN} = "perl-module-vars perl-module-locale perl-module-io-handle \
perl-module-symbol perl-module-selectsaver perl-module-io \
perl-module-integer perl-module-exporter-heavy"
PR = "r0"
diff --git a/recipes/perl/libio-zlib-perl_1.04.bb b/recipes/perl/libio-zlib-perl_1.04.bb
index 6d704096e4..32b44ae867 100644
--- a/recipes/perl/libio-zlib-perl_1.04.bb
+++ b/recipes/perl/libio-zlib-perl_1.04.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "IO::Zlib - IO:: style interface to Compress::Zlib"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "libcompress-zlib-perl-native"
-RDEPENDS += "libcompress-zlib-perl"
+RDEPENDS_${PN} += "libcompress-zlib-perl"
PR = "r5"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TO/TOMHUGHES/IO-Zlib-${PV}.tar.gz"
diff --git a/recipes/perl/libio-zlib-perl_1.10.bb b/recipes/perl/libio-zlib-perl_1.10.bb
index de891dd78d..30c0228a48 100644
--- a/recipes/perl/libio-zlib-perl_1.10.bb
+++ b/recipes/perl/libio-zlib-perl_1.10.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "IO::Zlib - IO:: style interface to Compress::Zlib"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "libcompress-zlib-perl-native"
-RDEPENDS += "libcompress-zlib-perl"
+RDEPENDS_${PN} += "libcompress-zlib-perl"
PR = "r0"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TO/TOMHUGHES/IO-Zlib-${PV}.tar.gz;name=io-zlib-${PV}"
diff --git a/recipes/perl/libmath-bigint-gmp-perl_1.18.bb b/recipes/perl/libmath-bigint-gmp-perl_1.18.bb
index 7b57983786..70147033cf 100644
--- a/recipes/perl/libmath-bigint-gmp-perl_1.18.bb
+++ b/recipes/perl/libmath-bigint-gmp-perl_1.18.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Math::BigInt::GMP - Use the GMP library for Math::BigInt routines
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS += "gmp-native"
-RDEPENDS += "gmp"
+RDEPENDS_${PN} += "gmp"
PR = "r6"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TE/TELS/math/Math-BigInt-GMP-${PV}.tar.gz"
diff --git a/recipes/perl/libmime-lite-perl_3.024.bb b/recipes/perl/libmime-lite-perl_3.024.bb
index d6dfa0458b..fae42e34c0 100644
--- a/recipes/perl/libmime-lite-perl_3.024.bb
+++ b/recipes/perl/libmime-lite-perl_3.024.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "Artistic|GPL"
PR = "r1"
-RDEPENDS = "perl-module-file-spec \
+RDEPENDS_${PN} = "perl-module-file-spec \
libemail-date-format-perl \
perl-module-test-more \
perl-module-time-local"
diff --git a/recipes/perl/libmodule-build-perl_0.2805.bb b/recipes/perl/libmodule-build-perl_0.2805.bb
index c4ecea41d1..095d4853c9 100644
--- a/recipes/perl/libmodule-build-perl_0.2805.bb
+++ b/recipes/perl/libmodule-build-perl_0.2805.bb
@@ -6,7 +6,7 @@ DEPENDS = "libyaml-perl-native libversion-perl-native \
libextutils-cbuilder-perl-native \
libextutils-parsexs-perl-native \
libarchive-tar-perl-native"
-RDEPENDS = "libyaml-perl libversion-perl libextutils-cbuilder-perl \
+RDEPENDS_${PN} = "libyaml-perl libversion-perl libextutils-cbuilder-perl \
libextutils-parsexs-perl libarchive-tar-perl"
PR = "r5"
diff --git a/recipes/perl/libmodule-load-perl_0.16.bb b/recipes/perl/libmodule-load-perl_0.16.bb
index 107bbe26a9..5063990425 100644
--- a/recipes/perl/libmodule-load-perl_0.16.bb
+++ b/recipes/perl/libmodule-load-perl_0.16.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "Artistic|GPL"
PR = "r1"
-RDEPENDS = "perl-module-test-more"
+RDEPENDS_${PN} = "perl-module-test-more"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/K/KA/KANE/Module-Load-${PV}.tar.gz"
diff --git a/recipes/perl/libnet-dbus-perl_0.33.5.bb b/recipes/perl/libnet-dbus-perl_0.33.5.bb
index f3010680dc..5e18628408 100644
--- a/recipes/perl/libnet-dbus-perl_0.33.5.bb
+++ b/recipes/perl/libnet-dbus-perl_0.33.5.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "Artistic|GPL"
PR = "r0"
-RDEPENDS = "perl-module-vars perl-module-locale perl-module-io-handle \
+RDEPENDS_${PN} = "perl-module-vars perl-module-locale perl-module-io-handle \
perl-module-symbol perl-module-selectsaver perl-module-io \
perl-module-integer perl-module-exporter-heavy"
diff --git a/recipes/perl/libnet-dbus-perl_0.33.6.bb b/recipes/perl/libnet-dbus-perl_0.33.6.bb
index 45a52e1913..15a0633335 100644
--- a/recipes/perl/libnet-dbus-perl_0.33.6.bb
+++ b/recipes/perl/libnet-dbus-perl_0.33.6.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Net::DBus - Perl D-Bus module"
SECTION = "libs"
LICENSE = "Artistic|GPL"
-RDEPENDS = "perl-module-vars perl-module-locale perl-module-io-handle \
+RDEPENDS_${PN} = "perl-module-vars perl-module-locale perl-module-io-handle \
perl-module-symbol perl-module-selectsaver perl-module-io \
perl-module-integer perl-module-exporter-heavy"
diff --git a/recipes/perl/libnet-ip-perl_1.25.bb b/recipes/perl/libnet-ip-perl_1.25.bb
index 201bf57f00..ec880453aa 100644
--- a/recipes/perl/libnet-ip-perl_1.25.bb
+++ b/recipes/perl/libnet-ip-perl_1.25.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Net::IP - Perl extension for manipulating IPv4/IPv6 addresses"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS += "libio-zlib-perl-native"
-RDEPENDS += "libio-zlib-perl perl-module-math-bigint"
+RDEPENDS_${PN} += "libio-zlib-perl perl-module-math-bigint"
PR = "r6"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MA/MANU/Net-IP-${PV}.tar.gz"
diff --git a/recipes/perl/libnet-rawip-perl_0.25.bb b/recipes/perl/libnet-rawip-perl_0.25.bb
index e0da3381f2..57cdf4e089 100644
--- a/recipes/perl/libnet-rawip-perl_0.25.bb
+++ b/recipes/perl/libnet-rawip-perl_0.25.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Perl extension to manipulate raw IP packets with interface to lib
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "libpcap"
-RDEPENDS = " \
+RDEPENDS_${PN} = " \
perl-module-class-struct \
perl-module-data-dumper \
perl-module-english \
diff --git a/recipes/perl/libparams-util-perl_0.20.bb b/recipes/perl/libparams-util-perl_0.20.bb
index e988f19ea8..7ad689b6c2 100644
--- a/recipes/perl/libparams-util-perl_0.20.bb
+++ b/recipes/perl/libparams-util-perl_0.20.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Params::Util - Simple, compact and correct param-checking functions"
SECTION = "libs"
LICENSE = "Artistic|GPL"
-RDEPENDS += "perl-module-exporter perl-module-overload \
+RDEPENDS_${PN} += "perl-module-exporter perl-module-overload \
perl-module-scalar-util perl-module-strict perl-module-vars"
PR = "r4"
diff --git a/recipes/perl/libsub-exporter-perl_0.970.bb b/recipes/perl/libsub-exporter-perl_0.970.bb
index 574eaa6bc2..4b299e3511 100644
--- a/recipes/perl/libsub-exporter-perl_0.970.bb
+++ b/recipes/perl/libsub-exporter-perl_0.970.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS += "libdata-optlist-perl-native libsub-install-perl-native \
libparams-util-perl-native"
-RDEPENDS += "perl-module-carp libdata-optlist-perl libparams-util-perl \
+RDEPENDS_${PN} += "perl-module-carp libdata-optlist-perl libparams-util-perl \
perl-module-strict libsub-install-perl perl-module-warnings"
PR = "r4"
diff --git a/recipes/perl/libsub-install-perl_0.922.bb b/recipes/perl/libsub-install-perl_0.922.bb
index eb49db435a..5af0cc59fa 100644
--- a/recipes/perl/libsub-install-perl_0.922.bb
+++ b/recipes/perl/libsub-install-perl_0.922.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Sub::Install - install subroutines into packages easily"
SECTION = "libs"
LICENSE = "Artistic|GPL"
-RDEPENDS += "perl-module-carp perl-module-scalar-util perl-module-strict \
+RDEPENDS_${PN} += "perl-module-carp perl-module-scalar-util perl-module-strict \
perl-module-warnings"
PR = "r4"
diff --git a/recipes/perl/libsub-uplevel-perl_0.13.bb b/recipes/perl/libsub-uplevel-perl_0.13.bb
index 754f471a3c..c8227e5ef2 100644
--- a/recipes/perl/libsub-uplevel-perl_0.13.bb
+++ b/recipes/perl/libsub-uplevel-perl_0.13.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Sub::Uplevel - apparently run a function in a higher stack frame"
SECTION = "libs"
LICENSE = "Artistic|GPL"
-RDEPENDS += "perl-module-exporter perl-module-strict perl-module-vars"
+RDEPENDS_${PN} += "perl-module-exporter perl-module-strict perl-module-vars"
PR = "r4"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/D/DA/DAGOLDEN/Sub-Uplevel-${PV}.tar.gz"
diff --git a/recipes/perl/libtest-builder-tester-perl_1.01.bb b/recipes/perl/libtest-builder-tester-perl_1.01.bb
index 73259f90bc..78373caf50 100644
--- a/recipes/perl/libtest-builder-tester-perl_1.01.bb
+++ b/recipes/perl/libtest-builder-tester-perl_1.01.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Test::Builder::Tester - test testsuites that have been built with Test::Builder"
SECTION = "libs"
LICENSE = "Artistic|GPL"
-RDEPENDS += "perl-module-strict perl-module-carp perl-module-exporter \
+RDEPENDS_${PN} += "perl-module-strict perl-module-carp perl-module-exporter \
perl-module-symbol perl-module-vars"
PR = "r3"
diff --git a/recipes/perl/libtest-differences-perl_0.47.bb b/recipes/perl/libtest-differences-perl_0.47.bb
index 434fefbd1f..ea95fa7135 100644
--- a/recipes/perl/libtest-differences-perl_0.47.bb
+++ b/recipes/perl/libtest-differences-perl_0.47.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Test::Differences - Test strings and data structures and show dif
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS += "libtext-diff-perl-native"
-RDEPENDS += "perl-module-carp perl-module-constant perl-module-exporter \
+RDEPENDS_${PN} += "perl-module-carp perl-module-constant perl-module-exporter \
perl-module-strict libtext-diff-perl"
PR = "r3"
diff --git a/recipes/perl/libtest-exception-perl_0.22.bb b/recipes/perl/libtest-exception-perl_0.22.bb
index e48e177257..11213f04a8 100644
--- a/recipes/perl/libtest-exception-perl_0.22.bb
+++ b/recipes/perl/libtest-exception-perl_0.22.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Test::Exception - Test exception based code"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS += "libsub-uplevel-perl-native"
-RDEPENDS += "perl-module-base perl-module-carp perl-module-strict \
+RDEPENDS_${PN} += "perl-module-base perl-module-carp perl-module-strict \
libsub-uplevel-perl perl-module-test-builder \
perl-module-warnings"
PR = "r3"
diff --git a/recipes/perl/libtest-mockmodule-perl_0.05.bb b/recipes/perl/libtest-mockmodule-perl_0.05.bb
index 3ceedd3764..f49eef2a59 100644
--- a/recipes/perl/libtest-mockmodule-perl_0.05.bb
+++ b/recipes/perl/libtest-mockmodule-perl_0.05.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Test::MockModule - Override subroutines in a module for unit testing"
SECTION = "libs"
LICENSE = "Artistic|GPL"
-RDEPENDS += "perl-module-carp perl-module-scalar-util perl-module-strict \
+RDEPENDS_${PN} += "perl-module-carp perl-module-scalar-util perl-module-strict \
perl-module-vars "
PR = "r3"
diff --git a/recipes/perl/libtest-output-perl_0.10.bb b/recipes/perl/libtest-output-perl_0.10.bb
index 1746a08d0a..ce1eb9a2af 100644
--- a/recipes/perl/libtest-output-perl_0.10.bb
+++ b/recipes/perl/libtest-output-perl_0.10.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Test::Output - Utilities to test STDOUT and STDERR messages"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS += "libsub-exporter-perl-native"
-RDEPENDS += "libsub-exporter-perl"
+RDEPENDS_${PN} += "libsub-exporter-perl"
PR = "r3"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SS/SSORICHE/Test-Output-${PV}.tar.gz"
diff --git a/recipes/perl/libtext-diff-perl_0.35.bb b/recipes/perl/libtext-diff-perl_0.35.bb
index 122dea68fa..c48b1eb2d3 100644
--- a/recipes/perl/libtext-diff-perl_0.35.bb
+++ b/recipes/perl/libtext-diff-perl_0.35.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Text::Diff - Perform diffs on files and record sets"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS += "libalgorithm-diff-perl-native"
-RDEPENDS += "libalgorithm-diff-perl perl-module-carp perl-module-constant \
+RDEPENDS_${PN} += "libalgorithm-diff-perl perl-module-carp perl-module-constant \
perl-module-exporter perl-module-strict perl-module-carp \
perl-module-strict "
PR = "r4"
diff --git a/recipes/perl/libtimedate-perl_1.20.bb b/recipes/perl/libtimedate-perl_1.20.bb
index bbf98739aa..fcd9b4f422 100644
--- a/recipes/perl/libtimedate-perl_1.20.bb
+++ b/recipes/perl/libtimedate-perl_1.20.bb
@@ -4,7 +4,7 @@ SECTION = "libs"
LICENSE = "Artistic|GPL"
PR = "r0"
-RDEPENDS += "perl-module-carp perl-module-exporter perl-module-strict perl-module-time-local"
+RDEPENDS_${PN} += "perl-module-carp perl-module-exporter perl-module-strict perl-module-time-local"
PACKAGE_ARCH = "all"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GB/GBARR/TimeDate-${PV}.tar.gz"
diff --git a/recipes/perl/liburi-perl_1.52.bb b/recipes/perl/liburi-perl_1.52.bb
index 8b522aa913..e32495a8ee 100644
--- a/recipes/perl/liburi-perl_1.52.bb
+++ b/recipes/perl/liburi-perl_1.52.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Manipulates and accesses URI strings"
SECTION = "libs"
LICENSE = "Artistic|GPL"
-#RDEPENDS += " libmime-base64-perl libnet-perl"
+#RDEPENDS_${PN} += " libmime-base64-perl libnet-perl"
PR = "r2"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/URI-${PV}.tar.gz"
diff --git a/recipes/perl/libxml-dom-perl_1.44.bb b/recipes/perl/libxml-dom-perl_1.44.bb
index e89d87c90b..66e158ddc0 100644
--- a/recipes/perl/libxml-dom-perl_1.44.bb
+++ b/recipes/perl/libxml-dom-perl_1.44.bb
@@ -7,7 +7,7 @@ DEPENDS += "libxml-parser-perl-native libxml-regexp-perl-native \
libhtml-parser-perl-native libhtml-tagset-perl-native \
liburi-perl-native libwww-perl-native"
-RDEPENDS += "libxml-parser-perl libxml-regexp-perl \
+RDEPENDS_${PN} += "libxml-parser-perl libxml-regexp-perl \
libhtml-parser-perl libhtml-tagset-perl liburi-perl libwww-perl"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TJ/TJMATHER/XML-DOM-${PV}.tar.gz"
diff --git a/recipes/perl/libyaml-perl_0.62.bb b/recipes/perl/libyaml-perl_0.62.bb
index 99f798f650..c98c797154 100644
--- a/recipes/perl/libyaml-perl_0.62.bb
+++ b/recipes/perl/libyaml-perl_0.62.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "libdigest-sha1-perl-native liberror-perl-native \
libipc-sharelite-perl-native"
-RDEPENDS = "libdigest-sha1-perl liberror-perl libipc-sharelite-perl"
+RDEPENDS_${PN} = "libdigest-sha1-perl liberror-perl libipc-sharelite-perl"
PR = "r5"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/I/IN/INGY/YAML-${PV}.tar.gz"