aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-09-04 15:39:51 -0700
committerKhem Raj <raj.khem@gmail.com>2009-09-05 19:19:54 -0700
commit1578d2e0a527f2baa6ccda851fcb51c72ba40fbf (patch)
tree3647754fcd3e61f3c2a8c87cdc304add381b9137 /recipes/perl
parent8c2c7d80a8386b907e95cce3efcc02e59c5924c2 (diff)
downloadopenembedded-1578d2e0a527f2baa6ccda851fcb51c72ba40fbf.tar.gz
perl_5.8.8.bb: Fix compilation when bindir is not /usr/bin
* Right now default perl installation happens in /usr prefix This patch tries to depend upong layout_prefix to decide on where to install. This is required for distros like micro who flatten the install tree and do not use /usr prefix Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/perl')
-rw-r--r--recipes/perl/perl_5.8.8.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index 8d9719959c..8f6b72b52e 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPL"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r27"
+PR = "r28"
# Major part of version
PVM = "5.8"
@@ -81,6 +81,7 @@ do_configure() {
sed -i -e 's,@DESTDIR@,${D},g' \
-e 's,@ARCH@,${TARGET_ARCH}-${TARGET_OS},g' \
-e "s%/usr/include/%${STAGING_INCDIR}/%g" \
+ -e 's,/usr/,${layout_exec_prefix}/,g' \
config.sh-${TARGET_ARCH}-${TARGET_OS}
if test "${MACHINE}" != "native"; then
@@ -103,10 +104,9 @@ do_compile() {
oe_runmake perl LD="${TARGET_SYS}-gcc"
}
do_install() {
- oe_runmake install
-
+ oe_runmake install
# Add perl pointing at current version
- ln -sf perl${PV} ${D}/usr/bin/perl
+ ln -sf perl${PV} ${D}${bindir}/perl
# Fix up versioned directories
mv ${D}/${libdir}/perl/${PVM} ${D}/${libdir}/perl/${PV}