summaryrefslogtreecommitdiffstats
path: root/recipes/php/php-5.2.13
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-03-05 01:10:09 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-03-05 01:10:09 +0100
commit4c2a2a7af095761bb214f1fee46bb2a852e9f776 (patch)
tree72becdb9e1f248051d3b9c3e75e1e99b6965b4d3 /recipes/php/php-5.2.13
parent70c732de4a75c4bc51a8f7c83130eef631eaae55 (diff)
downloadopenembedded-4c2a2a7af095761bb214f1fee46bb2a852e9f776.tar.gz
php: Upgrade from php 5.1.12 to 5.1.13
Diffstat (limited to 'recipes/php/php-5.2.13')
-rw-r--r--recipes/php/php-5.2.13/acinclude-xml2-config.patch18
-rw-r--r--recipes/php/php-5.2.13/imap-fix-autofoo.patch41
-rw-r--r--recipes/php/php-5.2.13/pear-makefile.patch13
3 files changed, 72 insertions, 0 deletions
diff --git a/recipes/php/php-5.2.13/acinclude-xml2-config.patch b/recipes/php/php-5.2.13/acinclude-xml2-config.patch
new file mode 100644
index 0000000000..bf519d2934
--- /dev/null
+++ b/recipes/php/php-5.2.13/acinclude-xml2-config.patch
@@ -0,0 +1,18 @@
+--- /orig-acinclude.m4 2007-02-20 15:03:25.000000000 +0200
++++ /acinclude.m4 2007-02-20 15:03:24.000000000 +0200
+@@ -2359,12 +2359,9 @@
+ AC_DEFUN([PHP_SETUP_LIBXML], [
+ AC_CACHE_CHECK([for xml2-config path], ac_cv_php_xml2_config_path,
+ [
+- for i in $PHP_LIBXML_DIR /usr/local /usr; do
+- if test -x "$i/bin/xml2-config"; then
+- ac_cv_php_xml2_config_path="$i/bin/xml2-config"
+- break
+- fi
+- done
++
++ ac_cv_php_xml2_config_path="$PHP_LIBXML_DIR/xml2-config"
++
+ ])
+
+ if test -x "$ac_cv_php_xml2_config_path"; then
diff --git a/recipes/php/php-5.2.13/imap-fix-autofoo.patch b/recipes/php/php-5.2.13/imap-fix-autofoo.patch
new file mode 100644
index 0000000000..3695b7bc42
--- /dev/null
+++ b/recipes/php/php-5.2.13/imap-fix-autofoo.patch
@@ -0,0 +1,41 @@
+Index: php-5.2.11/ext/imap/config.m4
+===================================================================
+--- php-5.2.11.orig/ext/imap/config.m4 2009-12-10 12:27:52.800974533 -0700
++++ php-5.2.11/ext/imap/config.m4 2009-12-10 12:28:33.720976583 -0700
+@@ -103,7 +103,7 @@
+ PHP_NEW_EXTENSION(imap, php_imap.c, $ext_shared)
+ AC_DEFINE(HAVE_IMAP,1,[ ])
+
+- for i in $PHP_IMAP /usr/local /usr; do
++ for i in $PHP_IMAP $PHP_IMAP/usr /usr/local /usr; do
+ IMAP_INC_CHK()
+ el[]IMAP_INC_CHK(/include/c-client)
+ el[]IMAP_INC_CHK(/include/imap)
+@@ -192,13 +192,7 @@
+ AC_MSG_ERROR(Cannot find rfc822.h. Please check your c-client installation.)
+ fi
+
+- if test -r "$IMAP_DIR/c-client/c-client.a"; then
+- ln -s "$IMAP_DIR/c-client/c-client.a" "$IMAP_DIR/c-client/libc-client.a" >/dev/null 2>&1
+- elif test -r "$IMAP_DIR/$PHP_LIBDIR/c-client.a"; then
+- ln -s "$IMAP_DIR/$PHP_LIBDIR/c-client.a" "$IMAP_DIR/$PHP_LIBDIR/libc-client.a" >/dev/null 2>&1
+- fi
+-
+- for lib in c-client4 c-client imap; do
++ for lib in /usr/lib c-client4 c-client imap; do
+ IMAP_LIB=$lib
+ IMAP_LIB_CHK($PHP_LIBDIR)
+ IMAP_LIB_CHK(c-client)
+Index: php-5.2.11/acinclude.m4
+===================================================================
+--- php-5.2.11.orig/acinclude.m4 2009-12-10 12:37:13.134722881 -0700
++++ php-5.2.11/acinclude.m4 2009-12-10 12:37:39.342007053 -0700
+@@ -2338,7 +2338,7 @@
+ PHP_OPENSSL_DIR="/usr/local/ssl /usr/local /usr /usr/local/openssl"
+ fi
+
+- for i in $PHP_OPENSSL_DIR; do
++ for i in $PHP_OPENSSL_DIR $PHP_OPENSSL_DIR/usr; do
+ if test -r $i/include/openssl/evp.h; then
+ OPENSSL_INCDIR=$i/include
+ fi
diff --git a/recipes/php/php-5.2.13/pear-makefile.patch b/recipes/php/php-5.2.13/pear-makefile.patch
new file mode 100644
index 0000000000..487f507a02
--- /dev/null
+++ b/recipes/php/php-5.2.13/pear-makefile.patch
@@ -0,0 +1,13 @@
+Index: php-5.2.11/pear/Makefile.frag
+===================================================================
+--- php-5.2.11.orig/pear/Makefile.frag 2009-08-02 13:11:15.000000000 -0600
++++ php-5.2.11/pear/Makefile.frag 2009-12-09 16:13:38.700972014 -0700
+@@ -11,7 +11,7 @@
+ PEAR_SUFFIX = -ds a$(program_suffix)
+
+ install-pear-installer: $(SAPI_CLI_PATH)
+- @$(top_builddir)/sapi/cli/php $(PEAR_INSTALL_FLAGS) pear/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)" ${PEAR_PREFIX} ${PEAR_SUFFIX}
++ @$(PHP_NATIVE_DIR)/php $(PEAR_INSTALL_FLAGS) pear/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)" ${PEAR_PREFIX} ${PEAR_SUFFIX}
+
+ install-pear:
+ @echo "Installing PEAR environment: $(INSTALL_ROOT)$(peardir)/"