aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/php
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-23 20:23:53 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:53:41 -0700
commitbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (patch)
tree96f28e2f5133d68c3e3dadabaa2339340671454f /recipes/php
parentfab0af3aefee22b21541e403d3c356a6979bfa63 (diff)
downloadopenembedded-bf7d0467a0788a7fcc1c96e0dc35a25ae09278a0.tar.gz
Rename url params patch=<ignored>/pnum=<n> to apply={yes,no}/striplevel=<n>
I think this makes the behavior rather more clear. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/php')
-rw-r--r--recipes/php/php-native_5.3.2.bb2
-rw-r--r--recipes/php/php.inc4
-rw-r--r--recipes/php/php_5.2.13.bb6
-rw-r--r--recipes/php/php_5.2.6.bb4
4 files changed, 8 insertions, 8 deletions
diff --git a/recipes/php/php-native_5.3.2.bb b/recipes/php/php-native_5.3.2.bb
index 9920088648..4ea0b6d651 100644
--- a/recipes/php/php-native_5.3.2.bb
+++ b/recipes/php/php-native_5.3.2.bb
@@ -2,7 +2,7 @@ require php-native.inc
PR = "r1"
-SRC_URI += "file://CVE-2010-0397.patch;patch=1"
+SRC_URI += "file://CVE-2010-0397.patch;apply=yes"
SRC_URI[src.md5sum] = "46f500816125202c48a458d0133254a4"
SRC_URI[src.sha256sum] = "9a380a574adcb3a9abe3226e7c3a9bae619e8a1b90842ec2a7edf0ad92afdeda"
diff --git a/recipes/php/php.inc b/recipes/php/php.inc
index cbec13d72d..9446b82611 100644
--- a/recipes/php/php.inc
+++ b/recipes/php/php.inc
@@ -4,8 +4,8 @@ SECTION = "console/network"
LICENSE = "PHP"
SRC_URI = "http://us2.php.net/distributions/php-${PV}.tar.bz2;name=src \
- file://acinclude-xml2-config.patch;patch=1 \
- file://php-m4-divert.patch;patch=1"
+ file://acinclude-xml2-config.patch;apply=yes \
+ file://php-m4-divert.patch;apply=yes"
S = "${WORKDIR}/php-${PV}"
diff --git a/recipes/php/php_5.2.13.bb b/recipes/php/php_5.2.13.bb
index dad6bcd44e..1a85f463cc 100644
--- a/recipes/php/php_5.2.13.bb
+++ b/recipes/php/php_5.2.13.bb
@@ -5,9 +5,9 @@ DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native mysql5 \
PR = "r6"
-SRC_URI += "file://pear-makefile.patch;patch=1 \
- file://imap-fix-autofoo.patch;patch=1 \
- file://CVE-2010-0397.patch;patch=1 \
+SRC_URI += "file://pear-makefile.patch;apply=yes \
+ file://imap-fix-autofoo.patch;apply=yes \
+ file://CVE-2010-0397.patch;apply=yes \
"
SRC_URI[src.md5sum] = "eb4d0766dc4fb9667f05a68b6041e7d1"
SRC_URI[src.sha256sum] = "2b50a2535e3bb9a98cd4d1633f9452d877276c40b385915261f040d535c7eadb"
diff --git a/recipes/php/php_5.2.6.bb b/recipes/php/php_5.2.6.bb
index 515eb29ea2..b57c3918b1 100644
--- a/recipes/php/php_5.2.6.bb
+++ b/recipes/php/php_5.2.6.bb
@@ -4,8 +4,8 @@ DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native mysql"
PR = "r7"
-SRC_URI += "file://pear-makefile.patch;patch=1 \
- file://string.c.patch;patch=1 "
+SRC_URI += "file://pear-makefile.patch;apply=yes \
+ file://string.c.patch;apply=yes "
export THREADS="pthread"
export LIBS=" -lpthread "