aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/php
diff options
context:
space:
mode:
authorGraeme Gregory <gg@slimlogic.co.uk>2009-12-10 19:03:08 -0700
committerGraeme Gregory <dp@xora.org.uk>2009-12-11 02:04:39 +0000
commit05f6870abebf2a002f6648fa12c1228b97224b41 (patch)
tree5a269189513400f25fda79232b0ec86fdf026c12 /recipes/php
parent8a2af9e702ff08ea7f3f239e227e6aa4e951b587 (diff)
downloadopenembedded-05f6870abebf2a002f6648fa12c1228b97224b41.tar.gz
php_5.2.11.bb : enable more mysql modules and move to mysql5
Diffstat (limited to 'recipes/php')
-rw-r--r--recipes/php/php_5.2.11.bb11
1 files changed, 7 insertions, 4 deletions
diff --git a/recipes/php/php_5.2.11.bb b/recipes/php/php_5.2.11.bb
index 058f1c2554..5b4871cbc7 100644
--- a/recipes/php/php_5.2.11.bb
+++ b/recipes/php/php_5.2.11.bb
@@ -1,9 +1,9 @@
require php.inc
-DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native mysql \
+DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native mysql5 \
libc-client openssl"
-PR = "r2"
+PR = "r4"
SRC_URI += "file://pear-makefile.patch;patch=1 \
file://imap-fix-autofoo.patch;patch=1 \
@@ -19,7 +19,7 @@ EXTRA_OECONF = " --without-iconv \
--enable-pcntl \
--enable-memory-limit \
--enable-wddx \
- --enable-embedded-mysqli \
+ --disable-embedded-mysqli \
--enable-magic-quotes \
--enable-fastcgi \
--with-imap=${STAGING_DIR_HOST} \
@@ -27,7 +27,8 @@ EXTRA_OECONF = " --without-iconv \
--with-zlib --with-zlib-dir=${STAGING_LIBDIR}/.. \
--with-libxml-dir=${STAGING_BINDIR_CROSS} \
--with-mysql="${STAGING_DIR_TARGET}${layout_exec_prefix}" \
-# --with-mysqli = "${STAGING_BINDIR_NATIVE}/mysql_config" \
+ --with-mysqli="${STAGING_BINDIR_CROSS}/mysql_config" \
+ --with-pdo-mysql="${STAGING_BINDIR_CROSS}/mysql_config" \
--without-pdo-sqlite \
"
@@ -35,6 +36,8 @@ export LD_LIBRARY_PATH = "${STAGING_LIBDIR}"
export PHP_NATIVE_DIR = "${STAGING_BINDIR_NATIVE}"
export PHP_PEAR_PHP_BIN = "${bindir}/php"
+#LDFLAGS += "-lstdc++"
+
do_configure_append() {
find ${S} -type f | xargs sed -i 's:I/usr/include:I${STAGING_INCDIR}:g'
}