aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/picocom
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/picocom
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/picocom')
-rw-r--r--recipes/picocom/picocom/gcc4.patch12
-rw-r--r--recipes/picocom/picocom/nolock.patch35
-rw-r--r--recipes/picocom/picocom_1.3.bb16
-rw-r--r--recipes/picocom/picocom_1.4.bb16
4 files changed, 79 insertions, 0 deletions
diff --git a/recipes/picocom/picocom/gcc4.patch b/recipes/picocom/picocom/gcc4.patch
new file mode 100644
index 0000000000..867ca11bf3
--- /dev/null
+++ b/recipes/picocom/picocom/gcc4.patch
@@ -0,0 +1,12 @@
+Index: picocom-1.4/picocom.c
+===================================================================
+--- picocom-1.4.orig/picocom.c 2004-08-12 13:45:11.000000000 +0200
++++ picocom-1.4/picocom.c 2007-03-08 14:40:30.000000000 +0100
+@@ -37,6 +37,7 @@
+ #include <sys/stat.h>
+ #include <sys/wait.h>
+ #include <limits.h>
++#include <bits/posix1_lim.h>
+
+ #define _GNU_SOURCE
+ #include <getopt.h>
diff --git a/recipes/picocom/picocom/nolock.patch b/recipes/picocom/picocom/nolock.patch
new file mode 100644
index 0000000000..42ca57f927
--- /dev/null
+++ b/recipes/picocom/picocom/nolock.patch
@@ -0,0 +1,35 @@
+diff -Naur picocom-1.4.orig/picocom.c picocom-1.4/picocom.c
+--- picocom-1.4.orig/picocom.c 2004-08-12 13:45:11.000000000 +0200
++++ picocom-1.4/picocom.c 2007-03-12 00:23:01.000000000 +0100
+@@ -790,7 +790,9 @@
+ {"escape", required_argument, 0, 'e'},
+ {"noinit", no_argument, 0, 'i'},
+ {"noreset", no_argument, 0, 'r'},
++#ifdef UUCP_LOCK_DIR
+ {"nolock", no_argument, 0, 'l'},
++#endif
+ {"flow", required_argument, 0, 'f'},
+ {"baud", required_argument, 0, 'b'},
+ {"parity", required_argument, 0, 'p'},
+@@ -827,9 +829,11 @@
+ case 'r':
+ opts.noreset = 1;
+ break;
++#ifdef UUCP_LOCK_DIR
+ case 'l':
+ opts.nolock = 1;
+ break;
++#endif
+ case 'e':
+ if ( isupper(optarg[0]) )
+ opts.escape = optarg[0] - 'A' + 1;
+@@ -930,7 +934,9 @@
+ printf("escape is : C-%c\n", 'a' + opts.escape - 1);
+ printf("noinit is : %s\n", opts.noinit ? "yes" : "no");
+ printf("noreset is : %s\n", opts.noreset ? "yes" : "no");
++#ifdef UUCP_LOCK_DIR
+ printf("nolock is : %s\n", opts.nolock ? "yes" : "no");
++#endif
+ printf("send_cmd is : %s\n", opts.send_cmd);
+ printf("receive_cmd is : %s\n", opts.receive_cmd);
+ printf("\n");
diff --git a/recipes/picocom/picocom_1.3.bb b/recipes/picocom/picocom_1.3.bb
new file mode 100644
index 0000000000..6c8bd0eb37
--- /dev/null
+++ b/recipes/picocom/picocom_1.3.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Picocom is a lightweight and minimal (~20K) dumb-terminal emulation program. "
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "GPL"
+SRC_URI = "http://efault.net/npat/hacks/picocom/dist/picocom-${PV}.tar.gz"
+
+CFLAGS_append = ' -DVERSION_STR=\\"${PV}\\"'
+
+do_compile() {
+ oe_runmake
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 ${PN} pcasc pcxm pcym pczm ${D}${bindir}/
+}
diff --git a/recipes/picocom/picocom_1.4.bb b/recipes/picocom/picocom_1.4.bb
new file mode 100644
index 0000000000..c13bdabcc3
--- /dev/null
+++ b/recipes/picocom/picocom_1.4.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Lightweight and minimal (~20K) dumb-terminal emulation program."
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "http://efault.net/npat/hacks/picocom/dist/picocom-${PV}.tar.gz \
+ file://nolock.patch;patch=1 \
+ file://gcc4.patch;patch=1"
+
+CFLAGS_append = ' -DVERSION_STR=\\"${PV}\\"'
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 ${PN} pcasc pcxm pcym pczm ${D}${bindir}/
+}