aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pidgin/pidgin
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-10-10 10:32:45 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-10-10 10:32:45 +0000
commit4089b4dd14270a884101cc7b8c240998c4354cd0 (patch)
tree83acc0bfa79c33f5d9361c290102363a08273363 /recipes/pidgin/pidgin
parent0d081f788afc5d2e9b5d05895e379056a5a90809 (diff)
downloadopenembedded-4089b4dd14270a884101cc7b8c240998c4354cd0.tar.gz
pidgin: crash and recipe fixes:
* Fixed status icon theme crash on startup. * Use --disable-schemas-install instead of gconf-no-errors.patch. * Introduced INC_PR.
Diffstat (limited to 'recipes/pidgin/pidgin')
-rw-r--r--recipes/pidgin/pidgin/gconf-no-errors.patch12
-rw-r--r--recipes/pidgin/pidgin/status-icon-theme-crash.patch27
2 files changed, 27 insertions, 12 deletions
diff --git a/recipes/pidgin/pidgin/gconf-no-errors.patch b/recipes/pidgin/pidgin/gconf-no-errors.patch
deleted file mode 100644
index 9a95175ac9..0000000000
--- a/recipes/pidgin/pidgin/gconf-no-errors.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- /tmp/Makefile.am 2007-05-08 18:39:49.000000000 +0200
-+++ pidgin-2.0.0/libpurple/gconf/Makefile.am 2007-05-08 18:40:13.755251000 +0200
-@@ -8,8 +8,7 @@
-
- if GCONF_SCHEMAS_INSTALL
- install-data-local:
-- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(schema_DATA) 2>&1 | \
-- grep -v "^WARNING: failed to install schema" | grep -v "^Attached schema" 1>&2
-+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(schema_DATA) 2>&1
- else
- install-data-local:
- endif
diff --git a/recipes/pidgin/pidgin/status-icon-theme-crash.patch b/recipes/pidgin/pidgin/status-icon-theme-crash.patch
new file mode 100644
index 0000000000..0cbd6067ea
--- /dev/null
+++ b/recipes/pidgin/pidgin/status-icon-theme-crash.patch
@@ -0,0 +1,27 @@
+This is a backport of missing chunk of the patch:
+
+Author: qulogic@pidgin.im
+Changelog: I guess this pref name was changed but this one line was not. This would
+cause the status icon theme to revert to the default on startup.
+Fixes #10155.
+Date: Tue, 01 Sep 2009 00:33:52 GMT
+#
+#
+# patch "pidgin/pidginstock.c"
+# from [2487a2d68312f5afff439a0fa765c3fe40553701]
+# to [d1da5e342d29fffdf381c68b779c2cb80c5e2caf]
+#
+Index: pidgin-2.6.2/pidgin/pidginstock.c
+===================================================================
+--- pidgin-2.6.2.orig/pidgin/pidginstock.c
++++ pidgin-2.6.2/pidgin/pidginstock.c
+@@ -609,7 +609,8 @@ pidgin_stock_init(void)
+
+ PidginStatusIconTheme *theme = PIDGIN_STATUS_ICON_THEME(purple_theme_loader_build(PURPLE_THEME_LOADER(loader), path));
+ pidgin_stock_load_status_icon_theme(theme);
+- g_object_unref(G_OBJECT(theme));
++ if (theme)
++ g_object_unref(G_OBJECT(theme));
+
+ }
+ else