aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pimlico
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-06-02 15:04:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-06-03 07:33:27 +0200
commitd4276bed389b7db06db58c7acebb83f92bff86a5 (patch)
tree2386574b6ab0c36a58a314a24d31f6b5c9291a65 /recipes/pimlico
parent823aa270059259ca619e21a5d9b22e86afb12f3b (diff)
downloadopenembedded-d4276bed389b7db06db58c7acebb83f92bff86a5.tar.gz
recipes: conform to OE packaging guidelines with RDEPENDS/RRECOMMENDS
* there is probably very few cases when it's needed without _${PN}, if you find one in attached patch, please enlighten me * usually we want those only for ${PN} not for all ${PACKAGES} ie ${PN}-dev, ${PN)-doc etc * there is a check for this in recipe-sanity.bclass * there is maybe few possible fixes also in bbclasses cpan-base.bbclass:RDEPENDS += "${@["perl", ""][(bb.data.inherits_class('native', d))]}" distutils-base.bbclass:RDEPENDS += "python-core" gtk-icon-cache.bbclass:RDEPENDS += "hicolor-icon-theme" image.bbclass:RDEPENDS += "${IMAGE_INSTALL} ${IMAGE_BOOT}" module.bbclass:RDEPENDS += "kernel (${KERNEL_VERSION}) update-modules" ?opie_i18n.bbclass: rdepends = bb.data.getVar("RDEPENDS", d, 1) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS_%s' % x[0].lower(), pn, d) ?opie_i18n.bbclass: bb.data.setVar('RDEPENDS', rdepends, d) rubyextension.bbclass:RDEPENDS += "ruby" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/pimlico')
-rw-r--r--recipes/pimlico/contacts.inc2
-rw-r--r--recipes/pimlico/contacts_svn.bb4
-rw-r--r--recipes/pimlico/dates.inc2
3 files changed, 4 insertions, 4 deletions
diff --git a/recipes/pimlico/contacts.inc b/recipes/pimlico/contacts.inc
index 6baab5e306..bd372268ab 100644
--- a/recipes/pimlico/contacts.inc
+++ b/recipes/pimlico/contacts.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "Address-book application."
LICENSE = "LGPL"
SECTION = "x11"
DEPENDS = "glib-2.0 gtk+ eds-dbus libowl"
-RDEPENDS = "libedata-book"
+RDEPENDS_${PN} = "libedata-book"
inherit autotools pkgconfig
diff --git a/recipes/pimlico/contacts_svn.bb b/recipes/pimlico/contacts_svn.bb
index daf1014ab8..bf34650606 100644
--- a/recipes/pimlico/contacts_svn.bb
+++ b/recipes/pimlico/contacts_svn.bb
@@ -1,8 +1,8 @@
require contacts.inc
#DEPENDS += "gnome-vfs"
-#RDEPENDS += "gnome-vfs-plugin-file"
-#RRECOMMENDS += "gnome-vfs-plugin-http"
+#RDEPENDS_${PN} += "gnome-vfs-plugin-file"
+#RRECOMMENDS_${PN} += "gnome-vfs-plugin-http"
PV = "0.8+svnr${SRCPV}"
diff --git a/recipes/pimlico/dates.inc b/recipes/pimlico/dates.inc
index 40a88ea5c0..b0d4f7b9aa 100644
--- a/recipes/pimlico/dates.inc
+++ b/recipes/pimlico/dates.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "Dates is a calendar application."
LICENSE = "LGPL"
SECTION = "x11"
DEPENDS = "glib-2.0 gtk+ libglade eds-dbus libowl"
-RDEPENDS = "libedata-cal"
+RDEPENDS_${PN} = "libedata-cal"
inherit autotools pkgconfig gtk-icon-cache