aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pingus/pingus_0.7.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pingus/pingus_0.7.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pingus/pingus_0.7.2.bb')
-rw-r--r--recipes/pingus/pingus_0.7.2.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes/pingus/pingus_0.7.2.bb b/recipes/pingus/pingus_0.7.2.bb
new file mode 100644
index 0000000000..a10131fa51
--- /dev/null
+++ b/recipes/pingus/pingus_0.7.2.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "Pingus is a free Lemmings clone."
+DEPENDS = "virtual/libsdl libsdl-image libsdl-mixer boost libpng"
+LICENSE = "GPL"
+HOMEPAGE = "http://pingus.seul.org/"
+SECTION = "x11/games"
+PR = "r1"
+
+ARM_INSTRUCTION_SET = "arm"
+
+inherit scons
+
+SRC_URI = "\
+ http://pingus.seul.org/files/pingus-0.7.2.tar.bz2 \
+ file://sconstruct.diff;patch=1 \
+ file://pingus.desktop \
+ file://pingus.png \
+ file://pingus-gta012.sh \
+"
+S = "${WORKDIR}/pingus-${PV}"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/pingus
+ install -d ${D}${datadir}/pixmaps
+ install -d ${D}${datadir}/applications
+ install -m 0644 ${WORKDIR}/pingus.png ${D}${datadir}/pixmaps
+ cp -a ${S}/data ${D}/${datadir}/pingus
+ install -m 0644 ${WORKDIR}/pingus.desktop ${D}${datadir}/applications
+
+ # specialized start script for OM devices
+ if test "${MACHINE}" = om-gta01 || test "${MACHINE}" = om-gta02 ; then
+ install -m 0755 ${WORKDIR}/pingus-gta012.sh ${D}${bindir}/pingus
+ install -m 0755 ${S}/pingus ${D}${bindir}/pingus.bin
+ else
+ install -m 0755 ${S}/pingus ${D}${bindir}/pingus
+ fi
+}
+
+# Account for 1337 script in do_install
+PACKAGE_ARCH_om-gta01 = "${MACHINE_ARCH}"
+PACKAGE_ARCH_om-gta02 = "${MACHINE_ARCH}"
+
+FILES_${PN} += "${datadir}"
+