summaryrefslogtreecommitdiffstats
path: root/recipes/pipepanic
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pipepanic
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pipepanic')
-rw-r--r--recipes/pipepanic/files/fix-datadir.patch16
-rw-r--r--recipes/pipepanic/pipepanic_0.1.1.bb27
2 files changed, 43 insertions, 0 deletions
diff --git a/recipes/pipepanic/files/fix-datadir.patch b/recipes/pipepanic/files/fix-datadir.patch
new file mode 100644
index 0000000000..479b266efe
--- /dev/null
+++ b/recipes/pipepanic/files/fix-datadir.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- pipepanic-0.1.1-source/main.h~fix-datadir
++++ pipepanic-0.1.1-source/main.h
+@@ -20,7 +20,7 @@
+ #define FALSE 0
+ #define TRUE 1
+ #define VERSION "0.1.1"
+-#define DATADIR "/opt/QtPalmtop/share/pipepanic/"
++#define DATADIR "/usr/share/pipepanic/"
+ #define DIGITS24BMP "digits24.bmp"
+ #define DIGITS48BMP "digits48.bmp"
+ #define TILES24BMP "tiles24.bmp"
diff --git a/recipes/pipepanic/pipepanic_0.1.1.bb b/recipes/pipepanic/pipepanic_0.1.1.bb
new file mode 100644
index 0000000000..91d53b9524
--- /dev/null
+++ b/recipes/pipepanic/pipepanic_0.1.1.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Pipepanic is a pipe connecting game using libSDL. \
+Connect as many different shaped pipes together as possible within the time given."
+HOMEPAGE = "http://www.users.waitrose.com/~thunor/pipepanic/"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "http://www.users.waitrose.com/~thunor/pipepanic/dload/pipepanic-${PV}-source.tar.gz \
+ file://fix-datadir.patch;patch=1"
+S = "${WORKDIR}/pipepanic-0.1.1-source"
+
+APPIMAGE = "zaurus/pipepanic.png"
+APPDESKTOP = "zaurus/pipenaic.desktop"
+
+inherit sdl
+
+do_compile() {
+ oe_runmake CC="${CC}" CFLAGS="${CFLAGS}" LINK="${CCLD}" LDFLAGS="${LDFLAGS} -Wl,-rpath-link,${STAGING_LIBDIR}/../qt2/lib"
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 pipepanic ${D}${bindir}
+
+ install -d ${D}${datadir}/pipepanic
+ install -m 0644 *.bmp ${D}${datadir}/pipepanic/
+}
+