aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pngcrush
diff options
context:
space:
mode:
authorDenis 'Gnutoo' Carikli <GNUtoo@no-log.org>2010-01-25 16:03:02 +0100
committerDenis 'Gnutoo' Carikli <GNUtoo@no-log.org>2010-01-27 17:29:18 +0100
commit269e3d5199f7db81effd65b6e53468864b414aa3 (patch)
tree53eb99153696b07dc4d96c5c2584c586ae3313cc /recipes/pngcrush
parentfba1e60aafde58daddc848ebdf07d84bd94cf435 (diff)
downloadopenembedded-269e3d5199f7db81effd65b6e53468864b414aa3.tar.gz
pngcrush_1.6.4.bb : use BPN(fixes pngcrush-native install)
The problem is that pngcrush-native fails during the installation because of this code in pngcrush_1.6.4.bb: install -m 755 ${PN} ${D}${bindir} that is in the do_install function. This code is inherited by pngcrush-native because pngcrush-native requires pngcrush_${PV}.bb,and PN becomes pngcrush-native instead of pngcrush and so it fails. Thanks hrw for learning me how to fix it easily(without copying the do_install function from pngcrush_1.6.4.bb into pngcrush-native) The effect of BPN on the 2 recipes was tested in bitbake -i Not changing PR because it doesn't change anything on pngcrush_1.6.4.bb's side,and on pngcrush-native's side it was just a compilation failure
Diffstat (limited to 'recipes/pngcrush')
-rw-r--r--recipes/pngcrush/pngcrush_1.6.4.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes/pngcrush/pngcrush_1.6.4.bb b/recipes/pngcrush/pngcrush_1.6.4.bb
index 9f0413a6cc..8d3781161e 100644
--- a/recipes/pngcrush/pngcrush_1.6.4.bb
+++ b/recipes/pngcrush/pngcrush_1.6.4.bb
@@ -10,5 +10,5 @@ EXTRA_OEMAKE = "CC='${CC}' CFLAGS='${CFLAGS}' LD='${CC}'"
do_install () {
install -d ${D}${bindir}
- install -m 755 ${PN} ${D}${bindir}
+ install -m 755 ${BPN} ${D}${bindir}
}