aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/portmap/portmap_6.0.bb
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2009-08-10 04:49:55 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2009-08-10 06:49:53 +0200
commit4fe22eed50ce7c45da30b0efc6106b90281ff5f5 (patch)
tree2cdb26a07868492c136fe014c9e7ed35d083981f /recipes/portmap/portmap_6.0.bb
parentf20d7d2a7e87b6c9fa8f368cce8813188c80f00c (diff)
downloadopenembedded-4fe22eed50ce7c45da30b0efc6106b90281ff5f5.tar.gz
portmap_6.0: Fix building on mipsel with gcc4.3
with gcc-4.4 and provides the following: | tmp/cross/mipsel/lib/gcc/mipsel-angstrom-linux/4.4.1/../../../../mipsel-angstrom-linux/bin/ld: portmap.o: relocation R_MIPS_HI16 against `__gnu_local_gp' can not be used when making a shared object; recompile with -fPIC The CFLAGS in portmap's Makefile contains -fpie, but is ignored. The CFLAGS I've added below are constructed from portmap's Makefile. When built with gcc-4.3.3 the resultant binary no longer segfaults. Signed-Off-By: Holger Hans Peter Freyther <zecke@selfish.org>
Diffstat (limited to 'recipes/portmap/portmap_6.0.bb')
-rw-r--r--recipes/portmap/portmap_6.0.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/recipes/portmap/portmap_6.0.bb b/recipes/portmap/portmap_6.0.bb
index cb94a48fb7..501aa5d848 100644
--- a/recipes/portmap/portmap_6.0.bb
+++ b/recipes/portmap/portmap_6.0.bb
@@ -1,6 +1,6 @@
require portmap.inc
-PR = "r3"
+PR = "r4"
SRC_URI = "http://www.sourcefiles.org/Networking/Tools/Miscellanenous/portmap-6.0.tgz \
file://destdir-no-strip.patch;patch=1 \
@@ -8,12 +8,10 @@ SRC_URI = "http://www.sourcefiles.org/Networking/Tools/Miscellanenous/portmap-6.
file://no-libwrap.patch;patch=1;pnum=0 \
file://portmap.init "
-# Remove this patch when SlugOS upgrades to binutils 1.18
-SRC_URI_append_slugos = " file://no-pie.patch;patch=1 "
-
S = "${WORKDIR}/${PN}_${PV}/"
CPPFLAGS += "-DFACILITY=LOG_DAEMON -DENABLE_DNS"
+CFLAGS += "-O2 -Wall -Wstrict-prototypes -fpie"
fakeroot do_install() {
install -d ${D}${mandir}/man8/ ${D}${base_sbindir} ${D}${sysconfdir}/init.d