aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powervr-drivers/libgles-omap3_3.00.00.09.bb
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2009-07-17 14:19:31 +0400
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2009-07-17 14:19:31 +0400
commitd6573b8bf03ea7b7789ac3977820706cb779c815 (patch)
tree17fb78ec58b30893c2c916afa7710bfcd67a5db3 /recipes/powervr-drivers/libgles-omap3_3.00.00.09.bb
parent54dfc8da23a6990dc84f5de94968e4b212447594 (diff)
parent88290161c02e7dc418f43202ccd92334a42e70e7 (diff)
downloadopenembedded-d6573b8bf03ea7b7789ac3977820706cb779c815.tar.gz
Merge commit 'origin/org.openembedded.dev' into org.openembedded.dev
Diffstat (limited to 'recipes/powervr-drivers/libgles-omap3_3.00.00.09.bb')
-rw-r--r--recipes/powervr-drivers/libgles-omap3_3.00.00.09.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/powervr-drivers/libgles-omap3_3.00.00.09.bb b/recipes/powervr-drivers/libgles-omap3_3.00.00.09.bb
new file mode 100644
index 0000000000..6a04e8359b
--- /dev/null
+++ b/recipes/powervr-drivers/libgles-omap3_3.00.00.09.bb
@@ -0,0 +1,26 @@
+require libgles-omap3.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+SGXPV = "3_00_00_09"
+IMGPV = "1.3.13.1832"
+BINFILE := "OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin"
+
+# The ES2.x and ES3.x CPUs have different SGX hardware, so we need to install 2 sets of userspace
+do_install_append() {
+ install -d ${D}${libdir}/ES3.0
+ install -d ${D}${libdir}/ES2.0
+ install -d ${D}${bindir}/ES3.0
+ install -d ${D}${bindir}/ES2.0
+
+ cp ${S}/gfx_rel_es2.x/lib* ${D}${libdir}/ES2.0/
+ cp ${S}/gfx_rel_es2.x/p[dv]* ${D}${bindir}/ES2.0/
+
+ cp ${D}${libdir}/lib*${IMGPV} ${D}${libdir}/ES3.0/
+ cp ${D}${bindir}/p[dv]* ${D}${bindir}/ES3.0
+}
+
+# Quality control is really poor on these SDKs, so hack around the latest madness:
+FILES_${PN} += "${libdir}/*.so"
+FILES_${PN}-dev = "${includedir}"
+