aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powervr-drivers
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-10-18 15:30:13 +0200
committerKoen Kooi <koen@openembedded.org>2009-10-18 15:32:39 +0200
commit213bf9c00e99b81df64d302932944bdbc6f9ed65 (patch)
treee9192d230f9b7c6c5354196fded8c1eb243e458b /recipes/powervr-drivers
parentf63f03571570ce2a575702b3f04e70e9406a6788 (diff)
downloadopenembedded-213bf9c00e99b81df64d302932944bdbc6f9ed65.tar.gz
omap3 sgx modules: make proc interface patch use proper kernel version macros, courtesy Bin Liu
Diffstat (limited to 'recipes/powervr-drivers')
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules/proc-interface.patch18
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1607.bb6
2 files changed, 11 insertions, 13 deletions
diff --git a/recipes/powervr-drivers/omap3-sgx-modules/proc-interface.patch b/recipes/powervr-drivers/omap3-sgx-modules/proc-interface.patch
index 831b3edd4d..c11a9b7017 100644
--- a/recipes/powervr-drivers/omap3-sgx-modules/proc-interface.patch
+++ b/recipes/powervr-drivers/omap3-sgx-modules/proc-interface.patch
@@ -1,20 +1,22 @@
-Index: omap3-sgx-modules-1.3.13.1607/services4/srvkm/env/linux/proc.c
-===================================================================
---- omap3-sgx-modules-1.3.13.1607.orig/services4/srvkm/env/linux/proc.c
-+++ omap3-sgx-modules-1.3.13.1607/services4/srvkm/env/linux/proc.c
-@@ -134,7 +134,6 @@ int CreateProcEntry(const char * name, r
+--- ./GFX_Linux_KM/services4/srvkm/env/linux/proc.c.orig 2009-10-09 13:46:40.000000000 -0500
++++ ./GFX_Linux_KM/services4/srvkm/env/linux/proc.c 2009-10-09 13:48:36.000000000 -0500
+@@ -134,7 +134,9 @@
if (file)
{
-- file->owner = THIS_MODULE;
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,31)
+ file->owner = THIS_MODULE;
++#endif
file->read_proc = rhandler;
file->write_proc = whandler;
file->data = data;
-@@ -165,7 +164,6 @@ int CreateProcReadEntry(const char * nam
+@@ -165,7 +167,9 @@
if (file)
{
-- file->owner = THIS_MODULE;
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,31)
+ file->owner = THIS_MODULE;
++#endif
return 0;
}
diff --git a/recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1607.bb b/recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1607.bb
index ea57fd2288..a0dc97c170 100644
--- a/recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1607.bb
+++ b/recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1607.bb
@@ -7,13 +7,9 @@ SRC_URI = "file://omap3-sgx-modules-${PV}.tar.bz2 \
file://0002-Compile-fixes-for-DSS2.patch;patch=1 \
file://rotation-dss2.patch;patch=1 \
file://build_es3.x_sgx.patch;patch=1 \
+ file://proc-interface.patch;patch=1 \
"
-SRC_URI_append_omapzoom2 = " file://proc-interface.patch;patch=1"
-SRC_URI_append_omap3evm = " file://proc-interface.patch;patch=1"
-SRC_URI_append_omap3517-evm = " file://proc-interface.patch;patch=1"
-
-
PVRBUILD = "release"
MAKE_TARGETS = " BUILD=${PVRBUILD}"