aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powervr-drivers
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-18 09:21:44 +0200
committerKoen Kooi <koen@openembedded.org>2009-06-18 09:21:44 +0200
commit8812174c3e3e00ac40cca82ebf9ae0a04e22e15a (patch)
tree516d46c6b6af0c68f320284dea525fdd450f7739 /recipes/powervr-drivers
parent79d4ef181586b7113e87f2e8ef777d3631cc1238 (diff)
downloadopenembedded-8812174c3e3e00ac40cca82ebf9ae0a04e22e15a.tar.gz
libgles-omap3: add recipe for .08 release
* the vrfb fixes aren't in this release, so remove the initscript that fixes those up
Diffstat (limited to 'recipes/powervr-drivers')
-rwxr-xr-xrecipes/powervr-drivers/libgles-omap3-3.00.00.08/rc.pvr41
-rw-r--r--recipes/powervr-drivers/libgles-omap3_3.00.00.08.bb11
2 files changed, 11 insertions, 41 deletions
diff --git a/recipes/powervr-drivers/libgles-omap3-3.00.00.08/rc.pvr b/recipes/powervr-drivers/libgles-omap3-3.00.00.08/rc.pvr
deleted file mode 100755
index 3505e63dfa..0000000000
--- a/recipes/powervr-drivers/libgles-omap3-3.00.00.08/rc.pvr
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/bin/sh
-
-#rmmod bc_example
-rmmod omaplfb
-rmmod pvrsrvkm
-
-insmod $(busybox find /lib/modules/$(uname -r) -name "pvrsrvkm.ko")
-#modprobe bc_example
-modprobe omaplfb
-
-pvr_maj=`grep "pvrsrvkm$" /proc/devices | cut -b1,2,3`
-
-if [ -e /dev/pvrsrvkm ] ; then
- rm -f /dev/pvrsrvkm
-fi
-
-mknod /dev/pvrsrvkm c $pvr_maj 0
-chmod 666 /dev/pvrsrvkm
-
-touch /etc/powervr-esrev
-
-SAVED_ESREVISION="$(cat /etc/powervr-esrev)"
-ES_REVISION="$(cat /proc/cpuinfo | grep "CPU revision" | awk -F: '{print $2}')"
-
-if [ "${ES_REVISION}" != "${SAVED_ESREVISION}" ] ; then
- echo -n "Starting SGX fixup for"
- if [ "${ES_REVISION}" = " 3" ] ; then
- echo " ES3.x"
- cp -a /usr/lib/ES3.0/* /usr/lib
- cp -a /usr/bin/ES3.0/* /usr/bin
- else
- echo "ES 2.x"
- cp -a /usr/lib/ES2.0/* /usr/lib
- cp -a /usr/bin/ES2.0/* /usr/bin
- fi
-
- echo "${ES_REVISION}" > /etc/powervr-esrev
-fi
-
-/usr/bin/pvrsrvinit
-
diff --git a/recipes/powervr-drivers/libgles-omap3_3.00.00.08.bb b/recipes/powervr-drivers/libgles-omap3_3.00.00.08.bb
new file mode 100644
index 0000000000..a5c0d99143
--- /dev/null
+++ b/recipes/powervr-drivers/libgles-omap3_3.00.00.08.bb
@@ -0,0 +1,11 @@
+require libgles-omap3.inc
+
+DEFAULT_PREFERENCE = "1"
+
+SGXPV = "3_00_00_08"
+IMGPV = "1.3.13.1607"
+
+# Quality control is really poor on these SDKs, so hack around the latest madness:
+FILES_${PN} += "${libdir}/*.so"
+FILES_${PN}-dev = "${includedir}"
+