aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powervr-drivers
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-04-08 10:07:11 +0200
committerKoen Kooi <koen@openembedded.org>2009-04-08 10:07:11 +0200
commitdb359313071eb77f2bde407fd58729a7ac7e0f21 (patch)
tree6f0a9211433a165dfee0235c1193a191aa21a5bf /recipes/powervr-drivers
parenta6169a4840b78f1fd26b4f0ccd3fb6e4ce3efb73 (diff)
downloadopenembedded-db359313071eb77f2bde407fd58729a7ac7e0f21.tar.gz
omap3-sgx-modules: add compile fix for DSS2 changes in linux-omap 2.6.29
Diffstat (limited to 'recipes/powervr-drivers')
-rw-r--r--recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1397.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1397.bb b/recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1397.bb
index fc9f02f5df..3f9a3cdc75 100644
--- a/recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1397.bb
+++ b/recipes/powervr-drivers/omap3-sgx-modules_1.3.13.1397.bb
@@ -14,7 +14,10 @@ PVRBUILD = "release"
MAKE_TARGETS = " BUILD=${PVRBUILD}"
do_compile_prepend() {
- find ${S} -name "*.*o" | xargs rm
+ find ${S} -name "*.*o" | xargs rm || true
+ if [ $(echo ${KERNEL_VERSION} | cut -c5,6) -gt 28 ] ; then
+ sed -i -e 's:omap_dispc_unregister_isr(OMAPLFBVSyncISR):omap_dispc_unregister_isr(OMAPLFBVSyncISR, psSwapChain, DISPC_IRQ_VSYNC):g' services4/3rdparty/dc_omap3430_linux/omaplfb_linux.c
+ fi
}
do_install() {