aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powervr-drivers
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-03-08 16:20:30 +0100
committerKoen Kooi <koen@openembedded.org>2010-03-08 18:47:58 +0100
commite518bd5129becbfbd65e5fbaf611a5cb363c5273 (patch)
tree7070a3b4f15c9c50d623fe71c9ba046314ab639e /recipes/powervr-drivers
parente5dcf0d4e407c1c8f8bb9fd58e3c56f9b1712255 (diff)
downloadopenembedded-e518bd5129becbfbd65e5fbaf611a5cb363c5273.tar.gz
libgles-omap3: autoload bufferclass_ti driver at boot
Diffstat (limited to 'recipes/powervr-drivers')
-rwxr-xr-xrecipes/powervr-drivers/libgles-omap3/rc.pvr5
-rw-r--r--recipes/powervr-drivers/libgles-omap3_3.01.00.02.bb2
2 files changed, 6 insertions, 1 deletions
diff --git a/recipes/powervr-drivers/libgles-omap3/rc.pvr b/recipes/powervr-drivers/libgles-omap3/rc.pvr
index 2a8260baec..ecf5f4a8a3 100755
--- a/recipes/powervr-drivers/libgles-omap3/rc.pvr
+++ b/recipes/powervr-drivers/libgles-omap3/rc.pvr
@@ -35,8 +35,10 @@ if [ $CPUTYPE = "OMAP3530" ]; then
insmod $(busybox find /lib/modules/$(uname -r) -name "pvrsrvkm.ko")
#modprobe bc_example
modprobe omaplfb
+ modprobe bufferclass_ti
pvr_maj=`grep "pvrsrvkm$" /proc/devices | cut -b1,2,3`
+ bc_maj=`grep "bc" /proc/devices | cut -b1,2,3`
if [ -e /dev/pvrsrvkm ] ; then
rm -f /dev/pvrsrvkm
@@ -45,6 +47,9 @@ if [ $CPUTYPE = "OMAP3530" ]; then
mknod /dev/pvrsrvkm c $pvr_maj 0
chmod 666 /dev/pvrsrvkm
+ mknod /dev/bc_cat c $bc_maj 0
+ chmod 666 /dev/bc_cat
+
touch /etc/powervr-esrev
SAVED_ESREVISION="$(cat /etc/powervr-esrev)"
diff --git a/recipes/powervr-drivers/libgles-omap3_3.01.00.02.bb b/recipes/powervr-drivers/libgles-omap3_3.01.00.02.bb
index 65b318ae3f..725e8bb5b9 100644
--- a/recipes/powervr-drivers/libgles-omap3_3.01.00.02.bb
+++ b/recipes/powervr-drivers/libgles-omap3_3.01.00.02.bb
@@ -2,7 +2,7 @@ BINLOCATION = "${S}/gfx_rel_es3.x"
require libgles-omap3.inc
-PR = "r5"
+PR = "r6"
# download required binary distribution from:
# http://software-dl.ti.com/dsps/forms/export.html?prod_no=/OMAP35x_Graphics_SDK_setuplinux_3_01_00_02.bin