aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/preboot/initramfs-preboot-image.bb
diff options
context:
space:
mode:
authorSimon 'Morphis' Busch <morphis@gravedo.de>2010-01-20 18:14:42 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2010-01-20 18:14:42 +0100
commitc87ea56a9e59dd4b3ddf67d900f4e14c1168bcd0 (patch)
tree8af6982d99943fbd57dde9acfc59ed25dcff5d38 /recipes/preboot/initramfs-preboot-image.bb
parent78c0a878694ec91eb3c793e37642819bc3edc87a (diff)
downloadopenembedded-c87ea56a9e59dd4b3ddf67d900f4e14c1168bcd0.tar.gz
preboot: new recipe; a dual boot solution for the palm pre (WIP)
Diffstat (limited to 'recipes/preboot/initramfs-preboot-image.bb')
-rw-r--r--recipes/preboot/initramfs-preboot-image.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/recipes/preboot/initramfs-preboot-image.bb b/recipes/preboot/initramfs-preboot-image.bb
new file mode 100644
index 0000000000..0675916680
--- /dev/null
+++ b/recipes/preboot/initramfs-preboot-image.bb
@@ -0,0 +1,69 @@
+#initramfs image which mounts the rootfilesystem and kexecs a kernel from there
+PR = "r1"
+
+ONLINE_PACKAGE_MANAGEMENT = "none"
+IMAGE_FSTYPES = "cpio.gz"
+
+export IMAGE_BASENAME = "initramfs-preboot-image"
+
+IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
+
+# avoid circular dependencies
+EXTRA_IMAGEDEPENDS = ""
+
+IMAGE_INSTALL = " \
+ task-boot \
+ util-linux-ng-mount util-linux-ng-umount \
+ dropbear \
+ fontconfig \
+ ttf-freefonts \
+ eina \
+ evas \
+ edje \
+ efreet \
+ eet \
+ edbus \
+ elementary \
+ elementary-themes \
+ elementary-tests \
+ fbset \
+ fbset-init \
+ msmcommd \
+# lvm2 \
+# preboot \
+ "
+
+IMAGE_LINGUAS = ""
+
+inherit image
+
+preboot_palmpre_rootfs_postprocess() {
+ # copy all our files to the rootfs
+ dirs=`find ${FILESDIR} -type d -printf "%P\n" | grep -v "^.$" | grep -v ".git"`
+ for dir in $dirs; do
+ mkdir -p ${IMAGE_ROOTFS}/$dir
+ done
+ files=`find ${FILESDIR} -type f -printf "%P\n" | grep -v ".git"`
+ for file in $files; do
+ cp -f ${FILESDIR}/$file ${IMAGE_ROOTFS}/$file
+ done
+
+ curdir=$PWD
+ cd ${IMAGE_ROOTFS}
+
+ # install our usbnet initscript
+ chmod +x etc/init.d/usbnet
+# ln -sf ../init.d/usbnet ${IMAGE_ROOTFS}/etc/rcS.d/S15usbnet
+
+ # miniboot sequence (just for debugging)
+ rm ${IMAGE_ROOTFS}/sbin/init
+ chmod +x ${IMAGE_ROOTFS}/etc/miniboot.sh
+ ln -sf /etc/miniboot.sh ${IMAGE_ROOTFS}/init
+ ln -sf ../etc/miniboot.sh ${IMAGE_ROOTFS}/sbin/init
+
+ cd $curdir
+}
+
+ROOTFS_POSTPROCESS_COMMAND_palmpre += " preboot_palmpre_rootfs_postprocess"
+
+