aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/prism54
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/prism54
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/prism54')
-rw-r--r--recipes/prism54/prism54-firmware_1.0.3.0.bb15
-rw-r--r--recipes/prism54/prism54-firmware_1.0.4.3.bb15
-rw-r--r--recipes/prism54/prism54-module_1.2.bb33
-rw-r--r--recipes/prism54/prism54-module_cvs.bb7
4 files changed, 70 insertions, 0 deletions
diff --git a/recipes/prism54/prism54-firmware_1.0.3.0.bb b/recipes/prism54/prism54-firmware_1.0.3.0.bb
new file mode 100644
index 0000000000..ef6ee2f73c
--- /dev/null
+++ b/recipes/prism54/prism54-firmware_1.0.3.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Firmware for the Prism54 driver"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "unknown"
+
+SRC_URI = "http://daemonizer.de/prism54/prism54-fw/fw-fullmac/${PV}.arm"
+
+S = "${WORKDIR}/prism54.org"
+
+do_install() {
+ install -d ${D}${base_libdir}/firmware/
+ install -m 0644 ${PV}.arm ${D}${base_libdir}/firmware/isl3890
+}
+
+FILES_${PN} = "/lib/firmware/"
diff --git a/recipes/prism54/prism54-firmware_1.0.4.3.bb b/recipes/prism54/prism54-firmware_1.0.4.3.bb
new file mode 100644
index 0000000000..80f1b60157
--- /dev/null
+++ b/recipes/prism54/prism54-firmware_1.0.4.3.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Firmware for the Prism54 driver"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "http://daemonizer.de/prism54/prism54-fw/fw-fullmac/${PV}.arm"
+
+S = "${WORKDIR}/prism54.org"
+
+do_install() {
+ install -d ${D}${base_libdir}/firmware/
+ install -m 0644 ${PV}.arm ${D}${base_libdir}/firmware/isl3890
+}
+
+FILES_${PN} = "/lib/firmware/"
diff --git a/recipes/prism54/prism54-module_1.2.bb b/recipes/prism54/prism54-module_1.2.bb
new file mode 100644
index 0000000000..41285fb412
--- /dev/null
+++ b/recipes/prism54/prism54-module_1.2.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Linux Driver for the 802.11g Prism GT / Prism Duette / Prism Indigo Chipsets"
+SECTION = "base"
+PRIORITY = "optional"
+HOMEPAGE = "http://prism54.org"
+LICENSE = "GPL"
+RDEPENDS = "kernel (${KERNEL_VERSION}) prism54-firmware (1.0.3.0) hotplug"
+RRECOMMENDS = "kernel-module-firmware-class"
+DEPENDS = "virtual/kernel prism54-firmware"
+PR = "r1"
+
+SRC_URI = "http://prism54.org/pub/linux/testing/tars/2004-06/prism54-1.2.tar.bz2"
+
+S = "${WORKDIR}/prism54-${PV}"
+
+inherit module-base
+
+# Hack Alert :D
+ARCH_mipsel = "mips"
+
+EXTRA_OEMAKE = "KDIR=${STAGING_KERNEL_DIR} KMISC=${D}${base_libdir}/modules/${KERNEL_VERSION}/net KVER=${KERNEL_VERSION}"
+
+do_compile() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake modules
+}
+
+do_install() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake install
+
+}
+
+FILES_${PN} = "/lib/modules/"
diff --git a/recipes/prism54/prism54-module_cvs.bb b/recipes/prism54/prism54-module_cvs.bb
new file mode 100644
index 0000000000..bb40f25a45
--- /dev/null
+++ b/recipes/prism54/prism54-module_cvs.bb
@@ -0,0 +1,7 @@
+SECTION = "base"
+PV = "1.2+cvs${SRCDATE}"
+
+require prism54-module_1.2.bb
+
+SRC_URI = "http://prism54.org/pub/linux/snapshot/tars/prism54-cvs-latest.tar.bz2"
+S = "${WORKDIR}/prism54-cvs-latest"