aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/prismstumbler
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/prismstumbler
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/prismstumbler')
-rw-r--r--recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/fix-includes.patch11
-rw-r--r--recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/gpsapi.patch13
-rw-r--r--recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/wireless.patch12
-rw-r--r--recipes/prismstumbler/prismstumbler-0.7.3/bogoconf.patch30
-rw-r--r--recipes/prismstumbler/prismstumbler-0.7.3/crosscompile.patch166
-rw-r--r--recipes/prismstumbler/prismstumbler-0.7.3/libz.patch16
-rw-r--r--recipes/prismstumbler/prismstumbler-0.7.3/wireless.patch21
-rw-r--r--recipes/prismstumbler/prismstumbler_0.7.2.bb57
-rw-r--r--recipes/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb46
-rw-r--r--recipes/prismstumbler/prismstumbler_0.7.3.bb65
10 files changed, 437 insertions, 0 deletions
diff --git a/recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/fix-includes.patch b/recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/fix-includes.patch
new file mode 100644
index 0000000000..f041d45baf
--- /dev/null
+++ b/recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/fix-includes.patch
@@ -0,0 +1,11 @@
+--- src/daemon/gpsctl.c~ 2007-08-01 19:09:31.000000000 +0200
++++ src/daemon/gpsctl.c 2007-08-01 19:09:31.000000000 +0200
+@@ -3,6 +3,7 @@
+ * Alberto GarcĂ­a Hierro <skyhusker@rm-fr.net>
+ */
+
++#include <stdint.h>
+ #include <gps.h>
+ #include "gpsctl.h"
+
+
diff --git a/recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/gpsapi.patch b/recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/gpsapi.patch
new file mode 100644
index 0000000000..638a877b77
--- /dev/null
+++ b/recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/gpsapi.patch
@@ -0,0 +1,13 @@
+--- prismstumbler-0.7.4pre1/src/daemon/gpsctl.c~ 2007-04-04 00:10:03.000000000 +0200
++++ prismstumbler-0.7.4pre1/src/daemon/gpsctl.c 2007-04-04 00:10:03.000000000 +0200
+@@ -30,8 +30,8 @@
+ if(!gps_conn)
+ return 0;
+
+- *lat = (float) gps_conn->newdata.latitude;
+- *lon = (float) gps_conn->newdata.longitude;
++ *lat = (float) gps_conn->fix.latitude;
++ *lon = (float) gps_conn->fix.longitude;
+ return 1;
+ }
+
diff --git a/recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/wireless.patch b/recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/wireless.patch
new file mode 100644
index 0000000000..dfa579f7b1
--- /dev/null
+++ b/recipes/prismstumbler/prismstumbler-0.7.3+0.7.4pre1/wireless.patch
@@ -0,0 +1,12 @@
+diff -ur prismstumbler-0.7.4pre1_old/src/daemon/cards.c prismstumbler-0.7.4pre1/src/daemon/cards.c
+--- prismstumbler-0.7.4pre1_old/src/daemon/cards.c 2006-03-28 19:31:26.000000000 +0200
++++ prismstumbler-0.7.4pre1/src/daemon/cards.c 2007-05-22 14:59:15.000000000 +0200
+@@ -9,6 +9,8 @@
+
+ #include <stdio.h>
+ #include <sys/socket.h>
++#include <linux/types.h>
++#include <net/if.h>
+ #include <linux/wireless.h>
+ #include <glib.h>
+ #include <string.h>
diff --git a/recipes/prismstumbler/prismstumbler-0.7.3/bogoconf.patch b/recipes/prismstumbler/prismstumbler-0.7.3/bogoconf.patch
new file mode 100644
index 0000000000..0d6af60590
--- /dev/null
+++ b/recipes/prismstumbler/prismstumbler-0.7.3/bogoconf.patch
@@ -0,0 +1,30 @@
+--- prismstumbler-0.7.3/configure.ac Wed Mar 10 19:19:56 2004
++++ prismstumbler-0.7.3/configure.ac Tue Oct 26 23:56:36 2004
+@@ -405,8 +405,7 @@
+ if cd $withval; then withval=`pwd`; cd $owd; fi
+ PCAPINC="-I$withval -I$withval/bpf"
+ PCAPLIB="-L$withval -lpcap"
+- elif test -f $withval/include/pcap.h -a \
+- -f $withval/include/net/bpf.h; then
++ elif test -f $withval/include/pcap.h; then
+ owd=`pwd`
+ if cd $withval; then withval=`pwd`; cd $owd; fi
+ PCAPINC="-I$withval/include"
+@@ -416,7 +415,7 @@
+ PCAPLIB="-L$withval/lib -lpcap"
+ fi
+ else
+- AC_ERROR(pcap.h, net/bpf.h, or libpcap.a not found in $withval)
++ AC_ERROR(pcap.h net/bpf.h or libpcap.a not found in $withval)
+ fi
+ ;;
+ esac ],
+@@ -504,7 +503,7 @@
+ [FIND_SQLITE_LIBS($withval, "")],
+ [FIND_SQLITE_LIBS($SQLITEDIRS, "lib")])
+
+-AC_ARG_WITH(mysql-includes,[ --with-sqlite-includes=DIR SQLite includes in DIR],
++AC_ARG_WITH(sqlite-includes,[ --with-sqlite-includes=DIR SQLite includes in DIR],
+ [FIND_SQLITE_INCS($withval, "")],
+ [FIND_SQLITE_INCS($SQLITEDIRS, "include")])
+
diff --git a/recipes/prismstumbler/prismstumbler-0.7.3/crosscompile.patch b/recipes/prismstumbler/prismstumbler-0.7.3/crosscompile.patch
new file mode 100644
index 0000000000..63e9f677a5
--- /dev/null
+++ b/recipes/prismstumbler/prismstumbler-0.7.3/crosscompile.patch
@@ -0,0 +1,166 @@
+Index: prismstumbler-0.7.3/src/gpsd/Makefile.in
+===================================================================
+--- prismstumbler-0.7.3.orig/src/gpsd/Makefile.in
++++ prismstumbler-0.7.3/src/gpsd/Makefile.in
+@@ -128,8 +128,8 @@ xgpsspeed: $(XGPSOBJS)
+ $(LINK.c) -o $@ $(XGPSOBJS) -L. -lgpsd $(LIBXAW) $(ALL_X_LIBS) $(LIBS)
+
+ libgpsd.a: $(LIB_OBJECTS)
+- ar -r libgpsd.a $(LIB_OBJECTS)
+- ranlib libgpsd.a
++ $(AR) -r libgpsd.a $(LIB_OBJECTS)
++ $(RANLIB) libgpsd.a
+
+ clean:
+ rm -f *.o *.a gpsd gps *~ config.status
+Index: prismstumbler-0.7.3/src/gpsd/Makefile
+===================================================================
+--- prismstumbler-0.7.3.orig/src/gpsd/Makefile
++++ prismstumbler-0.7.3/src/gpsd/Makefile
+@@ -1,4 +1,3 @@
+-# Generated automatically from Makefile.in by configure.
+ # Makefile.in
+ # $Modified: Thu Jan 22 11:55:32 1998 by brook $
+
+@@ -7,10 +6,10 @@
+
+ # What we use to compile C files.
+ # CC = cc
+-CC = gcc
++CC = ccache arm-angstrom-linux-gnueabi-gcc -march=armv5te -mtune=xscale
+
+ # The flags we use to compile C files.
+-CFLAGS = -g -O2
++CFLAGS = -I/home/papercrane/oe/angstrom.build/tmp/work/armv5te-angstrom-linux-gnueabi/prismstumbler-0.7.3-r5/prismstumbler-0.7.3/include -D_GNU_SOURCE -isystem/home/papercrane/oe/angstrom.build/tmp/staging/arm-angstrom-linux-gnueabi/include -fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os
+
+
+ ## The C preprocessor.
+@@ -19,7 +18,7 @@ CFLAGS = -g -O2
+ CPP = @CPP_TRADITIONAL@
+
+ # Flags passed to the C preprocessor. ()
+-CPPFLAGS =
++CPPFLAGS = -isystem/home/papercrane/oe/angstrom.build/tmp/staging/arm-angstrom-linux-gnueabi/include
+
+ # Definitions to be passed to the C preprocessor. (-DHAVE_CONFIG_H)
+ DEFS = -DHAVE_CONFIG_H
+@@ -28,10 +27,10 @@ DEFS = -DHAVE_CONFIG_H
+ ## The Linker.
+
+ # Flags passed to the linker. (-g -O)
+-LDFLAGS =
++LDFLAGS = -L/home/papercrane/oe/angstrom.build/tmp/staging/arm-angstrom-linux-gnueabi/lib -Wl,-rpath-link,/home/papercrane/oe/angstrom.build/tmp/staging/arm-angstrom-linux-gnueabi/lib -Wl,-O1
+
+ # Use this for building statically linked executables with GCC.
+-# LDFLAGS = -static
++# LDFLAGS = -static -L/home/papercrane/oe/angstrom.build/tmp/staging/arm-angstrom-linux-gnueabi/lib -Wl,-rpath-link,/home/papercrane/oe/angstrom.build/tmp/staging/arm-angstrom-linux-gnueabi/lib -Wl,-O1
+
+
+ ## Local libraries
+@@ -52,7 +51,7 @@ NETLIBS = $(LIBNSL) $(LIBSOCKET)
+ ## X Libraries
+
+ # Special flags for linking with X. (-L/usr/X11R5/lib)
+-X_LDFLAGS = -L/usr/X11R6/lib
++X_LDFLAGS = -L/usr/lib -L/home/papercrane/oe/angstrom.build/tmp/staging/arm-angstrom-linux-gnueabi/lib
+
+ # Motif library. (-lXm)
+ LIBXM =
+@@ -62,10 +61,10 @@ LIBXM =
+ # LIBXM = -Wl,-Bstatic -Wl,-Bdynamic
+
+ # X extension library; needed for Athena and Motif >= 2.0. (-lXext)
+-LIBXEXT = -lXext
++LIBXEXT =
+
+ # Xpm library; needed for DDD and sometimes for Motif >= 2.0. (-lXpm)
+-LIBXPM = -lXpm
++LIBXPM =
+
+ # Xp library; sometimes needed for Motif >= 2.1. (-lXp)
+ LIBXP =
+@@ -74,13 +73,13 @@ LIBXP =
+ LIBGEN =
+
+ # X toolkit library. (-lXt)
+-LIBXT = -lXt
++LIBXT =
+
+ # Xaw library. (-lXaw)
+-LIBXAW = -lXaw
++LIBXAW =
+
+ # X library. (-lSM -lICE -lX11 -lnsl -lsocket)
+-LIBX11 = -lSM -lICE -lX11
++LIBX11 = -lSM -lICE
+
+ # All libraries shown above
+ ALL_X_LIBS = $(X_LDFLAGS) $(LIBXM) $(LIBXP) $(LIBXPM) $(LIBXEXT) \
+@@ -94,7 +93,7 @@ COMPILE_AND_LINK.c = \
+ $(CC) $(CPPFLAGS) $(DEFS) $(CFLAGS) $(LDFLAGS)
+
+ ## Where to look for X include files. (-I/usr/X11R5/include)
+-X_INCLUDE = -I/usr/X11R6/include
++X_INCLUDE = -I/usr/include -I/home/papercrane/oe/angstrom.build/tmp/staging/arm-angstrom-linux-gnueabi/include/X11
+
+ ## Where to look for include files.
+ INCLUDE = -I. $(X_INCLUDE)
+@@ -129,8 +128,8 @@ xgpsspeed: $(XGPSOBJS)
+ $(LINK.c) -o $@ $(XGPSOBJS) -L. -lgpsd $(LIBXAW) $(ALL_X_LIBS) $(LIBS)
+
+ libgpsd.a: $(LIB_OBJECTS)
+- ar -r libgpsd.a $(LIB_OBJECTS)
+- ranlib libgpsd.a
++ $(AR) -r libgpsd.a $(LIB_OBJECTS)
++ $(RANLIB) libgpsd.a
+
+ clean:
+ rm -f *.o *.a gpsd gps *~ config.status
+Index: prismstumbler-0.7.3/src/gpsd/Makefile.arm
+===================================================================
+--- prismstumbler-0.7.3.orig/src/gpsd/Makefile.arm
++++ prismstumbler-0.7.3/src/gpsd/Makefile.arm
+@@ -94,7 +94,7 @@ COMPILE_AND_LINK.c = \
+ $(CC) $(CPPFLAGS) $(DEFS) $(CFLAGS) $(LDFLAGS)
+
+ ## Where to look for X include files. (-I/usr/X11R5/include)
+-X_INCLUDE = -I/skiff/local/arm-linux/include/X11
++X_INCLUDE = @X_CFLAGS@
+
+ ## Where to look for include files.
+ INCLUDE = -I. $(X_INCLUDE)
+@@ -129,8 +129,8 @@ xgpsspeed: $(XGPSOBJS)
+ $(LINK.c) -o $@ $(XGPSOBJS) -L. -lgpsd $(LIBXAW) $(ALL_X_LIBS) $(LIBS)
+
+ libgpsd.a: $(LIB_OBJECTS)
+- ar -r libgpsd.a $(LIB_OBJECTS)
+- ranlib libgpsd.a
++ $(AR) -r libgpsd.a $(LIB_OBJECTS)
++ $(RANLIB) libgpsd.a
+
+ clean:
+ rm -f *.o *.a gpsd gps *~ config.status
+Index: prismstumbler-0.7.3/src/gpsd/Makefile.i386
+===================================================================
+--- prismstumbler-0.7.3.orig/src/gpsd/Makefile.i386
++++ prismstumbler-0.7.3/src/gpsd/Makefile.i386
+@@ -94,7 +94,7 @@ COMPILE_AND_LINK.c = \
+ $(CC) $(CPPFLAGS) $(DEFS) $(CFLAGS) $(LDFLAGS)
+
+ ## Where to look for X include files. (-I/usr/X11R5/include)
+-X_INCLUDE = -I/usr/X11R6/include
++X_INCLUDE = @X_CFLAGS@
+
+ ## Where to look for include files.
+ INCLUDE = -I. $(X_INCLUDE)
+@@ -129,8 +129,8 @@ xgpsspeed: $(XGPSOBJS)
+ $(LINK.c) -o $@ $(XGPSOBJS) -L. -lgpsd $(LIBXAW) $(ALL_X_LIBS) $(LIBS)
+
+ libgpsd.a: $(LIB_OBJECTS)
+- ar -r libgpsd.a $(LIB_OBJECTS)
+- ranlib libgpsd.a
++ $(AR) -r libgpsd.a $(LIB_OBJECTS)
++ $(RANLIB) libgpsd.a
+
+ clean:
+ rm -f *.o *.a gpsd gps *~ config.status
diff --git a/recipes/prismstumbler/prismstumbler-0.7.3/libz.patch b/recipes/prismstumbler/prismstumbler-0.7.3/libz.patch
new file mode 100644
index 0000000000..8e0532f7a8
--- /dev/null
+++ b/recipes/prismstumbler/prismstumbler-0.7.3/libz.patch
@@ -0,0 +1,16 @@
+Index: src/Makefile.in
+===================================================================
+RCS file: /cvs/apps/prismstumbler/src/Makefile.in,v
+retrieving revision 1.5
+diff -u -r1.5 Makefile.in
+--- src/Makefile.in 1 Oct 2004 23:03:57 -0000 1.5
++++ src/Makefile.in 29 Nov 2004 23:19:29 -0000
+@@ -89,7 +89,7 @@
+
+ bin_PROGRAMS = prismstumbler psfront
+
+-psfront_LDADD = -L@SQLITELIB@ -lsqlite $(LIBGTK)
++psfront_LDADD = -L@SQLITELIB@ -lsqlite -lz $(LIBGTK)
+ psfront_CFLAGS = $(INCLUDES)
+
+ prismstumbler_LDADD = @PCAPLIB@ -lm gpsd/libgpsd.a $(LIBGTK)
diff --git a/recipes/prismstumbler/prismstumbler-0.7.3/wireless.patch b/recipes/prismstumbler/prismstumbler-0.7.3/wireless.patch
new file mode 100644
index 0000000000..729a88d0c3
--- /dev/null
+++ b/recipes/prismstumbler/prismstumbler-0.7.3/wireless.patch
@@ -0,0 +1,21 @@
+--- prismstumbler-0.7.3/src/iface-wlan-14.c.orig 2007-04-30 22:22:11.000000000 +0200
++++ prismstumbler-0.7.3/src/iface-wlan-14.c 2007-04-30 22:22:40.000000000 +0200
+@@ -26,6 +26,7 @@
+ #include <string.h>
+ #include <errno.h>
+
++#include <net/if.h>
+ #include <sys/ioctl.h>
+ #include <sys/socket.h>
+ #include <linux/types.h> /* for "__kernel_caddr_t" et al */
+--- prismstumbler-0.7.3/src/cards.c.orig 2007-04-30 22:23:06.000000000 +0200
++++ prismstumbler-0.7.3/src/cards.c 2007-04-30 22:23:33.000000000 +0200
+@@ -9,6 +9,8 @@
+
+ #include <stdio.h>
+ #include <sys/socket.h>
++#include <linux/types.h>
++#include <net/if.h>
+ #include <linux/wireless.h>
+ #include <glib.h>
+ #include <string.h>
diff --git a/recipes/prismstumbler/prismstumbler_0.7.2.bb b/recipes/prismstumbler/prismstumbler_0.7.2.bb
new file mode 100644
index 0000000000..cda97bc832
--- /dev/null
+++ b/recipes/prismstumbler/prismstumbler_0.7.2.bb
@@ -0,0 +1,57 @@
+SECTION = "x11/network"
+PR = "r1"
+
+PACKAGES = "${PN}-dbg prismstumbler prismstumbler-frontend"
+DESCRIPTION = "Prismstumbler wireless LAN scanner"
+LICENSE = "GPL"
+DEPENDS = "libpcap gtk+ wireless-tools sqlite"
+
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/prismstumbler/${PN}-${PV}.tar.bz2"
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = ""
+CFLAGS =+ "-I${S}/include"
+
+FILES_${PN} = "${bindir}/prismstumbler"
+
+FILES_prismstumbler-frontend = "${bindir}/psfront ${bindir}/pst \
+ ${datadir}/applications \
+ ${datadir}/pixmaps ${docdir}/prismstumbler/help.txt \
+ ${sysconfdir}"
+
+do_configure() {
+ cd ${S};
+ oe_runconf;
+ cd ${S}/src/gpsd;
+ rm Makefile;
+ rm config.log;
+ rm config.cache;
+ ${S}/src/gpsd/configure \
+ --build=${BUILD_SYS} \
+ --host=${HOST_SYS} \
+ --target=${TARGET_SYS} \
+ --prefix=${prefix} \
+ --exec_prefix=${exec_prefix} \
+ --bindir=${bindir} \
+ --sbindir=${sbindir} \
+ --libexecdir=${libexecdir} \
+ --datadir=${datadir} \
+ --sysconfdir=${sysconfdir} \
+ --sharedstatedir=${sharedstatedir} \
+ --localstatedir=${localstatedir} \
+ --libdir=${libdir} \
+ --includedir=${includedir} \
+ --oldincludedir=${oldincludedir} \
+ --infodir=${infodir} \
+ --mandir=${mandir} \
+ ${EXTRA_OECONF} \
+ $@;
+}
+
+do_install_append() {
+ chmod a+s ${D}${bindir}/prismstumbler
+}
diff --git a/recipes/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb b/recipes/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb
new file mode 100644
index 0000000000..b7c71002af
--- /dev/null
+++ b/recipes/prismstumbler/prismstumbler_0.7.3+0.7.4pre1.bb
@@ -0,0 +1,46 @@
+SECTION = "x11/network"
+PR = "r3"
+
+PACKAGES = "${PN}-dbg prismstumbler prismstumbler-frontend prismstumbler-doc"
+DESCRIPTION = "Prismstumbler wireless LAN scanner"
+DESCRIPTION_prismstumbler-frontend = "Prismstumbler wireless LAN scanner GTK frontend"
+LICENSE = "GPL"
+DEPENDS = "libpcap gtk+ wireless-tools sqlite zlib dbus-glib gpsd"
+RDEPENDS = "wireless-tools"
+RRECOMMENDS = "gpsd"
+
+SRC_URI = "http://projects.linuxtogo.org/frs/download.php/14/${PN}-0.7.4pre1.tar.gz \
+ file://gpsapi.patch;patch=1 \
+ file://wireless.patch;patch=1 \
+ file://fix-includes.patch;patch=1;pnum=0"
+
+S = "${WORKDIR}/${PN}-0.7.4pre1"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--x-includes=${STAGING_INCDIR}/X11 \
+ --x-libraries=${STAGING_LIBDIR} \
+ --with-libgps=${STAGING_EXECPREFIXDIR} \
+ --with-libpcap=${STAGING_EXECPREFIXDIR} \
+ --with-sqlite-includes=${STAGING_INCDIR} \
+ --with-sqlite-libs=${STAGING_LIBDIR} \
+ --without-athena --enable-dbus \
+ --with-libiw=${STAGING_EXECPREFIXDIR}"
+CFLAGS =+ "-I${S}/include"
+LDFLAGS += "-lz"
+
+# Ugly hack to find libstdc++ for libgps
+EXTRA_OEMAKE_append = 'CCLD="${CXX}"'
+
+FILES_${PN} = "${bindir}/prismstumbler"
+
+FILES_prismstumbler-frontend = "${bindir}/psfront ${bindir}/pst \
+ ${datadir}/applications \
+ ${datadir}/pixmaps ${docdir}/prismstumbler/help.txt \
+ ${sysconfdir}"
+RDEPENDS_prismstumbler-frontend = "${PN}"
+
+
+do_install_append() {
+ chmod a+s ${D}${bindir}/prismstumbler
+}
diff --git a/recipes/prismstumbler/prismstumbler_0.7.3.bb b/recipes/prismstumbler/prismstumbler_0.7.3.bb
new file mode 100644
index 0000000000..5bddcf31b6
--- /dev/null
+++ b/recipes/prismstumbler/prismstumbler_0.7.3.bb
@@ -0,0 +1,65 @@
+SECTION = "x11/network"
+PR = "r5"
+
+PACKAGES = "${PN}-dbg prismstumbler prismstumbler-frontend prismstumbler-doc"
+DESCRIPTION = "Prismstumbler wireless LAN scanner"
+LICENSE = "GPL"
+DEPENDS = "libpcap gtk+ wireless-tools sqlite zlib libxpm"
+RDEPENDS = "wireless-tools"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/prismstumbler/${PN}-${PV}.tar.bz2 \
+ file://bogoconf.patch;patch=1 \
+ file://crosscompile.patch;patch=1 \
+ file://libz.patch;patch=1;pnum=0 \
+ file://wireless.patch;patch=1"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--x-includes=${STAGING_INCDIR}/X11 \
+ --x-libraries=${STAGING_LIBDIR} \
+ --with-libpcap=${STAGING_EXECPREFIXDIR} \
+ --with-sqlite-includes=${STAGING_INCDIR} \
+ --with-sqlite-libs=${STAGING_LIBDIR} \
+ --without-athena \
+ --without-motif"
+
+CFLAGS =+ "-I${S}/include -D_GNU_SOURCE"
+
+FILES_${PN} = "${bindir}/prismstumbler"
+
+FILES_prismstumbler-frontend = "${bindir}/psfront ${bindir}/pst \
+ ${datadir}/applications \
+ ${datadir}/pixmaps ${docdir}/prismstumbler/help.txt \
+ ${sysconfdir}"
+RDEPENDS_prismstumbler-frontend = "${PN}"
+
+do_configure() {
+ autotools_do_configure
+ cd ${S}/src/gpsd
+ autoreconf
+ rm -f Makefile config.log config.cache
+ ${S}/src/gpsd/configure \
+ --build=${BUILD_SYS} \
+ --host=${HOST_SYS} \
+ --target=${TARGET_SYS} \
+ --prefix=${prefix} \
+ --exec_prefix=${exec_prefix} \
+ --bindir=${bindir} \
+ --sbindir=${sbindir} \
+ --libexecdir=${libexecdir} \
+ --datadir=${datadir} \
+ --sysconfdir=${sysconfdir} \
+ --sharedstatedir=${sharedstatedir} \
+ --localstatedir=${localstatedir} \
+ --libdir=${libdir} \
+ --includedir=${includedir} \
+ --oldincludedir=${oldincludedir} \
+ --infodir=${infodir} \
+ --mandir=${mandir} \
+ ${EXTRA_OECONF} \
+ $@;
+}
+
+do_install_append() {
+ chmod a+s ${D}${bindir}/prismstumbler
+}