aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pth/files
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2009-04-06 12:16:20 +0000
committerJeremy Lainé <jeremy.laine@m4x.org>2009-04-06 12:16:20 +0000
commitfd2069004f0d17c0edd3dd4130a58419d6b524ad (patch)
tree2a5cb1f7e9c617733f72742033b658fc85cebe68 /recipes/pth/files
parent42b3663b07fedb2e7bd19328fbc872cc561b3ac0 (diff)
downloadopenembedded-fd2069004f0d17c0edd3dd4130a58419d6b524ad.tar.gz
pth: use LDFLAGS (fixes QA error)
Diffstat (limited to 'recipes/pth/files')
-rw-r--r--recipes/pth/files/ldflags.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/pth/files/ldflags.patch b/recipes/pth/files/ldflags.patch
new file mode 100644
index 0000000000..9537ca8e19
--- /dev/null
+++ b/recipes/pth/files/ldflags.patch
@@ -0,0 +1,16 @@
+diff -urN pth-2.0.2.orig/Makefile.in pth-2.0.2/Makefile.in
+--- pth-2.0.2.orig/Makefile.in 2004-07-13 10:48:10.000000000 +0000
++++ pth-2.0.2/Makefile.in 2009-04-06 12:12:37.000000000 +0000
+@@ -168,10 +168,10 @@
+
+ # build the static and possibly shared libraries
+ libpth.la: $(LOBJS)
+- $(LIBTOOL) --mode=link --quiet $(CC) -o libpth.la $(LOBJS) \
++ $(LIBTOOL) --mode=link --quiet $(CC) $(LDFLAGS) -o libpth.la $(LOBJS) \
+ -rpath $(libdir) -version-info `$(SHTOOL) version -lc -dlibtool $(_VERSION_FILE)`
+ libpthread.la: pthread.lo $(LOBJS)
+- $(LIBTOOL) --mode=link --quiet $(CC) -o libpthread.la pthread.lo $(LOBJS) \
++ $(LIBTOOL) --mode=link --quiet $(CC) $(LDFLAGS) -o libpthread.la pthread.lo $(LOBJS) \
+ -rpath $(libdir) -version-info `$(SHTOOL) version -lc -dlibtool $(_VERSION_FILE)`
+
+ # build the manual pages