summaryrefslogtreecommitdiffstats
path: root/recipes/pulseaudio/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/pulseaudio/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/pulseaudio/files')
-rw-r--r--recipes/pulseaudio/files/asound.conf.pulseaudio7
-rw-r--r--recipes/pulseaudio/files/disable-using-glibc-tls.patch25
-rw-r--r--recipes/pulseaudio/files/fix-dbus-without-hal.patch15
-rw-r--r--recipes/pulseaudio/files/fix-shm.patch20
-rw-r--r--recipes/pulseaudio/files/gcc4-compile-fix.patch18
-rw-r--r--recipes/pulseaudio/files/volatiles.04_pulse2
6 files changed, 87 insertions, 0 deletions
diff --git a/recipes/pulseaudio/files/asound.conf.pulseaudio b/recipes/pulseaudio/files/asound.conf.pulseaudio
new file mode 100644
index 0000000000..71f01f2c3c
--- /dev/null
+++ b/recipes/pulseaudio/files/asound.conf.pulseaudio
@@ -0,0 +1,7 @@
+pcm.pulse {
+ type pulse
+}
+
+ctl.pulse {
+ type pulse
+}
diff --git a/recipes/pulseaudio/files/disable-using-glibc-tls.patch b/recipes/pulseaudio/files/disable-using-glibc-tls.patch
new file mode 100644
index 0000000000..31d147be7d
--- /dev/null
+++ b/recipes/pulseaudio/files/disable-using-glibc-tls.patch
@@ -0,0 +1,25 @@
+Index: pulseaudio-0.9.9/configure.ac
+===================================================================
+--- pulseaudio-0.9.9.orig/configure.ac 2008-01-24 01:06:06.000000000 +0000
++++ pulseaudio-0.9.9/configure.ac 2008-02-05 17:45:59.000000000 +0000
+@@ -139,8 +139,8 @@
+ ret=$?
+ rm -f conftest.o conftest
+ if test $ret -eq 0 ; then
+- AC_DEFINE([HAVE_TLS_BUILTIN], 1, [Have __thread().])
+- AC_MSG_RESULT([yes])
++dnl AC_DEFINE([HAVE_TLS_BUILTIN], 1, [Have __thread().])
++ AC_MSG_RESULT([no])
+ else
+ AC_MSG_RESULT([no])
+ fi
+@@ -325,8 +325,7 @@
+ rm -f conftest.o conftest
+
+ if test $ret -eq 0 ; then
+- AC_DEFINE([HAVE_PTHREAD_PRIO_INHERIT], 1, [Have PTHREAD_PRIO_INHERIT.])
+- AC_MSG_RESULT([yes])
++ AC_MSG_RESULT([no])
+ else
+ AC_MSG_RESULT([no])
+ fi
diff --git a/recipes/pulseaudio/files/fix-dbus-without-hal.patch b/recipes/pulseaudio/files/fix-dbus-without-hal.patch
new file mode 100644
index 0000000000..f8ac5674a6
--- /dev/null
+++ b/recipes/pulseaudio/files/fix-dbus-without-hal.patch
@@ -0,0 +1,15 @@
+Index: pulseaudio-0.9.8/src/Makefile.am
+===================================================================
+--- pulseaudio-0.9.8.orig/src/Makefile.am
++++ pulseaudio-0.9.8/src/Makefile.am
+@@ -1424,8 +1424,8 @@
+ # HAL
+ libdbus_util_la_SOURCES = modules/dbus-util.c modules/dbus-util.h
+ libdbus_util_la_LDFLAGS = -avoid-version
+-libdbus_util_la_LIBADD = $(AM_LIBADD) $(HAL_LIBS) libpulsecore.la
+-libdbus_util_la_CFLAGS = $(AM_CFLAGS) $(HAL_CFLAGS)
++libdbus_util_la_LIBADD = $(AM_LIBADD) $(HAL_LIBS) $(DBUS_LIBS) libpulsecore.la
++libdbus_util_la_CFLAGS = $(AM_CFLAGS) $(HAL_CFLAGS) $(DBUS_CFLAGS)
+
+ module_hal_detect_la_SOURCES = modules/module-hal-detect.c
+ module_hal_detect_la_LDFLAGS = -module -avoid-version
diff --git a/recipes/pulseaudio/files/fix-shm.patch b/recipes/pulseaudio/files/fix-shm.patch
new file mode 100644
index 0000000000..3bf61d0d34
--- /dev/null
+++ b/recipes/pulseaudio/files/fix-shm.patch
@@ -0,0 +1,20 @@
+# fixes building against uclibc
+# fixed upstream, see http://www.pulseaudio.org/ticket/200
+Index: pulseaudio-0.9.9/src/pulsecore/shm.c
+===================================================================
+--- pulseaudio-0.9.9/src/pulsecore/shm.c (revision 1971)
++++ pulseaudio-0.9.9/src/pulsecore/shm.c (revision 2110)
+@@ -319,4 +319,5 @@
+ int pa_shm_cleanup(void) {
+
++#ifdef HAVE_SHM_OPEN
+ #ifdef SHM_PATH
+ DIR *d;
+@@ -376,5 +377,6 @@
+
+ closedir(d);
+-#endif
++#endif /* SHM_PATH */
++#endif /* HAVE_SHM_OPEN */
+
+ return 0;
diff --git a/recipes/pulseaudio/files/gcc4-compile-fix.patch b/recipes/pulseaudio/files/gcc4-compile-fix.patch
new file mode 100644
index 0000000000..34ad026e4d
--- /dev/null
+++ b/recipes/pulseaudio/files/gcc4-compile-fix.patch
@@ -0,0 +1,18 @@
+| fix for more strict syntax compliance in gcc4.x
+| pulsecore/core-util.c: In function 'pa_raise_priority':
+| pulsecore/core-util.c:547: error: label at end of compound statement
+| Signed off: mickey@openmoko.org
+|
+Index: pulseaudio-0.9.6/src/pulsecore/core-util.c
+===================================================================
+--- pulseaudio-0.9.6.orig/src/pulsecore/core-util.c
++++ pulseaudio-0.9.6/src/pulsecore/core-util.c
+@@ -535,7 +535,7 @@ void pa_raise_priority(void) {
+ pa_log_info("Successfully gained high priority class.");
+ #endif
+
+-fail:
++fail:;
+
+ #if defined(HAVE_SYS_CAPABILITY_H)
+ if (caps) {
diff --git a/recipes/pulseaudio/files/volatiles.04_pulse b/recipes/pulseaudio/files/volatiles.04_pulse
new file mode 100644
index 0000000000..5b1998032b
--- /dev/null
+++ b/recipes/pulseaudio/files/volatiles.04_pulse
@@ -0,0 +1,2 @@
+# <type> <owner> <group> <mode> <path> <linksource>
+d pulse pulse 0755 /var/run/pulse none