aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-imaging
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/python/python-imaging
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/python/python-imaging')
-rw-r--r--recipes/python/python-imaging/path.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/python/python-imaging/path.patch b/recipes/python/python-imaging/path.patch
new file mode 100644
index 0000000000..1dc467a56d
--- /dev/null
+++ b/recipes/python/python-imaging/path.patch
@@ -0,0 +1,37 @@
+Index: Imaging-1.1.5/setup.py
+===================================================================
+--- Imaging-1.1.5.orig/setup.py 2005-03-23 19:16:40.000000000 +0100
++++ Imaging-1.1.5/setup.py 2006-05-31 14:36:07.000000000 +0200
+@@ -28,12 +28,13 @@
+ #
+ # TIFF_ROOT = libinclude("/opt/tiff")
+
+-FREETYPE_ROOT = None
+-JPEG_ROOT = None
++FREETYPE_ROOT = os.environ['STAGING_LIBDIR'], os.environ['STAGING_INCDIR']
++JPEG_ROOT = os.environ['STAGING_LIBDIR']
+ TIFF_ROOT = None
+-ZLIB_ROOT = None
++ZLIB_ROOT = os.environ['STAGING_LIBDIR']
+ TCL_ROOT = None
+
++
+ # FIXME: add mechanism to explicitly *disable* the use of a library
+
+ # --------------------------------------------------------------------
+@@ -175,15 +176,6 @@
+ add_directory(include_dirs, include_root)
+
+ #
+- # add standard directories
+-
+- add_directory(library_dirs, "/usr/local/lib")
+- add_directory(include_dirs, "/usr/local/include")
+-
+- add_directory(library_dirs, "/usr/lib")
+- add_directory(include_dirs, "/usr/include")
+-
+- #
+ # insert new dirs *before* default libs, to avoid conflicts
+ # between Python PYD stub libs and real libraries
+