aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-native_2.6.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/python/python-native_2.6.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/python/python-native_2.6.1.bb')
-rw-r--r--recipes/python/python-native_2.6.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/python/python-native_2.6.1.bb b/recipes/python/python-native_2.6.1.bb
new file mode 100644
index 0000000000..3ae48285b1
--- /dev/null
+++ b/recipes/python/python-native_2.6.1.bb
@@ -0,0 +1,28 @@
+require python.inc
+DEPENDS = "openssl-native bzip2-full-native"
+
+SRC_URI = "\
+ http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
+ file://00-fix-bindir-libdir-for-cross.patch;patch=1 \
+ file://04-default-is-optimized.patch;patch=1 \
+ file://10-distutils-fix-swig-parameter.patch;patch=1 \
+ file://11-distutils-never-modify-shebang-line.patch;patch=1 \
+ file://12-distutils-prefix-is-inside-staging-area.patch;patch=1 \
+"
+S = "${WORKDIR}/Python-${PV}"
+
+inherit native
+
+prefix = "${STAGING_DIR_NATIVE}/${layout_prefix}"
+exec_prefix = "${STAGING_DIR_NATIVE}/${layout_exec_prefix}"
+
+EXTRA_OEMAKE = '\
+ BUILD_SYS="" \
+ HOST_SYS="" \
+ STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
+ STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
+'
+
+do_stage_append() {
+ install -m 0755 Parser/pgen ${STAGING_BINDIR_NATIVE}/pgen
+}